none
Internet Explorer 9 Not working after installing on Vista Home Basic SP2.

    Question

  • I've installed and uninstalled 3 times IE 9.  Every time I try to run it, IE opens, but then I get a message saying that "internet explorer has stopped working, looking for solutions".  I click close program, and it gets caught in this loop.  It tries to reopen and look for solutions over and over again.  I have Vista Home Basic sp2 will all the updates, but I'm still having a problem.  Is IE 9 worth the headache and frustration?  Any assistance would be appreciated
    Saturday, April 09, 2011 1:12 AM

Answers

  •  

     

    I have the same problem running Vista Business 64bit Service Pack 2. Some computers with Vista I have got IE9 running, others not. IE9 does not play well with the widgets. Calendar breaks, for instance, on all machines that have IE9 installed, whether working or not. Try going from a month view to a day view - you cannot. I have tried disabling gadgets, but no luck - "Internet Explorer has stopped working".

    Was this release beta tested?

    Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    iexplore.exe
      Application Version:    9.0.8112.16421
      Application Timestamp:    4d76255d
      Fault Module Name:    igdumdx32.dll
      Fault Module Version:    8.15.10.2302
      Fault Module Timestamp:    4d558979
      Exception Code:    c0000005
      Exception Offset:    00009754
      OS Version:    6.0.6002.2.2.0.256.6
      Locale ID:    1033
      Additional Information 1:    7b6b
      Additional Information 2:    a6395874b5f63d3fdceb12d34bca881d
      Additional Information 3:    9cde
      Additional Information 4:    cf6d078a04c4a820b8a6931f2462f706



    IE9 will work on this machine in safe mode. It crashes when applying a clean boot. - clean boot error below:

    Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    iexplore.exe
      Application Version:    9.0.8112.16421
      Application Timestamp:    4d76255d
      Fault Module Name:    igdumdx32.dll
      Fault Module Version:    8.15.10.2302
      Fault Module Timestamp:    4d558979
      Exception Code:    c0000005
      Exception Offset:    00009754
      OS Version:    6.0.6002.2.2.0.256.6
      Locale ID:    1033
      Additional Information 1:    320d
      Additional Information 2:    4edd9d66ee480f698f7a8471ff5bf4c7
      Additional Information 3:    e4d0
      Additional Information 4:    771afbc01915626e232981dac36172e3


    Interestingly, I have another Vista Business 64bit machine - and IE9 runs fine on that. I have compared all services, etc., between the two machines. The main difference I can find is our graphics set up. I am running Intel(R) G45/G43 express chipset from the Mobo on the machine that will not run IE9. The machine that runs IE9 has different graphics cards. When in safe mode, my graphics display is basically off - and IE9 works. In clean boot - with services disabled - I have good graphics display - but no IE9. This would greatly surprise me if a graphics card had anything to do with it.

    ++++++++++++++++++++++++++++++

    I take that back. Look at what is common to both error message -- Fault Module Name: igdumdx32.dll

    Google igdumdx32.dll and you will soon see this is the Intel Graphics driver. This is most likely what is breaking my installation of IE9

    ++++++++++++++++++++++++++++++

    I have fixed my computer. I found two ways to make IE9 work on my machine. One is to boot into safe mode w/networking, and call IE9. Go to Internet Options -> Advanced -> Where it says 'Accelerated Graphics' click the checkbox that says 'Use software rendering instead of GPU rendering.' Reboot, and Oila! IE9 works on my machine.

    I then undid everything, and rebooted again. Then in Device Manager I uninstalled (but did not delete) my graphics driver. Then I rebooted. Upon reboot -the graphics driver was reinstalled - Oila! IE9 works on my machine.

    • Proposed as answer by rpruitt625 Thursday, April 28, 2011 3:51 AM
    • Marked as answer by SMB1976 Friday, April 29, 2011 1:02 AM
    Wednesday, April 27, 2011 12:50 PM

All replies

  • I have the same problem.

    I had to uninstall IE9 and back to IE8. Looking forward to a solution.

    Tuesday, April 12, 2011 9:14 AM
  • Hi,

     

    Would you please let me know if the issue occurred on IE8? The issue could be affected by third party add-ons or corrupted Internet Explorer components.

     

    I suggest booting into Safe Mode and running IE with no add-ons.

     

    Click Start -> All Programs -> Accessories -> System Tools -> Internet Explorer (with no add-ons)

     

    If the issue disappears, please perform the Clean Boot to narrow down the issue.

     

    If the issue persists, it could be corrupted IE components. I suggest reinstalling IE and running SFC to check the result.

     

    Reinstalling the Internet Explorer 8:

    ----------------------------

    1. Go to Start and in the search type Turn Windows features On or Off.

    2. Click on "Turn Windows features On or Off".

    3. Browse to the Internet Explorer 8 and uncheck the mark in front of it.

    4. Restart the computer

    5. Go the check the mark in front of Internet Explorer to reinstall it.

    6. After that, you need to reinstall IE9 again.

     

    http://windows.microsoft.com/en-US/internet-explorer/products/ie/home

     

    System File Checker

    http://support.microsoft.com/kb/929833

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, April 12, 2011 9:26 AM
    Moderator
  • Hi,

     

    Would you please let me know if the issue occurred on IE8? The issue could be affected by third party add-ons or corrupted Internet Explorer components.

     

    I suggest booting into Safe Mode and running IE with no add-ons.

     

    Click Start -> All Programs -> Accessories -> System Tools -> Internet Explorer (with no add-ons)

     

    If the issue disappears, please perform the Clean Boot to narrow down the issue.

     

    If the issue persists, it could be corrupted IE components. I suggest reinstalling IE and running SFC to check the result.

     

    Reinstalling the Internet Explorer 8:

    ----------------------------

    1. Go to Start and in the search type Turn Windows features On or Off.

    2. Click on "Turn Windows features On or Off".

    3. Browse to the Internet Explorer 8 and uncheck the mark in front of it.

    4. Restart the computer

    5. Go the check the mark in front of Internet Explorer to reinstall it.

    6. After that, you need to reinstall IE9 again.

     

    http://windows.microsoft.com/en-US/internet-explorer/products/ie/home

     

    System File Checker

    http://support.microsoft.com/kb/929833

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    I unisntalled IE9 and went back to IE8.  IE was working.  I reinstalled IE9, and had the same problem.  I uninstalled IE9 again and uninstalled IE8.  From IE7 I installed IE8 and then IE9 again.  Still had the same problem.  When I went into safe boot and ran IE without add ons while IE9 was still installed, I was able to go on to the internet.  I followed the instructions for the clean boot.  Once everything was unchecked, I tried IE9 and it still didn't run.  I ran the SFC checker.  Here is what it said"  2011-04-23 18:28:59, Info                  CSI    00000301 [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-04-23 18:29:04, Info                  CSI    00000303 [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-04-23 18:32:02, Info                  CSI    00000382 [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-04-23 18:32:02, Info                  CSI    00000384 [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-04-23 18:56:31, Info                  CSI    0000015e [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-04-23 18:56:36, Info                  CSI    00000160 [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-04-23 18:59:21, Info                  CSI    000001df [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2011-04-23 18:59:21, Info                  CSI    000001e1 [SR] Cannot repair member file [l:24{12}]"settings.ini" of Microsoft-Windows-Sidebar, Version = 6.0.6002.18005, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch

     I have also tried going into internet options and reset Internet Explorer Settings, but it still did not fix it.

    IE9 is working fine on my PC with Windows 7, but my laptop with Vista Home Basic SP2 is unable to run IE 9 without the error message "Internet Explorer has stopped working".  If you can find another solution, I would greatly appreciate it.  Thank you.


    Saturday, April 23, 2011 10:45 PM
  •  

     

    I have the same problem running Vista Business 64bit Service Pack 2. Some computers with Vista I have got IE9 running, others not. IE9 does not play well with the widgets. Calendar breaks, for instance, on all machines that have IE9 installed, whether working or not. Try going from a month view to a day view - you cannot. I have tried disabling gadgets, but no luck - "Internet Explorer has stopped working".

    Was this release beta tested?

    Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    iexplore.exe
      Application Version:    9.0.8112.16421
      Application Timestamp:    4d76255d
      Fault Module Name:    igdumdx32.dll
      Fault Module Version:    8.15.10.2302
      Fault Module Timestamp:    4d558979
      Exception Code:    c0000005
      Exception Offset:    00009754
      OS Version:    6.0.6002.2.2.0.256.6
      Locale ID:    1033
      Additional Information 1:    7b6b
      Additional Information 2:    a6395874b5f63d3fdceb12d34bca881d
      Additional Information 3:    9cde
      Additional Information 4:    cf6d078a04c4a820b8a6931f2462f706



    IE9 will work on this machine in safe mode. It crashes when applying a clean boot. - clean boot error below:

    Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    iexplore.exe
      Application Version:    9.0.8112.16421
      Application Timestamp:    4d76255d
      Fault Module Name:    igdumdx32.dll
      Fault Module Version:    8.15.10.2302
      Fault Module Timestamp:    4d558979
      Exception Code:    c0000005
      Exception Offset:    00009754
      OS Version:    6.0.6002.2.2.0.256.6
      Locale ID:    1033
      Additional Information 1:    320d
      Additional Information 2:    4edd9d66ee480f698f7a8471ff5bf4c7
      Additional Information 3:    e4d0
      Additional Information 4:    771afbc01915626e232981dac36172e3


    Interestingly, I have another Vista Business 64bit machine - and IE9 runs fine on that. I have compared all services, etc., between the two machines. The main difference I can find is our graphics set up. I am running Intel(R) G45/G43 express chipset from the Mobo on the machine that will not run IE9. The machine that runs IE9 has different graphics cards. When in safe mode, my graphics display is basically off - and IE9 works. In clean boot - with services disabled - I have good graphics display - but no IE9. This would greatly surprise me if a graphics card had anything to do with it.

    ++++++++++++++++++++++++++++++

    I take that back. Look at what is common to both error message -- Fault Module Name: igdumdx32.dll

    Google igdumdx32.dll and you will soon see this is the Intel Graphics driver. This is most likely what is breaking my installation of IE9

    ++++++++++++++++++++++++++++++

    I have fixed my computer. I found two ways to make IE9 work on my machine. One is to boot into safe mode w/networking, and call IE9. Go to Internet Options -> Advanced -> Where it says 'Accelerated Graphics' click the checkbox that says 'Use software rendering instead of GPU rendering.' Reboot, and Oila! IE9 works on my machine.

    I then undid everything, and rebooted again. Then in Device Manager I uninstalled (but did not delete) my graphics driver. Then I rebooted. Upon reboot -the graphics driver was reinstalled - Oila! IE9 works on my machine.

    • Proposed as answer by rpruitt625 Thursday, April 28, 2011 3:51 AM
    • Marked as answer by SMB1976 Friday, April 29, 2011 1:02 AM
    Wednesday, April 27, 2011 12:50 PM
  • Thank you so much.  This resolved my issue.  I followed your directions to a "T" and I am now able to surf the net on IE9 through windows Vista without the horrible loop.  Thank you for your hard work and determination.  You are awesome.
    Friday, April 29, 2011 1:07 AM
  • Thanks!

    Interestingly, I almost never use Internet Explorer. I am a Firefox fan.

    I have never had a problem with a Firefox update.

    Friday, April 29, 2011 3:26 AM
  • This worked for me well done and thankyou.
    • Proposed as answer by rootyosi Sunday, May 29, 2011 8:22 PM
    • Unproposed as answer by SMB1976 Monday, May 30, 2011 9:05 PM
    Sunday, May 01, 2011 12:10 PM
  • Thank you, this saved a lot of time and effort

    Tuesday, May 24, 2011 2:07 PM
  • On a Compaq laptop with Windows Home this did the trick. Now however can't uncheck the software rendering. But what the heck. As long as IE9 works fine I am as happy as a baby boy! Thanks for this advice. I was at a loss as on many other PC's I have installed IE9 without any hick-up.
    Sunday, May 29, 2011 1:38 PM
  • I used you first solution!  It worked!!!!  Thank you! Thank you! Thank you!
    Sunday, May 29, 2011 8:06 PM
  • rpruitt you are the MAN!!
    Thursday, June 09, 2011 12:00 AM
  • My daughter had same problem on her HP laptop running Vista 32 bit Home Premium.

    Opened Internet options from Start Search menu, went to Advanced tab, checked top box "Allow Software Rendering" - worked straight away no reboot or clean loads or anything - much simpler for me anyway



    • Proposed as answer by EJRW Wednesday, June 29, 2011 9:06 PM
    • Unproposed as answer by SMB1976 Wednesday, June 29, 2011 10:54 PM
    • Proposed as answer by thoughtfulmom Wednesday, September 07, 2011 7:05 AM
    Wednesday, June 29, 2011 9:04 PM
  • My daughter had same problem on her HP laptop running Vista 32 bit Home Premium.

    Opened Internet options from Start Search menu, went to Advanced tab, checked top box "Allow Software Rendering" - worked straight away no reboot or clean loads or anything - much simpler for me anyway




    The problem we were having is that we could not do anything within IE9.  The error messages wouldn't allow you to do access any options due to the influx of error messages.  I'm glad the simple route worked for you, but for the majority, the answer from rpruitt625 would be more helpful.
    Wednesday, June 29, 2011 10:56 PM
  • rpruitt625- Thanks for the fix.  IE9 has been sitting in my windows update for quite a while because over the past few months, been having the same problem.  Always got that loop error when I would upgrade to IE9 so I would uninstall and go back to IE8.  I mainly use Google Chrome because IE is slow.  I do trust IE when I do more secure stuff.   
    Saturday, July 23, 2011 5:53 AM
  • Thank you so much.. you saved me from reinstalling the OS
    Monday, July 25, 2011 4:33 AM
  • IE9 should of never been released as it is very buggy and constantly closes for no reason. Just recently it has disabled java and flash on my laptop so i have had to roll back to IE8 until thiese issues are resolved.

     

    Friday, July 29, 2011 7:19 AM
  • My daughter had same problem on her HP laptop running Vista 32 bit Home Premium.

    Opened Internet options from Start Search menu, went to Advanced tab, checked top box "Allow Software Rendering" - worked straight away no reboot or clean loads or anything - much simpler for me anyway



    This worked GREAT!!! THANK YOU!!! So much easier than rebooting the computer!

     

    You don't have to have internet explorer page open in order to do this. Open the start menu and type in internet options into the search box. It will open the internet options box. Go to the advanced tab. I clicked the top box which said "allow software rendering instead of GPU rendering". Hit apply and the when I clicked on the internet explorer it opened right up! I have been working on this forEVER! Thanks again!!


    • Proposed as answer by thoughtfulmom Wednesday, September 07, 2011 7:06 AM
    • Edited by thoughtfulmom Wednesday, September 07, 2011 7:06 AM
    Wednesday, September 07, 2011 7:05 AM
  • My mother's computer an HP DV6700 AMD Turion 64 X2 running Vista 32 bit SP2 had the problem where everytime you bring up an internet explorer browser it would come up internet explorer cannot display webpage. I knew it had to have something to do with internet explorer because firefox would run. I finally figured out that when you go in to Internet options > advanced settings and not just reset the settings but restore advanced settings! I hope this helps someone else! Now back to working on why my Ubuntu quit working after an update? ~Droopyd99 out
    Thursday, April 12, 2012 8:30 PM
  • Scratch that It didn't work!
    Thursday, April 12, 2012 10:25 PM
  • My daughter had same problem on her HP laptop running Vista 32 bit Home Premium.

    Opened Internet options from Start Search menu, went to Advanced tab, checked top box "Allow Software Rendering" - worked straight away no reboot or clean loads or anything - much simpler for me anyway



    Thanks EJRW!  Your method worked for me on HP Mini-PC (netbook) model HP2133 that has very weak S3 graphics and weak VIA CPU.

    Asus P5N32-E SLI mobo, C2D E8400 @3GHz, 4x 1GB PC2-8500 OCZ DDR2, Asus EN8800GT/512MB, dual-boot Win7 x64 & PCLinuxOS 2010

    • Proposed as answer by BMaytum Monday, June 11, 2012 4:37 PM
    Monday, June 11, 2012 4:37 PM
  • I know this article is old, but thank you.  I found this exact problem on another DG43GT Intel motherboard.  The 'Use software rendering instead of GPU rendering' setting was the trick.  It has a weak on-board graphics controller. 
    Saturday, November 03, 2012 10:09 PM
  •  Bro its amazing , in so easy step you made IE9 working on vista machine .

    Keep the good work!

    Thursday, October 03, 2013 3:49 PM