locked
Connecting to VPN before logon, option missing in Windows 10 RRS feed

  • Question

  • Hello

    I'm having some problems with Windows 10 Pro, and one of them is configuring VPN so it gives me the option to connect to vpn before I login into Windows.

    To make it clear, I want to have the option to connect to vpn. I do not want to connect to VPN every time my Notebook starts.

    I have no problems with setting up the VPN connection(Windows Application and Dell SonicWall NetExtender) and I can connect to my destination network.

    I want to be able to connect to the VPN before I log on the laptop, which should be possible. On Windows 7 and 8.1 it was easy to configure and there are a lot of guides on how to do it, but I did not found any for Windows 10.

    In the logon screen, there is a icon for the Networks, where you can connect to WiFi etc.

    I had the option to connect to VPN in previous versions, but now its missing, even after I tried the solutions which Iam used to use for Windows 7 and 8.1 to make this option appear.

    I have removed and configured the VPN connection a number of times now, and still it's not on the logon screen. It appears when I'm on the desktop but not before I'm logged on.

    Is there a option that I'm missing, which allows the VPN connection to be visible at the logon screen??

    In older Windows version I could choose the option "allow all user on this pc to use vpn" but since Windows 10, this option is gone.

    I hope someone is able to help me.

    Thanks in advance Jurez




    • Edited by JurezIT Wednesday, March 2, 2016 9:54 AM to make my problem more understandable
    Wednesday, March 2, 2016 7:48 AM

All replies

  • Connect VPN before Logon

    S.Sengupta, Windows Experience MVP

    Wednesday, March 2, 2016 8:18 AM
  • Hello, thanks for your reply but I have already seen this Thread and tried what they suggested. It does not work for Windows 10, for me at least it does not.
    • Edited by JurezIT Wednesday, March 2, 2016 8:36 AM
    Wednesday, March 2, 2016 8:35 AM
  • Hi JurezIT,

    Are you using the built-in VPV?

    "In older Windows version I could choose the option "allow all user on this pc to use vpn" but since Windows 10, this option is go"

    We could configure the VPN here (Control Panel\All Control Panel Items\Network and Sharing Center\Setup a new connection) and that option will be available.

    According to my test, the startup script method included in the link as S.Sengupta posted  would work well. Please ensure the script could run well manually before we configured it as startup script.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, March 3, 2016 8:51 AM
  • Hello MeipoXu,

    the thing is, with this script VPN will be enabled/connect every time I start.

    What I am looking for, is to be able to enable it manually before I want to login into Windows. So it should not be connect every time I start my Notebook. I want the possibility to connect from the login screen, when needed.

    I hope this makes my problem more clear.

    What I do not want is what this script does, Automatically connect to VPN whenever my Notebook is on.

    Under Win 7 and 8.1 I had this option.





    • Edited by JurezIT Thursday, March 3, 2016 1:46 PM
    Thursday, March 3, 2016 1:44 PM
  • Hi JurezIT,

    Are you using the built-in VPN?

    "What I am looking for, is to be able to enable it manually before I want to login into Windows"

    According to my test, I am afraid that is on longer available on Windows 10. We should login the machine then connect the VPN.

    "What I do not want  is what this script does, Automatically connect to VPN whenever my Notebook is on"
    If the VPN will connect automatically during the startup process, for a normal situation we should connect to VPN manually after login. Please check whether you have configured the startup script or logon script. In addition, please remove the related startup entry with the AutoRun tool.
    Autoruns for Windows v13.51
    https://technet.microsoft.com/en-us/sysinternals/bb963902.aspx?f=255&MSPPError=-2147217396

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, March 4, 2016 6:22 AM
  • Hi MeipoXu,

    thank you for your help. Sad to hear that VPN before Logon is not possible anymore.

    My customer seems very happy that Windows 10, the Future oriented operating system is not able to provide features, which he used for years in the older windows versions.

    Anyway thank you for your time and effort.



    • Edited by JurezIT Monday, March 7, 2016 7:58 AM
    Monday, March 7, 2016 7:45 AM
  • A few things come to mind, I just got my windows 10 VPN going on our network much like you would like to have it done.  You can not use the VPN wizard that most people try to use from the connection page.  you have to go through control panel and then network connection and then setup the VPN that way.  there will be an option to enable the allow all users to connect.  You also need to enable the require Ctr Alt Del option on login page, that is also require. 

    Nino Renzi IT Analyst

    • Proposed as answer by Paul 8ain Wednesday, January 10, 2018 10:06 PM
    Friday, April 22, 2016 8:29 PM
  • That only works for the native Windows provided VPN, not for the NetExtender.
    Friday, September 9, 2016 6:12 PM
  • If they did take it away, there would be a big issue in my mind as several of the Group Policies in my Domain need to apply at logon.  If I can't be connected to my domain before I logon (Via VPN) then I don't get those policies.

    Once I joined the computer to the Domain I was able to connect at logon.  Has to be a GPO that needs to be set.   Can't imagine Microsoft getting rid of that as it would cause a lot of problems in the enterprises I work for. :(

    Tuesday, January 10, 2017 5:19 PM
  • Here is the Fix.

    1. Create Your VPN connection.

    2. Connect to the VPN using the newly created VPN adapter.

    3. Join to the domain.

    4. Reboot

    5. Now you will see the VPN connection button on login.

    Happy Days.

    Wednesday, May 3, 2017 5:44 AM
  • that doesn't work. What on earth are you talking about?
    • Proposed as answer by Mdlf Wednesday, October 18, 2017 7:23 PM
    Tuesday, June 27, 2017 8:27 PM
  • Little late, but maybe this helps

    In PowerShell while logged on domain with a Windows 10 system:

    Add-VpnConnection -Name yourVPNname -ServerAddress yourserver adress -AllUserConnection $true -SplitTunneling $true -AuthenticationMethod MSChapv2 -TunnelType Automatic -EncryptionLevel Required -PassThru

    Then restart your system.

    It will not show the VPN login possibility in the network windows at startup, but you will see a double minitor logo where the power button is at the Windows 10 login screen. This is al local VPN policy and it worked for my organization.

    Hope it helps you or perhaps you already found a solution.

    Wednesday, October 18, 2017 7:30 PM
  • That worked. All the other blather didn't.
    Wednesday, January 10, 2018 10:06 PM
  • you have to check in the box " Allow other people to use this connection" when you create the VPN connection.

    hope it help

    Monday, March 5, 2018 3:47 PM
  • you have to check in the box " Allow other people to use this connection" when you create the VPN connection.

    hope it help

      I am not sure what version of Windows 10 you are using, but in v1709, this option "Allow other people to use this connection" does NOT exist, at least not that I can see.  The "Add a VPN connection" only allows for:

    VPN Provider

    Connection name

    Server name or address

    Type of sign-in info

    User name (optional)

    Password (optional)

    Remember my sign-in info

    Save    Cancel

    I cannot find this option you are talking about.

      The option for remote employees to be able to manually select the option to connect to the VPN before logon is very important in case their cached AD credentials become stale or desynced for any reason.  If this happens the user is then unable to authenticate to any internal domain resources like other user's Outlook calendars or inboxes etc...

    In my opinion, the only way to fix an issue like this would be to have the user use the option from the logon screen to connect to their VPN, and THEN login so that the AD controllers can refresh the authentication tokens.


    Wednesday, April 25, 2018 9:55 AM
  • For what its worth here is how I make this work

    I log in as a user that can log on locally

    Connect to the VPN
    Go to switch users on start and log in as the network user you want.  (VPN is still connected at this point)

    Once your logged in you will need to recreate the vpn for that domain user.
    After you do this the vpn button will be there at logon.


    Aaron Woldman Vision Net Ltd

    Tuesday, May 1, 2018 4:49 PM
  • I am not sure what version of Windows 10 you are using, but in v1709, this option "Allow other people to use this connection" does NOT exist, at least not that I can see.

    I ran into this recently with Server 2016, and it seems to be a byproduct of the transition from the old Control Panel and the new Settings panel.  There's some overlap in what they cover, but the "Allow other people to use this connection" checkbox is ONLY available if you go Control Panel > Network and Sharing Center > Set up a new connection or network and configure the VPN that way.

    If you go Settings > Network > VPN > Add a VPN connection, it is conspicuously absent.
    • Edited by Miles V Thursday, May 3, 2018 1:53 PM Context clarification with quote
    • Proposed as answer by reallybigcatheter Friday, September 27, 2019 4:56 PM
    Thursday, May 3, 2018 1:50 PM
  • Hi <g class="gr_ gr_649 gr-alert gr_spell gr_inline_cards gr_run_anim ContextualSpelling ins-del multiReplace" data-gr-id="649" id="649">AWoldman</g>,

    I ran into this issue when joining a new computer to a domain from a remote location. I could not find or figure by myself how to connect to the VPN before login on with Windows 10 Pro. I read a lot before I got to your post ut as soon as I read it I thought "It has to work !!". Let me tell you, YOU ARE THE MAN. You saved my day. 

    Thank you very much !!!

    Thursday, June 28, 2018 2:24 AM
  • Little late, but maybe this helps

    In PowerShell while logged on domain with a Windows 10 system:

    Add-VpnConnection -Name yourVPNname -ServerAddress yourserver adress -AllUserConnection $true -SplitTunneling $true -AuthenticationMethod MSChapv2 -TunnelType Automatic -EncryptionLevel Required -PassThru

    Then restart your system.

    It will not show the VPN login possibility in the network windows at startup, but you will see a double minitor logo where the power button is at the Windows 10 login screen. This is al local VPN policy and it worked for my organization.

    Hope it helps you or perhaps you already found a solution.

    very late reply  just found this and thanks it has made life a lot easier
    Thursday, October 11, 2018 11:40 PM
  • I had to look through many pages before i found this:

    The VPN icon will not show up at the logon screen if the connection is configured to use machine certificates.

    Wednesday, April 15, 2020 10:33 AM
  • Thats exactly right! In Network and Sharing Center ->
    Set Up a New Connection or Network ->
    Connect to a Workplace ->
    [Configure as Needed] ->
    Check the last box with the shield next to it (Allow other people to use this connection).
    Wednesday, April 15, 2020 10:39 AM