I can't update IE 8 to IE 11 RRS feed

  • Question

  • Hello chaps,

    I have a new install of windows 7, came with IE8 installed. I try and update to IE11 through Windows Update and it fails every time. It also fails if I try and download and install it from microsoft.com

    Any ideas?

    Friday, December 12, 2014 11:28 AM


All replies

  •  fails every time


    Robert Aldwinckle

    Friday, December 12, 2014 1:11 PM
  • Windows update gives me a Code 9C59 error.
    Friday, December 12, 2014 2:52 PM
  • Windows update gives me a Code 9C59 error.

    That's probably a sign of corruption in your WinSxS.  Try CheckSUR.


    Or just find more details in the context of that code where it appears in your logs.

    Robert Aldwinckle

    • Marked as answer by Yolanda Zhu Tuesday, December 23, 2014 3:26 AM
    Friday, December 12, 2014 4:27 PM
  • Windows update gives me a Code 9C59 error.

    You're certainly not alone. See http://goo.gl/ugp9cP & http://goo.gl/JRg6vG

    You will find Consumer-specific support for IE11 in this forum: http://answers.microsoft.com/en-us/ie/forum/ie11-windows_7

    ~Robear Dyer (PA Bear) MS MVP-Windows Client since 2002 Disclaimer: MS MVPs neither represent nor work for Microsoft

    Friday, December 12, 2014 8:56 PM
  • Hi,

    You could try to install the Internet Explorer 11 manually:

    Internet Explorer 11 for Windows 7


    You could click "Change System" button to get the proper version which applied to your computer.

    If it still fail to install, upload the log file to OneDrive and share the link here:

    IE11_main.log file in the Windows folder

    Karen Hu
    TechNet Community Support

    • Marked as answer by Yolanda Zhu Tuesday, December 23, 2014 3:26 AM
    Tuesday, December 16, 2014 9:53 AM
  • i have the same problem(manual installation) .is asking for sp1 ,i have already install sp1  bat ,same sh......t. why
    • Edited by djdeous Monday, September 28, 2015 6:11 PM
    Monday, September 28, 2015 6:08 PM
  • why


    Typically that's a sign that you have something installed but not completely applied.  Again, try CheckSUR?

    Robert Aldwinckle

    Monday, September 28, 2015 7:08 PM
  • I have been having the same problem on my macbook pro running windows 7 with IE 8 via bootcamp. Ive tried over and over. Please help somebody. I also have a corrupt registry that sfc scannow cant fix and cant find how to fix it. Ive tried c cleaner. I have the original windows 7 instal but can it fix the registry without having to erase everything doing a reinstall? Sorry to bounce between multiple issues but there driving me bonkers and i keep getting a chrome and firefox crash daily. If someone would email me at cleverwilliamf@gmail.com and help me I will make it up to u. God bless
    Monday, May 22, 2017 12:44 AM