locked
OWA 2010 'Options' Button not working RRS feed

  • Question

  • When logged in any user the 'Options' button in OWA 2010 (links as /ECP in a browser) just refreshes back to the home /OWA page.

    I have tried recreating the ECP directory in IIS and made sure authentication is the same as the OWA.

    Anyone else found this or can give me a solution???

    THX

    Thursday, May 13, 2010 5:57 PM

Answers

  • Check the RoleAssignmentPolicy attribute for the mailbox and see if the Default Role Assignment Policy is assigned to the user.
    • Proposed as answer by emma.yoyo Thursday, May 20, 2010 2:01 AM
    • Marked as answer by emma.yoyo Friday, May 21, 2010 3:35 AM
    Thursday, May 13, 2010 6:20 PM
  • Hi,

    Add to Abhi,

    please run the cmdlet Get-RoleAssignmentPolicy | fl name,isdefault

    and Get-mailbox "user" | fl RoleAssignmentPolicy

    Please post the results here. But after I make a test, if the RoleAssignmentPolicy attribute for the mailbox is not correct, if you click the "Options" in the OWA, there will be an error message: "Sorry! Access denied".

    So please check the ECP virtual directory-> HTTP redirect, if you Redirect requestion to this destionation:

    eg: https://servername.contoso.com/owa, it will back to the home /OWA page.


    Frank Wang
    • Proposed as answer by emma.yoyo Thursday, May 20, 2010 2:01 AM
    • Marked as answer by emma.yoyo Friday, May 21, 2010 3:35 AM
    Monday, May 17, 2010 7:22 AM
    • Proposed as answer by emma.yoyo Thursday, May 20, 2010 2:01 AM
    • Marked as answer by emma.yoyo Friday, May 21, 2010 3:35 AM
    Monday, May 17, 2010 2:54 PM

All replies

  • Check the RoleAssignmentPolicy attribute for the mailbox and see if the Default Role Assignment Policy is assigned to the user.
    • Proposed as answer by emma.yoyo Thursday, May 20, 2010 2:01 AM
    • Marked as answer by emma.yoyo Friday, May 21, 2010 3:35 AM
    Thursday, May 13, 2010 6:20 PM
  • Hi,

    Add to Abhi,

    please run the cmdlet Get-RoleAssignmentPolicy | fl name,isdefault

    and Get-mailbox "user" | fl RoleAssignmentPolicy

    Please post the results here. But after I make a test, if the RoleAssignmentPolicy attribute for the mailbox is not correct, if you click the "Options" in the OWA, there will be an error message: "Sorry! Access denied".

    So please check the ECP virtual directory-> HTTP redirect, if you Redirect requestion to this destionation:

    eg: https://servername.contoso.com/owa, it will back to the home /OWA page.


    Frank Wang
    • Proposed as answer by emma.yoyo Thursday, May 20, 2010 2:01 AM
    • Marked as answer by emma.yoyo Friday, May 21, 2010 3:35 AM
    Monday, May 17, 2010 7:22 AM
    • Proposed as answer by emma.yoyo Thursday, May 20, 2010 2:01 AM
    • Marked as answer by emma.yoyo Friday, May 21, 2010 3:35 AM
    Monday, May 17, 2010 2:54 PM
  • Any updates?
    Frank Wang
    Wednesday, May 19, 2010 2:04 AM
  • I migrated from E2K7 to 2K10

    OWA is working through ISA server

    Options button is not working

    https://hostE2K10/ECP is working

    Authentication is set to basic authentication

    When I press the options button the page just refreshes the page

    Any other ideas ?

    Friday, July 1, 2011 12:42 PM
  • I have the same problem here. Has anyone been able to resolve the issue?

    I tried the commands from earlier answers, these are the results. Look normal to me though.

    C:\Windows\system32> Get-RoleAssignmentPolicy | fl name,isdefault

    Name      : Default Role Assignment Policy
    IsDefault : True

    [PS] C:\Windows\system32>
    [PS] C:\Windows\system32>Get-mailbox "user1" | fl RoleAssignmentPolicy

    RoleAssignmentPolicy : Default Role Assignment Policy

    Tuesday, July 19, 2011 2:37 PM
  • I had the same issue as well, i resolved this by changing the ecp virtual directory authentication settings. I had to edit the basic authentication settings and add my local domain to the default domain.
    I did this for owa, active sync but forgot to do it for ecp.

    hope this helps someone.

    Friday, May 18, 2012 12:42 AM
  • Same problem.

    We had installed SP2 a month ago and had just gotten Rpc going for Outlook Anywhere. Somehow under http redirect on the Rpc tab in IIS the "Redirect requests to this destination" had gotten checked to redirect back to the main OWA site.

    Unchecked it and voila!



    Peter Andersen

    Friday, January 25, 2013 6:06 PM
  • Same problem however my fix was simple.

    We had installed SP2 a month ago and had just gotten Rpc going for Outlook Anywhere. Somehow under "http redirect on the Rpc tab in IIS" the "Redirect requests to this destination" had gotten checked to redirect back to the main OWA site.

    Unchecked it and voila!


    Peter Andersen

    Friday, January 25, 2013 6:09 PM