none
IE 9 and Adobe Acrobat virtual print failure

    Question

  • Ever since I updated to IE 9 on 05/09/11, I get error "Print driver host for 32bit applications has stopped working" on a third of the web pages I print to the Adobe Acrobat 9 Standard version 9.4.4 (virtual printer driver).

    What is causing this?

    Acrobat has worked fine with IE 8. I have Windows 7 x64.  I'm running the default x86 version of IE.  Acrobat is x86 as well.  Below are the error details:

    ==============================================================================================
    An error has occurred in the script on this page.
    Line 2107
    Char 1
    Error: The data area passed to a system call is too small.
    Code: 0
    URL: res://ieframe.dll/preview.js
    ==============================================================================================
    Problem signature:
      Problem Event Name:   BEX64
      Application Name:     splwow64.exe
      Application Version:  6.1.7600.16385
      Application Timestamp:        4a5bd3ca
      Fault Module Name:    ADUIGP.DLL
      Fault Module Version: 9.2.0.112
      Fault Module Timestamp:       4a8bc9a9
      Exception Offset:     000000000000acf7
      Exception Code:       c000000d
      Exception Data:       0000000000000000
      OS Version:   6.1.7600.2.0.0.256.4
      Locale ID:    1033
      Additional Information 1:     3e0c
      Additional Information 2:     3e0caaea4ecde1510409eea7d6946aff
      Additional Information 3:     b20c
      Additional Information 4:     b20c4f4ebb1dab9ebf80be8887b8c472

    ==============================================================================================
      Faulting application name: splwow64.exe, version: 6.1.7600.16385, time stamp: 0x4a5bd3ca
      Faulting module name: ADUIGP.DLL, version: 9.2.0.112, time stamp: 0x4a8bc9a9
      Exception code: 0xc000000d
      Fault offset: 0x000000000000b667
      Faulting process id: 0x1aac
      Faulting application start time: 0x01cc13c3ac9bda32
      Faulting application path: C:\Windows\splwow64.exe
      Faulting module path: C:\Windows\system32\spool\DRIVERS\x64\3\ADUIGP.DLL
    Report Id: fd63ffb1-7fb6-11e0-8e69-e0cb4ec8fc28
    ==============================================================================================
    Fault bucket , type 0
    Event Name: BEX64
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: splwow64.exe
    P2: 6.1.7600.16385
    P3: 4a5bd3ca
    P4: ADUIGP.DLL
    P5: 9.2.0.112
    P6: 4a8bc9a9
    P7: 000000000000b667
    P8: c000000d
    P9: 0000000000000000
    P10:

    Attached files:

    These files may be available here:
    C:\Users\Robert Cody\AppData\Local\Microsoft\Windows\WER\ReportArchive\AppCrash_splwow64.exe_bcebb6566c91cf2fdc24bad61ee89b6cade4dac_04349168

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: fd63ffb1-7fb6-11e0-8e69-e0cb4ec8fc28
    Report Status: 0

    Monday, May 16, 2011 1:01 PM

All replies

  • Hi,

     

    This problem may occur if you use the PrintDocument class in the .NET Framework library to print a file to a printer that uses the Generic/Text Only printer driver.

     

    I suggest that you may fix the problem via the following hotfix:

     

    http://support.microsoft.com/default.aspx?scid=KB;EN-US;822779

     

    Hope that helps


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, May 19, 2011 6:49 AM
  • Hi,

    The link supplied has the following displayed at top:

    System TipThis article applies to a different version of Windows than the one you are using. Content in this article may not be relevant to you.Visit the Windows 7 Solution Center

    I have Windows 7 x64, so I suspect this KB does not apply to me.


    Robert Cody
    Friday, May 20, 2011 11:55 AM
  • Hi,

    I want to share the following with you.

    http://msdn.microsoft.com/en-us/library/ms681382(v=vs.85).aspx

    So we can find this problem may caused by ERROR_INSUFFICIENT_BUFFER, I wondering if you have tried to reinstall Adobe Acrobat?

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, May 25, 2011 3:36 AM