none
Skype for Business - Centralized Logging Service Agent Error starting background thread to process traces

    Question

  • Centralized Logging Service Agent fails to start with error in the title. This happened after I mistakenly tried to log the IISLog scenario.  Restarting the server, Remove-CsClsConfiguration -Identity Global and restarting the service always ended up with the same error.  This is a Skype for Business 2015 Standard edition deployment with the November 17th cumulative update installed.

    Any idea how I get out of this?

    Additional details:

    Log Type - IISLogManager, Error - Object reference not set to an instance of an object.

    Cause: Internal error

    Resolution:

    Examine error details to determine resolution.

    Event ID: 33040

    Monday, January 18, 2016 5:45 PM

All replies

  • Hi,

    1.        It seems to be a .Net framework error, please run Microsoft .NET Framework Repair Tool and then restart the server.
    2.        ClsAgent.exe will load Microsoft.Rtc.ClsAgent.IISLog.dll from C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.Rtc.ClsAgent.IISLog\v4.0_6.0.0.0__31bf3856ad364e35 when the service is starting,  please try to replace the Microsoft.Rtc.ClsAgent.IISLog.dll with another from a same updated skype for business 2015 environment. Also we can analyze the service starting process via process monitor. Process Monitor

    If the above steps don't work, replace the ClsAgent.exe under C:\Program Files\Common Files\Skype for Business Server 2015\ClsAgent with another from a same updated skype for business 2015 environment.

     



    Tuesday, January 19, 2016 6:43 AM
    Moderator
  • 1) Ran the dot net framework repair tool which unregistered and re-registered windows installer service and told me to reinstall the dot-net framework 

    2) Switched the Microsoft.Rtc.ClsAgent.IISLog.dll file from a working copy

    3) Switched the clsagent.exe file from a working copy

    Still get the same error.


    Simon

    Tuesday, January 19, 2016 3:43 PM
  • Any other ideas for me?

    Simon

    Sunday, January 24, 2016 8:57 AM
  • Were you able to resolve the issue?
    Monday, April 11, 2016 10:16 PM
  • Unfortunately not.



    Simon

    Tuesday, April 12, 2016 12:04 PM
  • Any news? We got the same error.
    Thursday, May 26, 2016 8:27 AM
  • Hi there,

    I ran into the exact same Problem.
    First I tried a lot of things and start tracing the Logger with Process Monitor.
    I figured out, that the process is crashing as soon as the dll "Microsoft.Rtc.ClsAgent.IISLog.dll" is read.

    In my case I have done the following steps:

    1. Renamed the DLL

    "C:\Windows\Microsoft.NET\assembly\GAC_MSIL\Microsoft.Rtc.ClsAgent.IISLog\v4.0_6.0.0.0__31bf3856ad364e35\Microsoft.Rtc.ClsAgent.IISLog.dll" in "Microsoft.Rtc.ClsAgent.IISLog.dll.old"

    2. Switched the Logon On User of the Service "Skype for Business Server Centralized Logging Service Agent" to Local System account

    3. Started the Service once (I have seen in Process Monitor that an .msi was reinstalled and waited for some Minutes)

    4. Switched back to Network Service and started the Service again

    Hope, this works well for you too.

    Best regards


    • Edited by Keks Stern Tuesday, May 31, 2016 12:48 PM
    • Proposed as answer by G.Vitaly Friday, June 03, 2016 7:02 AM
    Tuesday, May 31, 2016 12:36 PM