none
ActiveX Filtering RRS feed

  • Question

  • Hi,  on Windows8, IE10, (not the metro ie), I usually run with ActiveX Filtering ON and I get to approve all attempts to run ActiveX controls. Usually I will only get to approve each run when ActiveX filtering is OFF.

    However even when ActiveX Filtering is ON I usually get to approve usually one run of a control.

    If was wasn't asking to approve all attempts to run a control be approved I would never know that ActiveX was running one control even when filtering is on.

    Is that the expected behaviour?

    thanks

    mark


    mark

    Wednesday, January 9, 2013 7:15 AM

Answers

  • Hi,

    ensure you are using the default security zone settings....

    Tools>Internet Options>Security tab, click "Reset all zones to default"... there are security zone settings that affect the behavior of activeX controls hosted in web pages, separate from the ActiveX filtering features.

    You will see the blue crossed circle icon in the Address bar (rhs) when any content of a page has been filtered or blocked. Click the icon and select the options for allowing content (on the current page).

    When you have changed the security zone settings for ActiveX controls you may see the information bar (at the bottom of the screen) prompting you to allow or disallow the control to run (on the current page)....

    To enable an Active X control (you probably mean Flash ActiveX), select the Tools>Manage Addons>Show All addons...... locate the ActiveX control in the list and double click it to display its properties dialog.....

    Flash Properties Dialog

    click the "Allow on all sites" button, to prevent the security Information bar reappearing each time you encounter the same ActiveX control on different web sites.

    When asking a question in IE forums it is helpful if you can provide a website link so that we and the MS support engineers can have a look ourselves. this will give us clues as to the problem/issue you may be facing.

    Regards.


    Rob^_^


    • Edited by 网游 - wang'you Wednesday, January 9, 2013 11:22 PM
    • Marked as answer by MarkTR Saturday, January 12, 2013 9:02 AM
    Wednesday, January 9, 2013 11:21 PM

All replies

  • Hi,

    ensure you are using the default security zone settings....

    Tools>Internet Options>Security tab, click "Reset all zones to default"... there are security zone settings that affect the behavior of activeX controls hosted in web pages, separate from the ActiveX filtering features.

    You will see the blue crossed circle icon in the Address bar (rhs) when any content of a page has been filtered or blocked. Click the icon and select the options for allowing content (on the current page).

    When you have changed the security zone settings for ActiveX controls you may see the information bar (at the bottom of the screen) prompting you to allow or disallow the control to run (on the current page)....

    To enable an Active X control (you probably mean Flash ActiveX), select the Tools>Manage Addons>Show All addons...... locate the ActiveX control in the list and double click it to display its properties dialog.....

    Flash Properties Dialog

    click the "Allow on all sites" button, to prevent the security Information bar reappearing each time you encounter the same ActiveX control on different web sites.

    Regards.


    Rob^_^

    Wednesday, January 9, 2013 11:20 PM
  • Hi,

    ensure you are using the default security zone settings....

    Tools>Internet Options>Security tab, click "Reset all zones to default"... there are security zone settings that affect the behavior of activeX controls hosted in web pages, separate from the ActiveX filtering features.

    You will see the blue crossed circle icon in the Address bar (rhs) when any content of a page has been filtered or blocked. Click the icon and select the options for allowing content (on the current page).

    When you have changed the security zone settings for ActiveX controls you may see the information bar (at the bottom of the screen) prompting you to allow or disallow the control to run (on the current page)....

    To enable an Active X control (you probably mean Flash ActiveX), select the Tools>Manage Addons>Show All addons...... locate the ActiveX control in the list and double click it to display its properties dialog.....

    Flash Properties Dialog

    click the "Allow on all sites" button, to prevent the security Information bar reappearing each time you encounter the same ActiveX control on different web sites.

    When asking a question in IE forums it is helpful if you can provide a website link so that we and the MS support engineers can have a look ourselves. this will give us clues as to the problem/issue you may be facing.

    Regards.


    Rob^_^


    • Edited by 网游 - wang'you Wednesday, January 9, 2013 11:22 PM
    • Marked as answer by MarkTR Saturday, January 12, 2013 9:02 AM
    Wednesday, January 9, 2013 11:21 PM