none
Getting error when trying to start a user defined Data Collector in Performance Monitor

    Question

  • Windows Server 2012 R2

    I created a user defined Data Collector in PerfMon (running as administrator) based on this post:

    http://blog.synology.com/?p=2086

    The Data Collector is listed under the the Data Collection Sets | User Defined | Server Manager Performance Monitor | My Data Collector.

    When I right click on Server Manager Performance Monitor then choose 'Start' I get the following window:

    [Window Title]
    Performance Monitor
    [Main Instruction]
    When attempting to start the Data Collector Set the following system error occurred:
    The operator or administrator has refused the request.
    [OK]

    My user account is in the local Administrator group as is Domain Admins which I'm a member. I also added my user account to the local perfmon groups.

    I also made sure the local Administrators group is in 'Log on as a batch job' in User Rights Assignment. As recommended on some other troubleshooting steps. 

    Still not working, any other troubleshooting ideas? Most of what I've found relates to Task Scheduling and I'm able to create in there without issue.

    Wednesday, January 20, 2016 6:03 PM

Answers

  • Hi ConexusDave,

    Thanks for posting on the TechNet forum.

    >>When attempting to start the Data Collector Set the following system error occurred:
    The operator or administrator has refused the request.

    I have test your issue in my environment.

    My lab environment: server 2012R2, domain: contosol.com, run as administrator or normal user accounts.

    Here are some results:

                                 Figure1: my current system information

                                  Figure2: success creating and starting

                                       Figure3: already start

    For your issue, you could try the methods below:

    Right-click "My Data Collector"-> select properties->General->Run As->choose another account.

    Or, you could give the current user full control permission:

    Right-click "My Data Collector"-> select properties->Security->Group or Users->Permissions->Full Control

    Note: My these testing accounts only in the Domain admin group and local admin group.

    Best regards,


    Andy_Pan



    Thursday, January 21, 2016 3:19 AM
    Moderator

All replies

  • Hi ConexusDave,

    Thanks for posting on the TechNet forum.

    >>When attempting to start the Data Collector Set the following system error occurred:
    The operator or administrator has refused the request.

    I have test your issue in my environment.

    My lab environment: server 2012R2, domain: contosol.com, run as administrator or normal user accounts.

    Here are some results:

                                 Figure1: my current system information

                                  Figure2: success creating and starting

                                       Figure3: already start

    For your issue, you could try the methods below:

    Right-click "My Data Collector"-> select properties->General->Run As->choose another account.

    Or, you could give the current user full control permission:

    Right-click "My Data Collector"-> select properties->Security->Group or Users->Permissions->Full Control

    Note: My these testing accounts only in the Domain admin group and local admin group.

    Best regards,


    Andy_Pan



    Thursday, January 21, 2016 3:19 AM
    Moderator
  • I am experiencing the same error, with the default "Server Manager Performance Monitor" collector set on my 6.3.9600 server. I have created another data collector set myself and it runs just fine. Why does the default included with the OS not work, and why does it not give any other errors in the event log to aid in troubleshooting?

    Chris Stamey

    Thursday, September 8, 2016 2:14 PM
  • Same problem on 2012 R2. Solution doesn't work for me.

    yaro

    Tuesday, September 20, 2016 12:46 PM