none
IE 11 enterprise mode logging not working? RRS feed

  • Question

  • hopefully this is the right forum for this question, i didn't see an IIS forum..

    i just set up enterprise mode logging for ie11 on server 2012 r2, iis 8.5.

    what i've set up so far:

    - installed iis, .net and asp

    - configured default website, tested localhost and remote access successfully

    - configured logging to include specific fields as per MS logging documentation

    - created and copied asp file to root of default website

    - configured and successfully tested enterprise mode gpo with xml site list (site list is being copied to local C: drive of each computer via the same gpo)

    - configured and successfully tested gpo to allow users to turn EM on/off for sites (via Tools menu in IE)

    - added local server url for logging to gpo (ie, http://servername:81/emIE.asp)

    - added full permission for server and iis_iusrs accounts to default site permissions

    - did a gpupdate /force and turned on/off EM on various websites

    when i look at my default website's log file (C:\inetpub\logs\LogFiles\W3SVC1), i don't see any entries for the on/off activities, but i does have some stuff.. not seeing anything related to the em testing though.

    can anyone point me in the right direction as to what i'm missing?  hopefully it's something simple!

    thanks!

    Friday, December 18, 2015 8:36 PM

Answers

  • maybe there's something a little different, in WS2012R2/IIS (like defaults of some kind), which the EMIE logging guide doesn't cater for?

    Maybe these discussions (on the general topic of 405 errors/disallowed verbs), might be helpful:
    http://stackoverflow.com/questions/6617210/http-405-on-error-on-http-post-iis-asp-net

    We set this logging up, some time ago, on WS2008R2, followed the same guide fro TechNet/MSDN http://msdn.microsoft.com/en-us/library/dn781326.aspx and it all just worked. (which is why I'm wondering if WS2012R2 might have changed something, is stricter about standard compliance, uses newer standards, etc, etc)


    Don [doesn't work for MSFT, and they're probably glad about that ;]


    • Edited by DonPick Sunday, December 20, 2015 11:22 PM
    • Proposed as answer by jim-xu Tuesday, December 29, 2015 9:13 AM
    • Marked as answer by Michael_LSModerator Wednesday, December 30, 2015 5:49 AM
    Sunday, December 20, 2015 11:18 PM

All replies

  • anyone?
    Sunday, December 20, 2015 6:43 PM
  • when i look at my default website's log file (C:\inetpub\logs\LogFiles\W3SVC1), i don't see any entries for the on/off activities, but i does have some stuff.. not seeing anything related to the em testing though.

    If you have an example of it working correctly you could trace both cases using ProcMon and compare them for the significant difference.  Additionally I would wonder if there is a relevant netsh trace which could be added for interleaving context.  I don't know if it would be the most appropriate one or not but one interesting one I found recently is  Microsoft-Windows-WinInet.  There is also this one Microsoft-IE but I don't know at all what it would give you.  In any case, for example, if those were running presumably ProcMon would show you extra trace items for its trace using filter Operation Is WriteFile.  Otherwise Category Is Write might be more appropriate, especially if you need to see registry changes recorded.  Etc.  Note that I am only proposing this if you have two otherwise identical cases to trace because without access to either source or support documentation such analysis would be much harder.

    Good luck



    Robert Aldwinckle
    ---

    Sunday, December 20, 2015 7:00 PM
    Answerer
  • i'm also using fiddler to investigate- each time i toggle EM from the tools menu in IE i see error 405, when i look at the Inspectors tab in fiddler it's missing the path to my iis server under Request Headers (ie, should be showing 'POST <servername>\emIE.asp' but instead only shows '\emIE.asp').

    it looks like the GP isn't applying the logging URL properly, though the GP is working because i can togggle EM in the Tools menu, so maybe it's an IIS issue?  i've double-checked my iis configuration against the ms documenation and other setup articles i've found.

    found this related post, same issue:

    https://social.technet.microsoft.com/Forums/ie/en-US/5f31d986-5cfa-4510-8611-2bd3836c167d/ie11-enterprise-mode-and-the-iis-logging-website-emieasp-log-the-toggle?forum=ieitprocurrentver

    Sunday, December 20, 2015 9:16 PM
  • did more digging in fiddler and found this under inspectors/headers tabs:

    under Response Headers:

    HTTP/1.1 405 Method Not Allowed

    under the Security tab:

    Allow: GET, HEAD, OPTIONS, TRACE

    and under the TextView tab:

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
    <title>405 - HTTP verb used to access this page is not allowed.</title>
    <style type="text/css">
    <!--
    body{margin:0;font-size:.7em;font-family:Verdana, Arial, Helvetica, sans-serif;background:#EEEEEE;}
    fieldset{padding:0 15px 10px 15px;}
    h1{font-size:2.4em;margin:0;color:#FFF;}
    h2{font-size:1.7em;margin:0;color:#CC0000;}
    h3{font-size:1.2em;margin:10px 0 0 0;color:#000000;}
    #header{width:96%;margin:0 0 0 0;padding:6px 2% 6px 2%;font-family:"trebuchet MS", Verdana, sans-serif;color:#FFF;
    background-color:#555555;}
    #content{margin:0 0 0 2%;;}
    .content-container{background:#FFF;width:96%;margin-top:8px;padding:10px;;}
    -->
    </style>
    </head>
    <body>
    <div id="header"><h1>Server Error</h1></div>
    <div id="content">
     <div class="content-container"><fieldset>
      <h2>405 - HTTP verb used to access this page is not allowed.</h2>
      <h3>The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.</h3>
     </fieldset></div>
    </div>
    </body>
    </html>

    so this appears to be an iis configuration issue?  i'm not really familiar with iis setup so i don't really know what i need to change here, do i have to allow POST submissions in iis?  looks like that feature is either missing or not set up correctly, so toggling EM isn't successfully getting sent to the iss log file?
    Sunday, December 20, 2015 9:39 PM
  • maybe there's something a little different, in WS2012R2/IIS (like defaults of some kind), which the EMIE logging guide doesn't cater for?

    Maybe these discussions (on the general topic of 405 errors/disallowed verbs), might be helpful:
    http://stackoverflow.com/questions/6617210/http-405-on-error-on-http-post-iis-asp-net

    We set this logging up, some time ago, on WS2008R2, followed the same guide fro TechNet/MSDN http://msdn.microsoft.com/en-us/library/dn781326.aspx and it all just worked. (which is why I'm wondering if WS2012R2 might have changed something, is stricter about standard compliance, uses newer standards, etc, etc)


    Don [doesn't work for MSFT, and they're probably glad about that ;]


    • Edited by DonPick Sunday, December 20, 2015 11:22 PM
    • Proposed as answer by jim-xu Tuesday, December 29, 2015 9:13 AM
    • Marked as answer by Michael_LSModerator Wednesday, December 30, 2015 5:49 AM
    Sunday, December 20, 2015 11:18 PM