none
IE 11 uses HTTP 1.0 for CONNECT requests instead of HTTP 1.1 RRS feed

  • Question

  • I'm running into a performance problem with Internet Explorer 11 and HTTP CONNECT requests going through a proxy server.  The problem is that IE uses HTTP 1.0 when initiating the CONNECT request.  Because it is using HTTP 1.0, there is a lot more connection traffic, which causes slow performance between the host and the proxy.  As a note, the proxy is remote to the user.

    Here is my environment:

    * Windows 7 SP1, plus all patches via Windows Update as of August 28, 2014
    * Latest version of IE 11, specifically version 11.0.9600.17207
    * IE HTTP settings are as follows:
         Use HTTP 1.1 (checked)
         Use HTTP 1.1 through proxy connections (checked)
    * Proxy:  Blue Coat ProxySG 300 running SGOS version 6.5.4.5; No authentication and no SSL intercept

    Other browsers, such as Firefox v31 or Google Chrome 36.0.1985.143m or 37.0.2062.102m use HTTP 1.1 with the CONNECT requests.  Because they use HTTP 1.1 requests, the amount of traffic pulled across the wire is significantly less (about 1/6th the amount of traffic).  This results in significantly better performance by the non-IE browsers.

    I found a similar post at this location (http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/how-to-force-ie-to-use-http11-over-ssl-through/360eca2d-e290-4078-ad37-7665bec706c4 ), but the post is five years old and not relevant because I'm not doing any authentication with the Blue Coat proxy.  The same proxy config with non-IE browsers going to the same websites yields CONNECT requests being made with HTTP 1.1 instead of HTTP 1.0 requests.  This appears to be an undocumented IE feature that when IE uses a proxy server and goes to an HTTPS site, it will only use HTTP 1.0 for CONNECT requests instead of HTTP 1.1.  

    Is this a known IE issue?  If so, is there a registry setting that can be implemented to override this default behavior?  If not, is there a patch/hotfix that can be downloaded and applied to address the problem?

    If there isn't a patch, are there any plans to enhance IE so it will use HTTP 1.1 instead of 1.0 for CONNECT requests?  If there are no plans, can plans be made to address this performance issue with IE?

    Thank you for your time and assistance.  It is appreciated.

    Friday, August 29, 2014 5:00 PM

All replies

  • Hi,

    As I know, recent browsets should use http 1.1, have you tried to force the http 1.1 via registry?

    Open registry editor

    • Click Start, click Run, type regedit, and then click OK.
    • Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings
    • On the Edit menu, point to New, and then click DWORD Value.
    • Type EnableHTTP1_1, and then press ENTER.
    • Right-click EnableHTTP1_1, and then click Modify.
    • Type 1, and then click OK.
    • On the Edit menu, point to New, and then click DWORD Value.
    • Type ProxyHttp1.1, and then press ENTER.
    • Right-click ProxyHttp1.1, and then click Modify.
    • Type 1, and then click OK. click F5 to refresh the registry.
    • Exit Registry Editor.

    And the link you pasted above (answer.microsoft.com) mentioned that this issue could be related with Blue Coat proxy, as a test, I suggest you set IE to "Automatically detect settings" instead of the proxy, check if it is the culprit.


    Yolanda Zhu
    TechNet Community Support

    Monday, September 1, 2014 10:02 AM
    Moderator
  •  HTTP CONNECT requests going through a proxy server.

    That has been an IE default forever.  Change it in the Options, Advanced tab, HTTP Settings section.



    Robert Aldwinckle
    ---

    Tuesday, September 2, 2014 2:06 AM
    Answerer
  • Hi

    1- According to the this picture press F12 key in your keyboard and select the old versions:

    IE

    2- Installing CCleaner program and mark all check box. and Run Cleaner.


    Future is mine! ^_^

    Tuesday, September 2, 2014 10:00 AM
  • Hello Yolanda,

    The registry settings to force HTTP 1.1 do not make a difference.  Still making a CONNECT using HTTP 1.0.  Any other thoughts?

    Gordon

    Tuesday, September 2, 2014 6:41 PM
  • Robert,

    In my original post I stated the following:

    * IE HTTP settings are as follows:

         Use HTTP 1.1 (checked)
         Use HTTP 1.1 through proxy connections (checked)

    Your answer appears to be the same thing that I stated, which I have already tried unsuccessfully.  Any other thoughts?

    Tuesday, September 2, 2014 6:42 PM
  • Any other thoughts?

    Ignoring the apparent lack of effect on the Connect request does it change the other requests?  I suppose I could test this using Fiddler.  TBD.



    Robert Aldwinckle
    ---

    Wednesday, September 3, 2014 12:23 AM
    Answerer