locked
IE 8 Beta 2: Impossible to delete Browsing History!?

    Question

  •  

    I am running Internet Explorer 8, Beta 2 on Windows Vista Home Premium 32-bit and I am having the most difficult time deleting my browsing history.  It's funny because I thought this was supposed to be a big feature, this 'deleting browser history'.

     

    I have my browser history set to 0 days; I have gone through Tools > Internet Options > Browsing History ("Delete") > checked all boxes (with and withour preserving favorites website data); I have gone to the Favorites button (upper-left of tabs), chosen the History tab, and manually deleted the history; I have used the Command Prompt to delete my history, and I have even used two separate privacy, history-deleting programs (Internet Eraser, and CCleaner).  Checking "deleting browsing history on exit" and restarting my computer several times does nothing either.  It will not budge.


    Now, the history does apparently delete from the History tab under Favorites, but when typing an address into the URL bar, it still suggests sites from history from even before IE 8 Beta 2 was released.  The only way I can get rid of them is by clicking the red X to the right of the history suggestions.  I spent an hour clicking the red X's before I started to see suggestions I had already deleted.

     

    Does anyone have any suggestions?

     

    Thank you.

    Wednesday, September 03, 2008 11:58 AM

Answers

All replies

  • Hi,

     

    For IE8 Beta issues, please discuss them in our Internet Explorer Beta newsgroup:

     

    http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=microsoft.public.internetexplorer.beta

     

    Or you can call Microsoft for direct support. It is free of charge.

     

    https://support.microsoft.com/oas/default.aspx?prid=12357

     

    I hope your issue can be resolved soon.

     

    Tim Quan - MSFT

     

     

    Thursday, September 04, 2008 3:04 AM
    Moderator
  • Problem: OK Computer couldn't get IE8 browsing history to delete automatically and is using 0 days and understandably thinking that the cache would be deleted immediately after an IE8 session.

     

    Solution: Microsoft often uses "0" (zero) to mean "Never" such as with their Power Options, and may be overriding your "delete browsing history on exit". So keep the "delete browsing history on exit" checked but change the  "0" days to "1" day for the browsing history deletion setting. It should work.

    Monday, December 01, 2008 8:10 PM
  • IE8 > Tools > Internet Options > Content > AutoComplete Settings > Delete AutoComplete history > [select items to delete] > Delete

    The problem is that IE8 has an additional "drop down address bar history".  That is probably what you have the problem with, try the above.
    • Proposed as answer by bertie356 Monday, June 29, 2009 11:02 PM
    Monday, June 29, 2009 11:02 PM
  • i have the same problem and i dont know what to do yet...am looking in googel to see if there is any thing that can help... also IE8 has internet isuues that am mad about so hopefully they can fix it very soon..
    Monday, July 06, 2009 4:49 AM
  • Thanks bertie356, that is it.
    Tuesday, July 07, 2009 10:57 PM
  • I have given up on IE and have changed browser its the biz no more bugs and days lost trying to fix other peoples problems!

    Sunday, August 09, 2009 11:58 AM
  • THANKS BERTIE
    DAYS OF EFFORT SPENT GOING ROUND IN CIRCLES!!
    WHY ON EARTH DO THE DIALOGUE BOXES IN MICROSOFT NOT GUIDE THE USER OR CONTAIN SIMILAR FUNCTIONS TOGETHER!!!
    Wednesday, August 12, 2009 9:57 AM
  • If you are still reading to find the solution it seems all common ways to delete history didn't worked for you as it didn't for my history.
    So:
    1)GO TO Control Panel\System and Maintenance
    2)OPEN Modify Index Locations
    3)SELECT Internet Explorer History
    4)CLICK Advanced button
    5)CLICK Restore To Default
    6)RESTART your computer.

    TA TA:):)

    Wednesday, November 11, 2009 2:32 AM
  • Mhardworking:

    Thanks.  Your solution WORKED!!!

    TA TA :) :) is the correct conclusion.

    Saturday, November 21, 2009 12:05 PM