locked
Delegates sent items saving RRS feed

  • Question

  • Hi

    I have run up against an issue where when one person sends an email from another persons address with full access to the email account and send as rights the sent email only saves in the senders sent items not the delegated account.

    Current exchange version is as follows

    Name                : EXCHANGE
    Edition             : Enterprise
    AdminDisplayVersion : Version 15.0 (Build 1320.4)

    Exchange Server 2013 CU17

    I know that I need to apply 3 more CU's to the system but this is currently on hold for varying reasons.

    I have run the following to save sent items in both the senders and delegated sent items but receive an error after attempting to run the comand

    Comandlet used "set-mailbox "User email addy" -MessageCopyForSentAsEnabled $True

    Error received "MessageCopyForSentAsEnabled can only be set on shared mailboxes"

    From all the forums and exchange sites essentially say this should work but for some reason the setting is not.

    Any ideas / help much appreciated.

    Tuesday, September 11, 2018 9:17 AM

Answers

  • Hello!

    I think, this feature is enabled only for shared mailboxes, as we can see in Exchange Team article.
    But I hope that there's some way to enable it for user mailboxes.

    @Evgeny, not really, previously, this parameter was available only for shared mailboxes. In Exchange Online or Exchange 2016 CU6 or later, this parameter is also available for user mailboxes. 

    So far, the above-mentioned command is not applied to user mailbox in Exchange 2013. So the command way is not practicable. 

    As a workaround, we could create a register key named DelegateSentItemsStyle with value 1 under  HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Preferences, and also ensure Outlook is in cached mode.

    With this register key, the send as message will be only saved in the sender's mailbox (delegated account), while by now there is not a perfect solution to save the message in both of the mailboxes (sender's and delegate's).

    For more details, see Messages sent from a shared mailbox aren't saved to the Sent Items folder of the shared mailbox in Outlook

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Edited by Manu Meng Wednesday, September 12, 2018 8:10 AM
    • Proposed as answer by Manu Meng Friday, September 14, 2018 9:07 AM
    • Marked as answer by Damfoose Tuesday, September 18, 2018 10:00 AM
    Wednesday, September 12, 2018 7:38 AM

All replies

  • Hello!

    I think, this feature is enabled only for shared mailboxes, as we can see in Exchange Team article.
    But I hope that there's some way to enable it for user mailboxes.
    • Proposed as answer by Evgeny Vovney Tuesday, September 11, 2018 10:56 AM
    Tuesday, September 11, 2018 10:56 AM
  • Hello!

    I think, this feature is enabled only for shared mailboxes, as we can see in Exchange Team article.
    But I hope that there's some way to enable it for user mailboxes.

    @Evgeny, not really, previously, this parameter was available only for shared mailboxes. In Exchange Online or Exchange 2016 CU6 or later, this parameter is also available for user mailboxes. 

    So far, the above-mentioned command is not applied to user mailbox in Exchange 2013. So the command way is not practicable. 

    As a workaround, we could create a register key named DelegateSentItemsStyle with value 1 under  HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Preferences, and also ensure Outlook is in cached mode.

    With this register key, the send as message will be only saved in the sender's mailbox (delegated account), while by now there is not a perfect solution to save the message in both of the mailboxes (sender's and delegate's).

    For more details, see Messages sent from a shared mailbox aren't saved to the Sent Items folder of the shared mailbox in Outlook

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Edited by Manu Meng Wednesday, September 12, 2018 8:10 AM
    • Proposed as answer by Manu Meng Friday, September 14, 2018 9:07 AM
    • Marked as answer by Damfoose Tuesday, September 18, 2018 10:00 AM
    Wednesday, September 12, 2018 7:38 AM
  • Hi,

    Just checking in to see if above information was helpful. Please let us know if you would like further assistance.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, September 18, 2018 9:58 AM
  • Accepting Manu's answer as after further research into the issue this is correct for Exchange 2013.
    Tuesday, September 18, 2018 10:01 AM