locked
Disable file transfer/copy paste for RDS RRS feed

  • Question

  • Hello all,

    I'm working on a PC named ABC. From ABC i'm doing a remote desktop connection to a server/PC named XYZ.

    I want that when i'm connected to XYZ via RDS.....i should be prevented to copy files/documents or any stuffs from XYZ to my PC ABC.

    No file transfer should occur from XYZ to ABC.

    Any idea how we can implement this. Will the setting "Do Not Allow LPT Port Redirection" be helpful??

    grateful for a quick replyyyyy

    Friday, November 30, 2012 6:10 AM

Answers

  • Following settings are enough

    Do not allow Clipboard redirection Enabled

    -         Do not allow drive redirection Enabled

    • Marked as answer by Clarence Zhang Wednesday, December 5, 2012 9:43 AM
    Friday, November 30, 2012 7:56 AM
  • rdp-tcp connection properties - Client Settings, check the box for "Disable
    the following: Clipboard mapping"

    or

    Start -> Run -> tscc.msc -> Connections -> RDP-tcp -> Properties -> Client
    Settings

    Friday, November 30, 2012 7:02 AM

All replies

  • rdp-tcp connection properties - Client Settings, check the box for "Disable
    the following: Clipboard mapping"

    or

    Start -> Run -> tscc.msc -> Connections -> RDP-tcp -> Properties -> Client
    Settings

    Friday, November 30, 2012 7:02 AM
  • Hello,

    i have created a gp and configured the following settings:

    -          Do not allow Clipboard redirection Enabled

    -          Do not allow COM port redirection Enabled

    -          Do not allow drive redirection Enabled

    -          Do not allow LPT port redirection Enabled

    zdsSame are working fine...preventing data to be copied to and from......

    Friday, November 30, 2012 7:39 AM
  • Following settings are enough

    Do not allow Clipboard redirection Enabled

    -         Do not allow drive redirection Enabled

    • Marked as answer by Clarence Zhang Wednesday, December 5, 2012 9:43 AM
    Friday, November 30, 2012 7:56 AM
  • this does prevent the user from copying files using copy on remote XYZ (server) and paste on local ABC (client).

    but how to restrict copy of files from XYZ (server) to \\ABC\shared folder

    is there any way to block such file copy over network shares for RDP users ?


    • Proposed as answer by a.laachir Thursday, August 22, 2019 10:48 AM
    Friday, March 16, 2018 3:08 PM
  • blbock ports in  server FW 

    • UDP 138, File and Printer Sharing (NB-Datagram-In)
    • UDP 137, File and Printer Sharing (NB-Name-In)
    • TCP 139, File and Printer Sharing (NB-Session-In)
    • TCP 445, File and Printer Sharing (SMB-In)


    Chile

    Thursday, October 11, 2018 7:19 PM