locked
Device attached to the system not functioning RRS feed

  • Question

  • I have upgraded more than 50 clients from XP to windows 7.

    When the user try to change the password or reset the password the message appeared “the device attached to the system not functioning”.

    When I add the domain name for example “test.org\username” user cannot reset the password, but if I enter the domain IP for example 1.1.1.1\user name the user can change the password.

    Server windows 2008 R2, Clients Windows 7 professional SP1.

    Wednesday, September 12, 2012 5:23 AM

All replies

  • Please run : Dcdiag /v /c /d /e /s:dcname >c:\dcdiag.txt 

    http://www.arabitpro.com

    Wednesday, September 12, 2012 6:02 AM
  • Thank you for replaying

    NOTEPAD Result

    Command Line: "dcdiag.exe
    /v /c /d /e /s:dcname"

    Directory Server Diagnosis


    Performing initial setup:

       * Connecting to directory service on server dcname.

       Ldap search capabality attribute search failed on server dcname, return

       value = 81
       The host dcname could not be resolved to an IP address. Check the DNS

       server, DHCP, server name, etc.

       DcDiag: uncaught exception raised, continuing search

    When I run the commend, suddenly i Found error (Active directory Domain Services/ lightweight Directory services diagnostic utility has stopped working)

    Problem signature:
      Problem Event Name:    APPCRASH
      Application Name:    dcdiag.exe
      Application Version:    6.1.7601.17514
      Application Timestamp:    4ce7a044
      Fault Module Name:    ntdll.dll
      Fault Module Version:    6.1.7601.17725
      Fault Module Timestamp:    4ec4aa8e
      Exception Code:    c0000005
      Exception Offset:    000000000003074a
      OS Version:    6.1.7601.2.1.0.274.10
      Locale ID:    1033
      Additional Information 1:    6da3
      Additional Information 2:    6da3e97bee351e4c7a46be449ea1982b
      Additional Information 3:    2320
      Additional Information 4:    2320ea52da067b2f1394c8002beb7c34

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt

    Wednesday, September 12, 2012 6:51 AM
  • can you please run the below command from CMD

    netdom query fsmo 


    http://www.arabitpro.com

    Wednesday, September 12, 2012 6:56 AM
  • Schema Master                  servername.domainname.org

    Domain naming master      servername.domainname.org

    PDC                                    servername.domainname.org

    RID pool manager               servername.domainname.org

    infrustructure master          servername.domainname.org

    the commend comopleted successfully.

    Wednesday, September 12, 2012 7:07 AM
  • Great!! 

    now run this command 

    Dcdiag /v /c /d /e /s:SERVERNAME >c:\dcdiag.txt 


    http://www.arabitpro.com

    Wednesday, September 12, 2012 7:09 AM
  • The result words are more than 6000 words I cannot post it

    Wednesday, September 12, 2012 8:03 AM
  • post it on the skydrive i will download from there

    http://www.arabitpro.com

    Wednesday, September 12, 2012 8:19 AM
  • I ahve uploaded the result

    • Proposed as answer by REZAKORDIWIDE Monday, August 7, 2017 9:52 PM
    Wednesday, September 12, 2012 8:30 AM
  • HAVE
    Wednesday, September 12, 2012 8:30 AM
  • share the link to us to get it downloaded

    http://www.arabitpro.com

    Wednesday, September 12, 2012 8:40 AM
  • Did you get the file

    Wednesday, September 12, 2012 9:41 AM
  • according to the log it mentions you have 2 servers server1 and server 2 and presently server 1 is working Server 2 is either removed or network connected . If it doesn't exit then we might have to perform the metadata cleanup.

    http://www.petri.co.il/delete_failed_dcs_from_ad.htm


    http://www.arabitpro.com


    Wednesday, September 12, 2012 9:50 AM
  • server 2 is shut down, but we are using two servers server1 & server2 and both of them working fine.
    Wednesday, September 12, 2012 9:52 AM
  • If server 2 shutdown then why its shutdown and since how many days its shutdown ? any specific reason ? 


    http://www.arabitpro.com

    Wednesday, September 12, 2012 9:56 AM
  • Just today for Maintenance, but even if the second server is up the problem still exist. 

    Wednesday, September 12, 2012 9:57 AM
  • ?

    Saturday, September 15, 2012 4:25 AM
  • Can you please tranfer the roles to another server which is Server 2 and shutdown the server 1 and recheck the stitautuion ? 

    http://www.arabitpro.com

    Saturday, September 15, 2012 5:56 AM
  • I tried this step, but still the problem not solved.

    Saturday, September 15, 2012 6:06 AM
  • Do you have any event IDS ? 

    http://www.arabitpro.com

    Saturday, September 15, 2012 6:11 AM
  • What IDS you asking for

    Saturday, September 15, 2012 6:14 AM
  • When you are trying th change the password there should be an Event posted in the event viewer in the security.

    http://www.arabitpro.com

    Saturday, September 15, 2012 6:15 AM
  • in the client PC or the Domain

    Saturday, September 15, 2012 6:16 AM
  • Server side and one more question do you have any Third applications installed on the server by any chance ? Did you tried the scenario by disabling the firewall and the AV ? 

    http://www.arabitpro.com

    Saturday, September 15, 2012 6:18 AM
  • A Kerberos authentication ticket (TGT) was requested.

    Account Information:

    Account Name: dc2

    Supplied Realm Name: Domain

    User ID: Domain\dc2

    Service Information:

    Service Name: krbtgt

    Service ID: Domain\krbtgt

    Network Information:

    Client Address: ::ffff:10.77.152.10

    Client Port: 60870

    Additional Information:

    Ticket Options: 0x40800010

    Result Code: 0x0

    Ticket Encryption Type: 0x17

    Pre-Authentication Type: 2

    Certificate Information:

    Certificate Issuer Name:

    Certificate Serial Number:

    Certificate Thumbprint:

    Certificate information is only provided if a certificate was used for pre-authentication.

    Saturday, September 15, 2012 6:24 AM
  • I have shutdown the Firewall and no I don’t have third party App installed.

    Still the problem is there

    Saturday, September 15, 2012 6:26 AM
  • While changing the password you get the error isnt it ? can you please retry changing the Password and check the event id in the application and security both places

    http://www.arabitpro.com

    Saturday, September 15, 2012 6:32 AM
  • I got the same message from the security log's

    No log's generated in the application log's

     

    Saturday, September 15, 2012 6:39 AM
  • Can you please share me the screen shot when you try to to change the password and join the domain ? 



    http://www.arabitpro.com

    Saturday, September 15, 2012 6:44 AM
  • Saturday, September 15, 2012 7:08 AM
  • Saturday, September 15, 2012 7:09 AM
  • Is this image what you asking for?
    Saturday, September 15, 2012 7:44 AM
  • If I put the user in DOMAIN ADMIN group then I acn change the password, but if I remove it from the group I acnnot change the password.
    Saturday, September 15, 2012 9:13 AM
  • I can change the password
    Saturday, September 15, 2012 9:13 AM
  • Also if I put the password for the user from the domain he can access the computer without checking user must change password box.
    Saturday, September 15, 2012 9:32 AM
  • There is no  Direct upgrade from Windows Xp to Windows 7 how did u performed the task ? 

    http://www.arabitpro.com

    Saturday, September 15, 2012 10:20 AM
  • It's clean format from the DVD.

     
    Saturday, September 15, 2012 7:19 PM
  • What setting are configured for following ?

    Interactive logon: Require Domain Controller authentication to unlock (Required setting Enabled)

    Domain member: Require strong (Windows 2000 or later) session key (Required setting Enabled)

    Interactive logon: Require smart card (Required setting Disabled if you do not use Smart Card)

    Saturday, September 15, 2012 8:49 PM
  • all the setting are the same which you provide.

    still the problem exist.

    Sunday, September 16, 2012 5:33 AM
  • Can you please un-join and re-join a sample machine to the domain and then try ?
    Sunday, September 16, 2012 6:18 AM
  • Tried not working.
    Sunday, September 16, 2012 6:34 AM
  • Please open a ticket from Microsoft CSS and seek there assistance or wait for the moderators to reply. I am not sure why is this behavior one thing I can suspect is might be AD database  corruption which can be resolved by defraging the database.

    Note: Do not do anything unless you get guidance from Moderators.


    http://www.arabitpro.com

    Sunday, September 16, 2012 7:38 AM
  • HSHSH,

    By any chance, are you running your DC on Citrix ? Looks like a bug in Citrix !

    Thread from Citrix forum

    A device attached to the system is not functioning. 

    http://forums.citrix.com/thread.jspa?threadID=273457

    Sunday, September 16, 2012 1:54 PM
  • No citrix
    • Proposed as answer by Laprenzoa3 Monday, March 4, 2013 9:50 PM
    • Unproposed as answer by Laprenzoa3 Monday, March 4, 2013 9:50 PM
    Sunday, September 16, 2012 4:44 PM
  • I am having the same problem HSHSH mentioned but in my case the computers are windows 7 straight out of the box. Please can anyone help? HSHSH were you able to resolve your issue? if yes! how did you get around it. Thanks


    Monday, March 4, 2013 9:57 PM
  • Did you ever find a resolve to this. I have a user that is having the same issue on windows 7 machines. Work around was to set password manually and remove "user must change password".

    Bryan.oreilly@paccar.com

    Monday, November 25, 2013 5:51 PM
  • Hi All,

    We were having same issue where

    1) User unable to change password and was getting same error as device attached to the system is not functioning.

    2) User were unable to update group policy and error code was 1051 event ID

    We have multiple domain and only one site ( 2 DCs) was having issue.

    We had all workaround we demoted 1 DC and promoted, made changes in site level.

    Captured Netmon logs, and other logs.

    We could able to change password by domain admin, domain user were unable to change the password even if i tried with command prompt.

    Finally MS told to check lingering object, Same day i demoted one dc and promoted again and went and checked whether newly promoted dc is apprearing in domain controller OU.  

    I got shocked that newly promoted DC was available but Other  DC which is primary for that site was not available and it was laying in Computer OU.

    Then i took MS support and moved the DC from Computer OU to Domain Controller OU. 

    Post that we checked users were able to change the password and able to update group policy.

    We had lots of pressure to resolve this issue as the client was doing audit and we do not wanted to fail in auditing.

     


    With Regards, Raviraj Nagenhatti - System Administrator

    Tuesday, November 10, 2015 6:31 PM
  • Hi All,

    We were having same issue where

    1) User unable to change password and was getting same error as device attached to the system is not functioning.

    2) User were unable to update group policy and error code was 1051 event ID

    We have multiple domain and only one site ( 2 DCs) was having issue.

    We had all workaround we demoted 1 DC and promoted, made changes in site level.

    Captured Netmon logs, and other logs.

    We could able to change password by domain admin, domain user were unable to change the password even if i tried with command prompt.

    Finally MS told to check lingering object, Same day i demoted one dc and promoted again and went and checked whether newly promoted dc is apprearing in domain controller OU.  

    I got shocked that newly promoted DC was available but Other  DC which is primary for that site was not available and it was laying in Computer OU.

    Then i took MS support and moved the DC from Computer OU to Domain Controller OU. 

    Post that we checked users were able to change the password and able to update group policy.

    We had lots of pressure to resolve this issue as the client was doing audit and we do not wanted to fail in auditing.

     


    With Regards, Raviraj Nagenhatti - System Administrator

    Tuesday, November 10, 2015 6:31 PM
  • Hi ,

    I had similar problem with our DC at work but i've been able to solve it....

    Point to GPMC, group policy object, default domain policy, security filtering and delete all users, groups, computers then add domain users group ...

    Try running gpupdate /force ......

    Try again...

    Wednesday, December 9, 2015 3:58 PM