none
VM's failing to live migrate or quick move or even move when shut down RRS feed

  • Question

  • I've been trouble shooting an issue for a while in my hyperv cluster.

    I've some machines that I can't move.

    I did do an export / import of one and it worked and I can now live migrate it.

    Comparing the VMs that can be move against the VMs that can't. I've noticed the ones that work all have an extra permission.

    But I don't know how to add it or grant it.

    It looks like it has an application icon of sorts and its granted full permission to the virtual machine files

    Friday, June 14, 2019 1:38 PM

Answers

All replies

  • Hello Joe,

    You didn't tell us the errors you're receiving so it's difficult to say what could be the cause for this to happen.

    When a virtual machine (VM) is created a hidden user account is created that is unique to that VM. If a VM configuration is deleted this "VM user account" will also be deleted. 

    To fix these permission issues, I believe it's faster to create a new VM and attach the virtual disks, doing that will reset all of the permissions on the elements and create a new "VM user account".

    An export/import should also work, as you've already tested.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Friday, June 14, 2019 2:18 PM
  • Thanks, But I think my problem is related to this:

    https://forums.veeam.com/microsoft-hyper-v-f25/guest-os-starting-up-is-very-slow-on-hyper-v-2016-t50984.html

    So I'm currently trying to reduce the file size of the VMCX file. Hopefully that resolves the issue.

    • Marked as answer by Joe Mailey Friday, June 14, 2019 7:58 PM
    Friday, June 14, 2019 5:07 PM
  • OK, please let me know if you have any other question.

    Regards,

    Daniel


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, June 17, 2019 1:49 AM
    Moderator