none
Windows security dialog box for secure sites is empty - no user name and password fields are visible RRS feed

  • Question

  • I am a helpdesk tech for a large company and we having an issue with IE 8+ on win7 32bit. 

    Anytime a user goes to a secure site that requires authentication, the windows security dialog box pops up waiting for credentials, but it is impossible to enter them because the user name and password fields are not showing in the box.

    Resetting IE has no effect.  Changing security levels  for different zones also has no effect.  We have added multiple sites to our trusted lists and still no results.  These site all perform normally in Firefox and Chrome but those browsers are not an option for our users. 

    This problem is also present in IE 9 beta.
    I have even tried to completely remove IE and reinstall it but still get no results.

    I have seen 2 other threads about this issue, neither of them have resolutions.  One on technet has some detailed info on the exact same issue, but has no answer and was started last year.

    http://social.technet.microsoft.com/Forums/en/itprovistaie/thread/4d1714cd-8e8b-483d-a3de-383c3ef9e86b

    The other is on this forum, also with no answer.

    http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/45d4db20-61d5-49a7-88ee-14d35309138b

     

    here is a screen shot of the problem in action. 

    Please keep in mind that this is just one example and that the problem occurs when visiting ANY site with authentication.

     We have tried to reset the security zones to defaults but that does no good.

     

    I will be happy to provide any further info that is needed.


    Thanks for your help!

    Friday, January 21, 2011 3:09 PM

All replies

  • here is a screen shot of the problem in action. 


    It looks as if you could have keyboard focus in that message window.  Have you tried using Tab to see if it could find the fields for you that way?   Have you tried changing your screen resolution or DPI setting to see if the message window renders any better that way? 

    Also, if that message is a custom message I would try getting rid of the customization to see if a more usable prompt could be produced more conventionally.


    Good luck

    Robert Aldwinckle
    ---

    Friday, January 21, 2011 5:41 PM
    Answerer
  • I wish it were that simple.  Besides, what kind of support rep would I be if I didn't try to tab through the fields first? lol.

    Also, that is not a custom or java prompt, it's an NT authentication box.  Just like what you would see if you were logging into a site powered by IIS.  

    We have seen this problem across multiple screen resolutions, so I know that's not the problem.  The fact is, the elements of that box are not there, at all. They aren't being included when the box is rendered.  it's not as if they are hidden by the box being sized incorrectly.

    Thanks for the suggestion, but I think it's a bit more complicated than that.

    any other thoughts?

    Friday, January 21, 2011 10:21 PM
  • Anyone else have any thoughts on this?
    Tuesday, January 25, 2011 8:53 PM
  • I have the exact same problem for a couple of months now on 60 laptops running Windows 7 x86 Professional.

    Browser is IE 8.

    Updating to IE9 BETA did not help, setting all security settings to low is not a solution. I have tried to solve this by disabling the Trend Micro anti virus we use here, but no solution.

    In fact, the problem seems to only occur on specific websites, such as: https://server.db.kvk.nl/TST-BIN/FP/er , this is a public login page for the Chambre of Commerce in Holland. On other websites, such as non-form based webmail, the problem does not occur.

    Thursday, January 27, 2011 12:21 PM
  • Hi,

     

    I had the same problem myself. Install Windows 7 SP1. It solved the issue in my case. Best of luck.

     

    Monday, April 25, 2011 8:14 PM
  • What if you already have SP1 installed before the problem happens?  An sfc /scannow didn't help.  I think this started to happen after the machine was joined to the domain, if that helps.

     

    This issue is also happening when trying to log into our PEAP wireless access point so it's not only for web pages.

    Monday, May 16, 2011 7:26 PM
  • any other thoughts?


    Have you compared the normal dialog with the problem one for a font difference?  Also, if you have two cases for the rendering of that dialog you may get some clues by comparing ProcMon traces of the two.   FWIW I see an icon for my User Account being rendered in there and ProcMon shows that happening.  E.g. do a find for User.bmp   If the problem trace didn't show  User.bmp  being opened you would know you were on the right track assuming there was a problem with the rendering of the dialog, so then just trace backwards trying to see where the divergence started.

     

    Good luck

    Robert
    ---

    Tuesday, May 17, 2011 3:27 AM
    Answerer
  • I noticed that the problem happens after the machine is re-imaged.  The master PC can be working, I take an image, deploy that image and the destination PC has the problem.  Something is happening during the imaging process.
    Thursday, May 26, 2011 5:25 PM
  • I know this is a very old thread, but we ran into the same problem last Friday. It appeared the machines were indeed created from an image - a year old one. The solution was to install Windows 7 Service Pack 1

    Regards,

    Joost

    Monday, April 23, 2012 9:39 AM
  • We have this exact problem, but the machines are already at Windows 7 SP1.

    Which imaging solution is everyone using? WDS, ImageX, Ghost, Acronis....?

    Wednesday, September 12, 2012 2:35 PM
  • We are using Acronis and have the same issue. Has anyone found a solution to this problem?
    Wednesday, October 31, 2012 3:02 PM
  • I believe I have found what the issue is (or at least what it was for me).

    During my image customizations, I was making changes to the default user icon's by replacing the bmp files in the "C:\ProgramData\Microsoft\User Account Pictures\" directory. My custom BMP file was 128x128 pixels, however for some reason it was 60KB and all the other files were 48KB. I went back and edited my original PNG file and converted it back to BMP and it was now 48KB and the problem disappeared. I was having both issues described above with it requesting security to get into a website (in my case OWA) and also with my PEAP wireless.

    Hope this helps!

    Thursday, December 6, 2012 3:13 AM
  • I know this is an old thread, but in case others stumble across this, I'd like to add one more thing.  It seems that Windows 7 requires a 24-bit 128x128 bitmap as the user image.
    Tuesday, November 3, 2015 4:37 PM
  • Bump.  This has also happens to me on both of my new Windows 10 laptops trying to use MSTSC (Remote Desktops).  For me using Remote Desktop Connection manager allowed me to connect to some systems.  


    /bac

    Wednesday, July 20, 2016 10:59 AM
  • Installing Windows 7 SP1 reset the user.bmp image. This is why the install of the service pack fixed this issue for you.

    Brian Reid C7 Solutions Ltd (www.c7solutions.com)

    Thursday, September 14, 2017 12:29 PM
  • Installing Windows 7 SP1 reset the user.bmp image. This is why the install of the service pack fixed this issue for you.

    Brian Reid C7 Solutions Ltd (www.c7solutions.com)

    Thursday, September 14, 2017 12:29 PM
  • This fixed this where I saw the issue as well. The marketing department had requested the company logo replace the user picture and provided at 1MB file. This was copied over user.bmp on all machines by way of GPO preferences. 

    Reszing user.bmp to under 48K in "C:\ProgramData\Microsoft\User Account Pictures\" on a single user resolved the issue for that user. We then changed the source of the image to under 48K centrally to fix all users


    Brian Reid C7 Solutions Ltd (www.c7solutions.com)

    Thursday, September 14, 2017 12:32 PM