none
IE11 Injecting Favicon.ico into the end of the url

    Question

  • Since a few days we are seeing "favicon.ico"  and "|//browserguard1" has been frequently added to the end of the url causing errors. The requests share this attributes in common:

    1.- browser client --> IE11  (Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko)

    2.- referer --> "http://127.0.0.1/ie-tab-l/indexIE.html"

    3.- example request: 

    optionName=Searchingfavicon.ico HTTP/1.1″ 200 3618 “http://127.0.0.1/ie-tab-l/indexIE.html” “Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko”

    Started early Feb 2014.

    anyone could help us?

    Best regards!!


    Tuesday, February 25, 2014 7:58 PM

Answers

  • Hi,

    the fist step in troubleshooting any web browser issues is to test in noAddons mode....

    apparently you have the browserguard addon installed.

    Regards.

    http://support.microsoft.com/kb/2520365

    An update to the PC Tools Browser Guard Toolbar that fixes the compatibility issue is not available yet. 

    To work around this compatibility issue, disable the PC Tools Browser Guard Toolbar. To do this, follow these steps: 
    1. Close all Internet Explorer windows.
    2. Open a new Internet Explorer window.
    3. When you receive the PC Tools Browser Guard Toolbar incompatibility notification, click Keep it disabled, or ignore the notification.

    Note The PC Tools Browser Guard Toolbar may not work correctly when it is disabled.


    Rob^_^

    Tuesday, February 25, 2014 11:34 PM

All replies

  • Hi,

    the fist step in troubleshooting any web browser issues is to test in noAddons mode....

    apparently you have the browserguard addon installed.

    Regards.

    http://support.microsoft.com/kb/2520365

    An update to the PC Tools Browser Guard Toolbar that fixes the compatibility issue is not available yet. 

    To work around this compatibility issue, disable the PC Tools Browser Guard Toolbar. To do this, follow these steps: 
    1. Close all Internet Explorer windows.
    2. Open a new Internet Explorer window.
    3. When you receive the PC Tools Browser Guard Toolbar incompatibility notification, click Keep it disabled, or ignore the notification.

    Note The PC Tools Browser Guard Toolbar may not work correctly when it is disabled.


    Rob^_^

    Tuesday, February 25, 2014 11:34 PM
  • Hi all,

    Do we know if the problem is caused by an add-on ?

    Because we've had the same issue on our webstite since early February (favicon.ico being appended to end if urls, IE11 only)

    My colleague opened a ticket here :

    https://connect.microsoft.com/IE/feedback/details/817630/erreur-favicon-ico-sur-ie11

    And I commented a blog there :

    http://www.bergercity.de/allgemein/http127-0-0-1ie-tab-lindexie-html/

    But we are still expecting a clear explanation from anyone.

    If it's an add-on then we have no control over our clients' browsers and add-ons :(

    Friday, March 7, 2014 8:55 AM
  • Hi oudoulj,

    Please supply the additional information requested from the IETeam triage on your connect ticket...

    among them... the ADDRESS OF YOUR WEBSITE.

    Hello ramzitch,
        
    Thank you for the feedback. We do have a few questions that will aid us in our investigation. Can you please provide the following:

    1)IE version with build number listed in the Help|About dialogue.
    3)URL along with detailed Repro Steps.
    2)A video or snapshot of the issue you are observing.


    Rob^_^

    Saturday, March 8, 2014 12:04 AM
  • Hi oudoulj,

    Please supply the additional information requested from the IETeam triage on your connect ticket...

    among them... the ADDRESS OF YOUR WEBSITE.

    Hello ramzitch,
        
    Thank you for the feedback. We do have a few questions that will aid us in our investigation. Can you please provide the following:

    1)IE version with build number listed in the Help|About dialogue.
    3)URL along with detailed Repro Steps.
    2)A video or snapshot of the issue you are observing.


    Rob^_^

    YOU KEEP ASKING THE WRONG QUESTION!


    WE ARE SEEING THIS ON THE WEB SERVER WE DONT KNOW THE BROWSER BUT BY GUESSING FROM

    127.0.0.1/ie-tab-l/indexIE.html


    IT IS INTERNET EXPLODER!

    Thursday, May 29, 2014 4:31 PM
  • hey rob

    I really appreciate you posting the same thing multiple time, even though it is not useful

    Issues is it is a customer coming in to the website, we are seeing these all over but we cannot duplicate in house.  I guess you can call us "microsoft"

    Friday, June 27, 2014 4:25 PM
  • Yes they keep repeating the same thing since well ... I know why

    So let me try

    Internet Exploder is adding favicon.ico

    the referrer is http://127.0.0.1/ie-tab-l/indexIE.html

    IT IS NOT US THAT IS DOING IT

    IT IS OUR CUSTOMER HITTING THE SITES

    IT IS ALL OVER THE INTERNET BUT YOU KEEP ASKING THE SAME WRONG QUESTIONS

    SO TO REITERATE

    IT IS OUR CUSTOMERS USING IE11 HITTING OUR SITE AND SOME HOW YOUR BROWSER IS ADDING FAVICON.ICO

    WE HAVE NO IDEA WHAT IS CAUSING IT

    IT JUST SHOWED UP AND IT IS INTERNET EXPLODER

    Friday, June 27, 2014 4:30 PM
  • I just found this but do not know if it is fact

    Seems like its caused by the “PC Tools Browser Guard Toolbar

    search the interwebs for

    "favicon.ico" end of url "indexIE.html"

    Friday, June 27, 2014 4:42 PM