IE9 randomly gives 'Internet Explorer cannot display the webpage' error, click refresh and the page loads


  • We have recently moved offices from a site where ADSL was unreliable, to a new office in the City of London (that's UK!) where we now have New 64-bit W7 PCs with IE9 - and a leased line (10Mb on a 100Mb bearer).  We had hoped that the Internet access trobles would disappear.  We have a freshly-installed infrastructure, and our original Small Business Server 2008.

    Internet access is now generally lightning fast - hooray!  However, sites that usually work sometimes return the 'Internet Explorer cannot display the webpage' page.  Click the 'refresh' button, and the page appears instantly.

    I have a 'ping test' utility which, for instance, pinging, returns <1ms responses continually, but with random 'spikes' of 5ms once in a while - none of which seems to point at a service provider problem.  Their technical people are very helpful, but cannot see any reason for the problem.

    Is there an issue on our local network?  How do I tell?

    Wednesday, June 13, 2012 8:59 AM

All replies

  • Tools>Compatibility View Settings>check "Include updated website lists from Microsoft", uncheck "Display all sites in Compatibility View"

    are you using a proxy?

    To examine your network traffic with IE, F12 (to Display the Developer tool)>Networking tab, click "Start Capture"


    download fiddler ( - to show all network traffic, not just IE's.

    Some IE Addons call home when the browser is opening a new tab/window. Test by running IE in no-Addons mode. Open task manager and look for the GoogleToolbarUpdater(32).exe service on the Processes tab. (It starts even if the GTB is disabled).

    If you are using the GTB... click its settings button (looks like a spanner), and adjust your privacy settings... go to to turn off google's Online History Tracking.

    "randomly occuring" suggest an addon issue.

    Lastly turn on IE's Phishing filter... this will stop other phishing filters (your anti-virus products, google site verification) from also requesting site verification.

    when asking a question about "IE cannot display web page" errors it is helpful if you supply sample addresses...


    Wednesday, June 13, 2012 9:27 AM
  • Thanks, Rob - a helpful catalogue of things to check!

    I noticed the email telling me you had replied, and just to illustrate the problem regarding 'sample addresses', i started IE, which has a single tab homepage setting of '' (I'm logged in as the SB2008 'admin' account on a spare computer), and to get to the technet forums, I clicked for a new tab, and in the 'most popular sites' list clicked on Google (to lazily get to the forum by way of a google search) and got the 'Internet Explorer cannot display the webpage' error!  The 'home' tab was still showing the google page.  A 'refresh' brought up the home Google page instantly (sic).  I haven't been able to repeat this so far, but I have checked things against your list, and am now running this session without add-ons, by way of experiment.  There aren't any exotic add-ins, in any case. commonly fails, if anything is going to fail - hence my mentioning it in the original post.  A traceroute from the diagnostics page on our Netgear router typically reaches the IP address that responds to a ping in between 8 and 10 ms, with 8 hops, but occasionally the hop from the first bbc host ( to the next host takes 40ms, not the usual 1ms - but given the size of the bbc enterprise, that probably isn't a surprise.

    Some previous research I did suggested extending the ReceiveTimeout key for IE in the registry.  I currently have this set to 8 minutes - perhaps a bit extreme, particularly since the IE error message appears within seconds when it occurs.

    I have experimented with lots of sites, some of which take a long time to load, but don't fail.

    I've looked at the capture for accessing the bbc site, but so far it hasn't failed, so I'm none the wiser. I guess I'll just have to settle down and wait? Any further suggestions would be very welcome!

    Regards, etc.


    Wednesday, June 13, 2012 11:17 AM
  • Hi,

    Firstly, please troubleshoot the issue by referring to "Internet Explorer cannot display the webpage" error in Internet Explorer.

    If issue persists, based on my knowledge, this issue may be related to your DNS.

    Please let us know if you have set up a DNS server.

    If not, by default, clients use your router IP address as DNS server address. Please try to use another router and see how it works.

    Also, please contact your ISP to see if you can obtain a public DNS address. If you can, please use it in the following setting and test the issue again.

    Hope this helps.

    Jeremy Wu

    TechNet Community Support

    Thursday, June 14, 2012 8:58 AM
  • Thanks, Jeremy.

    I persisted on wednesday afternoon, and tried Fiddler.  This has provided more diagnostic information tha the standard 'Internet Explorer cannot...' message, because I get (on the one occasion when my random browsing produced an error) '[Fiddler] DNS Lookup for "" failed. The requested name is valid, but no data of the requested type was found'.  Later this morning I will check out what this might point to as a failure.

    Our Internet connection is probably a little unusual, and now looks like:

    10Mb leased line -> Cisco router provided by ISP which passes all traffic to the WAN port on our Netgear SRXN3205.  This has valid DNS addresses for 2 external DNS Servers at our ISP.  The SRXN3205 was our choice several years ago, and supports secure VPN links to Netgear routers at 3 remote sites (the partners' computers in their home offices).

    There is a DNS service running on the SBS 2008 server, which has the external DNS Server addresses in its 'forwarders' list.  The workstations have the 'automatic' settings for their IPv4 configuration.  And this setup used to work - before we moved offices and ISP in March this year, we had been having a lot of straightforward service problems (an old telephone exchange!), and this problem started some time before we moved - I wondered if it might be concurrent with the arrival of IE9, but can't pin that down accurately.  We now have 64-bit W7 throughout, but before moving all but one of the old PCs was 32-bit Vista-based.

    Anyway, any further suggestions would be welcome!  I'll post here again if/when I find the answer!


    Friday, June 15, 2012 8:52 AM
  • Hi Frank,

    Thanks for the reply.

    However, in order to determine the issue, please let us know and test the following:

    1. Are the Cisco router and the Netgear SRXN3205 configured by yourself?

    2. Does the issue occur with all your clients?

    3. Check if the issue will still occur when using other browsers.

    4. How do you connect all the devices? If it is possible, please provide us a simple topology map.

    5. Please run command line “ipconfig /all” in your clients to make sure that they have used your internal DNS server address.

    6. Let us know how long it will take to ping your internal DNS server address and your ISP DNS server address from one of your clients.

    7. Run command line “tracert” and let us know the result.

    8. When the issue occurs, can you ping both and its IP address successfully from one client?

    Looking forward to your response.


    Jeremy Wu

    TechNet Community Support

    Wednesday, June 20, 2012 8:56 AM
  • Thanks, Jeremy - apologies for being slow to get the list worked through - I've been to all those places, but not as a single exercise - so here goes!

    1. The Cisco router is provided by the ISP, was installed at the beginning of May (we were running on the ADSL backup line up to that point - getting fibre installed is a black art requiring many weeks in old London town) and has an external IP address of 78.32.62.*-1.  It is configured (I am assured by them) simply to pass all traffic on our external address (78.32.62.*) straight on. Its only connection to our equipment is through the WAN port on the SRXN3205 (where an ADSL modem once connected in our previous office configuration).  I installed the SRXN3205 about 4 years ago, and the new ISP has not accessed it in any way that I am aware of.  Its status page looks fine to me.

    BK SRXN3205 Status Page

    2.  The isssue occurs on all workstations, and randomly, ie if one fails, it is not even likely that another will, as far as we have been able to determine.

    3. We do not use other browsers as a matter of course, and I have not so far provoked the problem with either Firefox or Safari or Chrome in very limited testing.

    4. Our network is very straightforward (pardon the Visio 2010 (sic) standard icons - I couldn't find any for current-looking kit (or even a Surface))

    BK Network Topology

    Just noticed that I forgot the separate Linux server that supports the telephonesystem, providing number lookup and automatic dialling from our contacts list.  It also connects directly to the Netgear switch (only).  The LAN cabling is new CAT5e throughout, from a reliable and fully-certified installer, and the incoming connetions to the InterNet are also new.  All the PCs (bar one) are also new, and all W7 64-bit.

    5 ipconfig/all:


    Windows IP Configuration

       Host Name . . . . . . . . . . . . : BKT01

       Primary Dns Suffix  . . . . . . . : bk.local

       Node Type . . . . . . . . . . . . : Hybrid

       IP Routing Enabled. . . . . . . . : No

       WINS Proxy Enabled. . . . . . . . : No

       DNS Suffix Search List. . . . . . : bk.local

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . : bk.local

       Description . . . . . . . . . . . : Broadcom NetXtreme 57xx Gigabit Controller

       Physical Address. . . . . . . . . : 00-22-19-19-D3-5E

       DHCP Enabled. . . . . . . . . . . : Yes

       Autoconfiguration Enabled . . . . : Yes

       Link-local IPv6 Address . . . . . : fe80::2893:6a92:c639:f8e4%11(Preferred)

       IPv4 Address. . . . . . . . . . . :

       Subnet Mask . . . . . . . . . . . :

       Lease Obtained. . . . . . . . . . : 21 June 2012 08:35:48

       Lease Expires . . . . . . . . . . : 29 June 2012 08:35:50

       Default Gateway . . . . . . . . . :

       DHCP Server . . . . . . . . . . . :

       DHCPv6 IAID . . . . . . . . . . . : 234889753

       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-17-3A-FE-D3-00-22-19-19-D3-5E

       DNS Servers . . . . . . . . . . . :

       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.bk.local:

       Media State . . . . . . . . . . . : Media disconnected

       Connection-specific DNS Suffix  . : bk.local

       Description . . . . . . . . . . . : Microsoft ISATAP Adapter

       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0

       DHCP Enabled. . . . . . . . . . . : No

       Autoconfiguration Enabled . . . . : Yes



    Pinging with 32 bytes of data:

    Reply from bytes=32 time<1ms TTL=128

    Reply from bytes=32 time<1ms TTL=128

    Reply from bytes=32 time<1ms TTL=128

    Reply from bytes=32 time<1ms TTL=128

    Ping statistics for

        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    Approximate round trip times in milli-seconds:

        Minimum = 0ms, Maximum = 0ms, Average = 0ms



    Pinging with 32 bytes of data:

    Reply from bytes=32 time=1ms TTL=59

    Reply from bytes=32 time=1ms TTL=59

    Reply from bytes=32 time=1ms TTL=59

    Reply from bytes=32 time=1ms TTL=59

    Ping statistics for

        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

    Approximate round trip times in milli-seconds:

        Minimum = 1ms, Maximum = 1ms, Average = 1ms



    Tracing route to []

    over a maximum of 30 hops:

      1    <1 ms    <1 ms    <1 ms

      2    <1 ms    <1 ms    <1 ms [78.32.62.*-1]

      3     1 ms    <1 ms    <1 ms []

      4     1 ms     1 ms     1 ms []

      5     1 ms     1 ms     1 ms [


      6     1 ms     1 ms     1 ms []

      7     *        *        *     Request timed out.

      8     1 ms     1 ms     1 ms []

      9     1 ms     4 ms     2 ms

     10     1 ms     1 ms     1 ms

    Trace complete.


    Tracing route to []

    over a maximum of 30 hops:

      1    <1 ms    <1 ms    <1 ms

      2    <1 ms    <1 ms    <1 ms [78.32.62.*-1]

      3     1 ms    <1 ms    <1 ms []

      4     1 ms     1 ms     1 ms []

      5     1 ms     1 ms     1 ms [


      6     1 ms     1 ms     1 ms []

      7     *        *        *     Request timed out.

      8     *        *        *     Request timed out.

      9     1 ms     1 ms     1 ms []

     10     2 ms     1 ms     4 ms

     11     1 ms     1 ms     1 ms []

    Trace complete.


    8. We are tring to trap this  - but in a busy work environment, it's not easy to get a user to break off and check.  My suspicion is that it will not prove helpful, since invariably, clicking 'refresh' immediately brings the page up.

    9. By way of further comment!

    The SRXN3205 also has a traceroute diagnostic, which I have tried every few minutes to - it shows a similar '*' line generally, but responses of around 10ms usually.  The only likely failure instance I have seen was where the response lag was after the route had entered the bbc domain, and it took nearly 50ms to respond.  Therefore, I incline to the view that it's not us, or our ISP, but the behaviour of some (probably intricate, or huge eg bbc) websites to respond satisfactorily quickly.  Could this be rectified by adjusting the patience exhibited by IE9 (ie extending its timeout thresholds)?

    We also have an external security certificate for which at times (eg the first time you use an external PC to access the Remote Web Workplace) produces a complaint, and you need to 'trust' the certificate.  Might this be causing some sort of justifiable delay through the security regime at the destination website?  If so, why randomly, rather than consistently?

    I look forward to your having the time to review the above!

    Best Regards


    • Edited by Frank Kay Friday, June 22, 2012 3:52 PM
    Friday, June 22, 2012 9:33 AM
  • Frank & Jeremy,

    This is interresting!  I am seeing exactly the same behavior from a user's new Windows 7 Professional SP1 64-bit computer in California.  The following notes accompany our particular circumstances.
      1) Similar LAN topology as described & depicted above:
        a. an ISP-provided static gateway (WAN; NAT>forwards everything non-VoIP to our router);
        b. VoIP phones;
        c. our (new - see 4.a.) router [192.168.0.x is DHCP-enabled; several MAC reservations outside DHCP pool, including symptomatic client at];
        d. NetGear 48-port switch;
        e. 4 computers on our 192.168.0.x network;
        f. 2 network printers (one via networked TrendNet Print Server switch);
        g. Linksys WAP (DHCP disabled from this hardware; just a Wi-Fi beacon);
        h. CCTV DVR;
        i. Credit Card POS data entry terminal.
      2) and represent sites that randomly generate our 'Internet Explorer cannot display the webpage' error.
      3) Among 4 Internet users on this LAN, only one (.0.10) experiences the problem.
      4) No problem 60 days ago, though since, we have identified the following changes:
        a. ISP replaced our (0.254) router (yes, they were generous, as this is on our side of 'their' hardware), and we have high confidencence the problem is not here;
        b. Symptomatic client (.0.10) was rebuilt from Win XP Pro SP3 32-bit that did NOT exhibit this issue, though the user primarily employed FireFox prior to rebuild;
        c. Database "server" (.0.1) was upgraded from Win XP Pro SP3 64-bit to new Windows 7 Professional SP1 64-bit;
      5) DNS Server settings in manual IPv4 configuration on symptomatic client point to, our router.

    So, I am posting because I am looking for a solution.  I have a few ideas, and I'm sure most of them have nothing to do with the problem.  I just want to identify the one that does!  :)

    A.  I used Windows Easy Transfer.  Could I have had a perfect Win 7 64-bit install, installed IE9, and then overwritten good IE9 registry entries for my 64-bit system with 32-bit garbage when I transferred settings from the WET file?  Hopefully, it was only cookies & Favorites, but I have no idea.  :|

    B.  Expanding on A., whenever the user experiences the issue, he calls me into his office, and now, we are logging the offending sites & pages.  I notice that the offenders all appear to run animation of one sort or another.  This possible pattern has me considering graphics handling in IE9.  Could WET have applied inappropriate values to the registry for objects or scripts like Silverlight, Flash, Java, or even the GPU/renderer from the old XP system?!?

    C.  One of the upgrade incentives I presented to this company was to "Get Genuine".  Prior to getting genuine, I have no idea if or how the system settings might have been ...finagled.  With a clean install on a bare OEM drive, could I have defeated my sterility purpose by applying WET settings from the old setup?

    Frank, did you all use WET when you upgraded from Vista?

    My environment is not terribly busy.  If you want me to run some evaluations on stuff, I'm happy to give it a shot.  Thank you for opening this thread!

    Post more soon, please!  :)


    Be conscientious always, exercise courtesy at every opportunity, & spend idle time thinking about how you can show consideration. No one will force you to be nice: everyone notices when you're not. It's neither easy nor hard, and it's always worth it!

    • Edited by Sierra Multimedia Thursday, October 11, 2012 4:02 PM Latent spelling & grammar issues arose when converting to HTML =}
    Thursday, October 11, 2012 3:56 PM
  • C:\Users\CabinoNet.BK>ipconfig/all

       DNS Servers . . . . . . . . . . . :

    That is a local address.  It shows that you are using the router for your DNS instead of using the real DNS; so if there is a timing problem in that relay with the real DNS, IE is made to think that the lookup cannot be done.

    You can use  netsh  (in a cmd window) to test using the real DNS without making any other changes.   E.g. to see that same information use:

         netsh  i  i  sh  dn

    and then if you like use a  set  command to change it to make it direct.

         netsh  i  i  se  dn  ?

     to see the syntax you would need to use.

    BTW using  ping  and  tracert  only show that you have addressability for the original host name and only prove connectivity for the  ICMP  protocol.   So, in particular, they do not prove that you have addressability for an alias' canonical host name nor do they prove connectivity for the protocol that you want to use, HTTP.

    To see the consequence of this let's use your example.

    First do an


    That looks like it should work Ok for IE.

    Then do

    ipconfig  /flushdns

    and then try to open that domain name using IE.   It would be even better in IE9 because then you could be tracing the requests using the Network Capture tool (in Developer Tools, e.g. via F12, Ctrl-Backtab,F5).   Tip:  the defaults are not helpful for tracing redirects, which is what we are expecting to see; so make sure that  Clear entries on navigate  menu items are both unchecked.

    What do you see in IE, e.g. as a normal user?

    What do you see in the IE Developer Tools, Network Capture (and in the Console tab)?

    What do you see in the cmd window with

    ipconfig  /displaydns

    My guess is that it is showing that   IE  is only getting as far as trying to open  e.g. as required by the first redirect and then getting stuck because the host name is an alias that you only see as a CNAME record?   Then what you could try is getting IE to try to do that actual lookup  and trace that.   In fact, you're lucky;  it redirects to where you want to be.  Sometimes, the caching host just gives an error when you try this but the point is that now you would have a lookup cached for IE to use--if that was the problem.   ;  )


    Good luck

    Robert Aldwinckle

    Thursday, October 11, 2012 7:15 PM
  •   2) and represent sites that randomly generate our 'Internet Explorer cannot display the webpage' error.

    @ Matthew

    Thanks for bringing this thread to my attention.  However, I think that your examples may be different, so would prefer you to open your own thread for discussing them further if you need more help.

    I think my tips to the OP should help you with your first example but probably not with your second, for which you should supply more details about what you are seeing.




    Thursday, October 11, 2012 7:32 PM
  • You're welcome - and thank you, Robert!

    I am following and troubleshooting with the OP because the behavior he reported is identical to what my user sees.  When I am certain about a positive or negative result from my tests, based on community proposals to the OP, I will return to update.  The examples and www.BBC.Net.UK produce media-heavy pages similar to my two examples.  Further, from ISP, to VoIP, to wireless, and throughout the rest of the OP's topology, our networks appear to be arranged identically.

    I'm confounded by the OP's experience on everyone's computers in his LAN.  This issue only affects 1 of 4 users on ours, even though all 4 Windows 7 Professional SP1 installations are configured exactly the same way, regarding DNS.  Nevertheless, I'm willing to try anything!  :)

    If I have nothing substantive to add, I will refrain from posting further.  If I need to open another (identically titled) thread; I can do that too, but then future users who share the issue we have would be led to pursue both threads under the same topic - for the same issue.  I think that would be unnecessarily cumbersome, and it could get confusing.

    Searching for solutions,


    Be conscientious always, exercise courtesy at every opportunity, & spend idle time thinking about how you can show consideration. No one will force you to be nice: everyone notices when you're not. It's neither easy nor hard, and it's always worth it!

    Thursday, October 11, 2012 9:48 PM