none
Remote Desktop License Issue RRS feed

  • Question

  • Hi,

    I am currently running Server 2016 as a Mulitpoint box.  The system has 5 workstations connected, all of which work without issue.

    When I attempt to login remotely, I receive an error;

    Remote Desktop License Issue

    There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes, Contact your system administrator to to fix this problem.

    After 58 minutes, you get a 2 minute warning.  After 2 more minutes Remote Desktop is disconnected. 

    I can log back in with Remote Desktop, get the same error, but am back exactly where I left off before being disconnected.  It's as if I disconnect the session without logging out, leaving the session still running.

    Any help is appreciated.

    Friday, March 17, 2017 5:59 PM

Answers

  • We have released a new fix for this issue.  Please install KB4025334:

    https://support.microsoft.com/en-us/help/4025334/windows-10-update-kb4025334

    You can also download the patch directly from the Microsoft update catalog:

    http://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4025334

    This update adds a new mechanism to correctly configure the RDSH license server.  However, you still need to select what type of CALs you will be using, per user or per device.  To do this, select the "Manage client access licenses" task from the Home tab.  You will be prompted to choose the Remote Desktop licensing mode.  Once you have selected a licensing mode, click OK, and the license mode and license server configuration will be set correctly.  

    Also, to add new client access licenses, click on the Add client access licenses link (it is just below where you select the licensing mode).  This link will take you to the RD Licensing Manager.  You will first need to activate the license manager, then you can add client access licenses.

    Make sure you purchase and install client access licenses that are the same type as the licensing mode you have chosen.  You can not use a per device client access license on a server configured to user per user client access licenses and vice versa.

    Friday, July 21, 2017 4:25 PM
    Moderator
  • Hi!

    Please try the following to activate the license server. It is currently not activated automatically and the following steps are needed.

    1. Launch Local Group      Policy Editor (gpedit.msc)
    2. In the left pane, navigate      to Local Computer Policy->Computer Configuration->Administrative      Templates->Windows Components->Remote Desktop Services->Remote      Desktop Session Host->Licensing
    3. In the right pane, right      click Use the specified Remote Desktop license servers and select Edit
    • In the group policy editor      dialog, select Enabled
    • Enter the local computer      name in the License servers to use: field.
    • Select OK
    1.  In      the right pane, right click Set the Remote Desktop licensing mode      and select Edit
      • In the grou policy editor       dialog, select Enabled
      • Set the Licensing mode       to Per Device/Per User
      • Select       OK

    Once the Licensing mode on the RDSH role is configured properly, the notification about the grace period goes away.

    Monday, March 20, 2017 4:31 PM

All replies

  • Hi!

    Please try the following to activate the license server. It is currently not activated automatically and the following steps are needed.

    1. Launch Local Group      Policy Editor (gpedit.msc)
    2. In the left pane, navigate      to Local Computer Policy->Computer Configuration->Administrative      Templates->Windows Components->Remote Desktop Services->Remote      Desktop Session Host->Licensing
    3. In the right pane, right      click Use the specified Remote Desktop license servers and select Edit
    • In the group policy editor      dialog, select Enabled
    • Enter the local computer      name in the License servers to use: field.
    • Select OK
    1.  In      the right pane, right click Set the Remote Desktop licensing mode      and select Edit
      • In the grou policy editor       dialog, select Enabled
      • Set the Licensing mode       to Per Device/Per User
      • Select       OK

    Once the Licensing mode on the RDSH role is configured properly, the notification about the grace period goes away.

    Monday, March 20, 2017 4:31 PM
  • Well I wish I had seen this reply earlier. We changed over from WMS 2012 and this error comes up all the time.

    Please fix this bug: this should really be taken care of during installation of the role.

    Thanks,

    Bavo

    Thursday, March 30, 2017 8:39 PM
  • Hi, I tried the solution, but it did not work.

    I also can set up only Per Device or Per User, not both, I guess that is what the article meant, just checking.

    Any other idea please?

    Thanks you 

    Monday, May 29, 2017 8:00 PM
  • You can add a license server, using op 127.0.0.1 & disable notifications, it is in the same gpo
    Thursday, June 1, 2017 8:24 PM
  • We have released a new fix for this issue.  Please install KB4025334:

    https://support.microsoft.com/en-us/help/4025334/windows-10-update-kb4025334

    You can also download the patch directly from the Microsoft update catalog:

    http://catalog.update.microsoft.com/v7/site/Search.aspx?q=KB4025334

    This update adds a new mechanism to correctly configure the RDSH license server.  However, you still need to select what type of CALs you will be using, per user or per device.  To do this, select the "Manage client access licenses" task from the Home tab.  You will be prompted to choose the Remote Desktop licensing mode.  Once you have selected a licensing mode, click OK, and the license mode and license server configuration will be set correctly.  

    Also, to add new client access licenses, click on the Add client access licenses link (it is just below where you select the licensing mode).  This link will take you to the RD Licensing Manager.  You will first need to activate the license manager, then you can add client access licenses.

    Make sure you purchase and install client access licenses that are the same type as the licensing mode you have chosen.  You can not use a per device client access license on a server configured to user per user client access licenses and vice versa.

    Friday, July 21, 2017 4:25 PM
    Moderator
  • This does not work... Trying to download and run it, it says it is not for my operating system?? Running Windows Server 2016 - Why does the file say windows10??
    Friday, July 20, 2018 5:40 PM
  • I have the same issue and the download at the bottom does not work. Multipoint shows that the licences are available but when a user signs in, it gives the warning screen.

    Tried the Group Policy editor route too and still not working

    Friday, July 20, 2018 5:42 PM
  • While the recommended download failed for all the reasons mentioned herein, the group policy edit resolved our MANY weeks of headaches for the Mac users of Citrix XenDesktop.
    
    Thanks for finally helping us to make the RDS License change that made the difference.







    • Edited by Zev- Wednesday, December 5, 2018 2:59 AM
    Wednesday, December 5, 2018 12:55 AM
  • Hi,

    Found Solution to this issue..  Sounds weird but it worked for me.. i had same issue in Server 2019 Data Center. After installing roles and features of Remote Desktop Services this error started appearing whenever i used to connect the RDP Session.

    The Administrative Tools in Control Panel has a folder called "Terminal Services" by default even if the server doesnt have Remote Desktop Services Roles & Features installed.

    This folder was accidentally deleted and since then the RDP Sessions started giving the warning 

    "Remote Desktop License Issue"

    "There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes, Contact your system administrator to to fix this problem"

    Solution:

    1. Create an empty folder on Desktop and name it as "Terminal Services"

    2. Copy and Paste this folder in "Administrative Tools" in "Control Panel"

    3. Restart the server and Connect RDP Session.

    4. Done.

    Note: Make sure that "RDP Cals" are installed and Server is activated. Also make sure to assign remote server name in GPEDIT.msc along with defining the RDP Cals used PER DEVICE or PER USER.


    Sunday, February 17, 2019 3:35 PM
  • Hi,

    Found Solution to this issue..  Sounds weird but it worked for me.. i had same issue in Server 2019 Data Center. After installing roles and features of Remote Desktop Services this error started appearing whenever i used to connect the RDP Session.

    The Administrative Tools in Control Panel has a folder called "Terminal Services" by default even if the server doesnt have Remote Desktop Services Roles & Features installed.

    This folder was accidentally deleted and since then the RDP Sessions started giving the warning 

    "Remote Desktop License Issue"

    "There is a problem with your Remote Desktop license, and your session will be disconnected in 60 minutes, Contact your system administrator to to fix this problem"

    Solution:

    1. Create an empty folder on Desktop and name it as "Terminal Services"

    2. Copy and Paste this folder in "Administrative Tools" in "Control Panel"

    3. Restart the server and Connect RDP Session.

    4. Done.

    Note: Make sure that "RDP Cals" are installed and Server is activated. Also make sure to assign remote server name in GPEDIT.msc along with defining the RDP Cals used PER DEVICE or PER USER.


    Sunday, February 17, 2019 3:36 PM
  • Hello,

    does not work for me!

    Have the same problem, looking for days for a solution (Message "Remote Desktop License Issue ... will be disconnected in 60 minutes)

    In the "Control Panel / Administrative Tools" folder there are / are 2 folders:
    - 1) Remote Desktop Services
    - 2) Terminal Services

    RDPCals per user are also installed.

    The best part:
    The server has a week without a license error message function, this came at some point after a reboot.The server is currently running in 120-day trial mode without using any of the installed RDPCals.

    I need a solution ...

    regards

    Wolfgang Schwarz, Fritzlar/Germany


    Wolfgang Schwarz

    Saturday, March 2, 2019 10:54 PM
  • Hello,

    did you find a solution?

    I have the same problem

    :(

    Wednesday, March 20, 2019 11:26 PM
  • Anyone found a solution?

    • Edited by Facult Monday, April 15, 2019 8:35 AM
    Monday, April 15, 2019 8:34 AM