none
Reinstallare Exchange 2007 su sbs 2008 RRS feed

  • Discussione generale

  • Ciao, causa mancanza elettricità il db di exchange si è rovinato, ho provato a ripristinarlo in tutti i modi indicati ma non c'è niente da fare; anche se inserisco nuovi utenti da outlook mi dà sempre disconesso...

    Come si fa reinstallare SOLO Exchange su SBS 2008?

    grazie


    Luca
    • Spostato Edoardo BenussiMVP venerdì 15 ottobre 2010 06:29 forum più consono (Da:Microsoft Windows Server Forum)
    • Tipo modificato Anca Popa mercoledì 20 ottobre 2010 09:49 ricerca di soluzione
    giovedì 14 ottobre 2010 16:27

Tutte le risposte

  • cosa significa "in tutti i modi?", che hai usato le utility di exchange tipo eseutil?

    non hai un backup?

    quale tipo di errore hai?

     


    Alberto Lissoni MCSA, MCTS, MCITP Server
    giovedì 14 ottobre 2010 16:44
  • Ma perchè vuoi reinstallare exchange per un db corrotto? smonta il DB e lancia un eseutil /mh e posta il risultato.

    --
    Peppacci - MVP -
    Microsoft Exchange Server
    http://blogs.sysadmin.it/peppacci/Default.aspx

    Peppacci - MVP - Microsoft Exchange Server http://blogs.sysadmin.it/peppacci/Default.aspx
    venerdì 15 ottobre 2010 07:42
    Moderatore
  • Ho usato le utility di exchange, ma senza risultato; ho smontato il db corrotto, ne ho creato uno nuovo, l'ho montato ma da outlook mi dà sempre "disconesso" anche se creo un nuovo utente... ho pensato che una reinstallazione potesse mettere a posto le cose...

    non ho utilizzato il comando eseutil, ho provato dagli strumenti di exchange.

    Provo e posto il risultato

    Grazie mille


    Luca
    venerdì 15 ottobre 2010 08:06
  • Ciao Luca,

    LO strumento per la correzione dei DB di exchange è ESEUTIL.

    Non ti preoccupare che, con questo strumento, quello che si può ripristinare si ripristina. In ultima battuta puoi usare il comando eseutil /P, che tralascia tutti i contenuti corrotti, ripristinandoti un database con "il salvabile".

    questo il rif. ufficiale:
    http://technet.microsoft.com/it-it/library/aa998249(EXCHG.80).aspx

     

    Ciao!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    lunedì 18 ottobre 2010 12:27
  • Ciao Luca,

    Direi che è l'ora di ricevere notizie!

    Intanto ringrazio tutti dell'interessamento e mi scuso per l'intromissione.


    Anca Popa
    Follow ForumTechNetIt on Twitter
    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft.
    martedì 19 ottobre 2010 10:02
  • Salve a tutti

    ho usato lo strumento ESEUTIL con l'opzione /P ma mi ha restituito un errore dicendo che il file o era in uso o era bloccato (il db era smontato); ho eseguito allora eseutil /mh e non ho trovato errori di sorta... (ho poi scoperto che avevo già usato eseutil ma dagli strumenti di exchange)

     Allora ho provato per assurdo a rimontare il db e... ci sono riuscito! (nel senso che prima mi dava sempre errore) Ora mi dà "montato" sul database;

    I client con outlook ora si connettono ad exchange, però non riescono ad ricevere le mail tra loro (nell'invio non segnala nessun errore).

    Segnalo che Exchange viene usato solo per la posta interna...

    Che fare?


    Luca
    martedì 19 ottobre 2010 10:36
  • Ciao,

    direi che dovresti:

    1. smontare il db
    2. ARRESTARE il servizio "archivio informazioni"
    3. eseguire eseutil /MH e POSTARE QUI IL RISULTATO
    4. eseguire eseutil /G e POSTARE QUI IL RISULTATO
    5. eventualmente usare di nuovo eseutil /P o /D o isinteg (dopo un BEL BACKUP, adesso che ti torna ONLINE) per riparare errori di database.

    Sarei propenso a credere, però, che il database adesso sia a posto. Controllerei per altre cose (magari, durante i tentativi, hai disattivato qualche servizio..)

    Ciao!


    Diego Castelli - MCSA 2003, MCP ISA 2004, MCTS Forefront. ITA: Questo post è fornito "così com'è". Non conferisce garanzie o diritti di alcun tipo. Ricorda di usare la funzione "segna come risposta" per i post che ti hanno aiutato a risolvere il problema e "deseleziona come risposta" quando le risposte segnate non sono effettivamente utili. Questo è particolarmente utile per altri utenti che leggono il thread, alla ricerca di soluzioni a problemi similari. ENG: This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    mercoledì 20 ottobre 2010 09:18
  • Ciao questi sono i risultati:

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.02
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating FILE DUMP mode...
             Database: database2.edb

            File Type: Database
       Format ulMagic: 0x89abcdef
       Engine ulMagic: 0x89abcdef
     Format ulVersion: 0x620,12
     Engine ulVersion: 0x620,12
    Created ulVersion: 0x620,12
         DB Signature: Create time:07/16/2010 10:09:32 Rand:83223439 Computer:
             cbDbPage: 8192
               dbtime: 446579 (0x6d073)
                State: Clean Shutdown
         Log Required: 0-0 (0x0-0x0)
        Log Committed: 0-0 (0x0-0x0)
       Streaming File: No
             Shadowed: Yes
           Last Objid: 1191
         Scrub Dbtime: 0 (0x0)
           Scrub Date: 00/00/1900 00:00:00
         Repair Count: 2
          Repair Date: 07/16/2010 10:06:48
     Old Repair Count: 2
      Last Consistent: (0x87F,356,A6)  10/20/2010 17:48:59
          Last Attach: (0x860,9,86)  10/18/2010 18:53:47
          Last Detach: (0x87F,356,A6)  10/20/2010 17:48:59
                 Dbid: 1
        Log Signature: Create time:05/11/2010 16:47:27 Rand:1445754 Computer:
           OS Version: (6.0.6002 SP 2 NLS 500100.50100)

    Previous Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Incremental Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Copy Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Previous Differential Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Full Backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

    Current Shadow copy backup:
            Log Gen: 0-0 (0x0-0x0)
               Mark: (0x0,0,0)
               Mark: 00/00/1900 00:00:00

         cpgUpgrade55Format: 0
        cpgUpgradeFreePages: 0
    cpgUpgradeSpaceMapPages: 0

           ECC Fix Success Count: none
       Old ECC Fix Success Count: none
             ECC Fix Error Count: none
         Old ECC Fix Error Count: none
        Bad Checksum Error Count: none
    Old bad Checksum Error Count: none

    Operation completed successfully in 0.826 seconds.

     

    Microsoft Windows [Versione 6.0.6002]
    Copyright (c) 2006 Microsoft Corporation. Tutti i diritti riservati.

    C:\Users\Giancarlo>cd desktop

    C:\Users\Giancarlo\Desktop>eseutil /g database2.edb

    Extensible Storage Engine Utilities for Microsoft(R) Exchange Server
    Version 08.02
    Copyright (C) Microsoft Corporation. All Rights Reserved.

    Initiating INTEGRITY mode...
            Database: database2.edb
      Temp. Database: TEMPINTEG8328.EDB

    Checking database integrity.

                         Scanning Status (% complete)

              0    10   20   30   40   50   60   70   80   90  100
              |----|----|----|----|----|----|----|----|----|----|
              ...................................................


    Integrity check successful.

    Operation completed successfully in 13.119 seconds.

     

    Credo che il database sia a posto, ma usando lo strumento verifica messaggi ho trovato questo errore:

     

    550 5.2.0 STOREDRV.Deliver: The Microsoft Exchange Information Store service reported an error. The following information should help identify the cause of this error: "MapiExceptionCallFailed:16.18969:F2070000, 17.27161:0000000066020000000000000200000000000000, 255.23226:00000000, 255.27962:7A000000, 255.27962:0A000000, 255.27962:0E000000, 255.27962:0A000000, 255.27962:94000000, 255.17082:15FAFFFF, 0.27745:15FAFFFF, 4.21921:15FAFFFF, 255.27962:FA000000, 255.1494:00000000, 255.1238:0F010480, 0.16668:0F010480, 0.27420:0F010480, 0.39497:0F010480, 4.55881:0F010480, 0.27676:0F010480, 0.23580:0F010480, 0.36537:0F010480, 4.5587:0F010480, 0.65193:0F010480, 0.16668:0F010480, 0.27420:0F010480, 0.39497:0F010480, 4.55881:0F010480, 0.27676:0F010480, 0.23580:0F010480, 0.36537:0F010480, 4.5587:0F010480, 0.65193:0F010480, 4.23921:EC030000, 6.21970:0F01048000806F670F010480, 4.24305:0F010480, 4.22257:15FAFFFF, 4.30449:15FAFFFF, 4.3007:15FAFFFF, 4.5318:15FAFFFF, 4.10104:15FAFFFF, 0.57449:0F010480, 4.6025:05000780, 4.5257:05000780, 4.4606:15FAFFFF, 255.1750:00000000, 0.26849:15FAFFFF, 255.21817:15FAFFFF".

    Qualcuno sa che cosa sia?


    Luca
    mercoledì 20 ottobre 2010 16:25
  • Ciao Luca,

    Il problema di cui sopra è stato corretto con l'Update Rollup 3 per Exchange Server 2007.

    Ti suggerisco di installare tutti gli aggiornamenti diponibili e di eseguire Windows Small Business Server 2008 Best Practices Analyzer

    Article ID: 932515 - Last Review: August 31, 2007 - Revision: 1.5
    You receive a 5.2.0 non-delivery report (NDR) message when you send an e-mail message to an Exchange 2007 server that is running the Isinteg.exe tool in a dismounted mailbox store


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    lunedì 25 ottobre 2010 07:52
  • Ciao, venerdì avevo fatto una ricerca ed avevo trovato la stessa soluzione; spero tra oggi e domani di postare il risultato degli aggiornamenti.

    grazie

     


    Luca
    lunedì 25 ottobre 2010 08:17
  • Niente da fare: innanzitutto era già presente l'SP2 di exchange quindi non non mi ha fatto fare l'update roll up 3; ho eseguito l'aggiornamento a sp3 ma continua a darmi lo stesso errore;

    Eseguendo il BPA mi haq restituito i seguenti errori:

    DNS PORT (udp 539) status:

    EDNS is enabled

    EDNS is enabled on this server. Some of the routers or firewalls may not support EDNS. You should disable EDNS on this server. To do so, click Start, and then click Command Prompt. In the Command Prompt window, type dnscmd /Config /EnableEdnsProbes 0 and then restart the DNS Server service.

    local activation permission to the IIS Wamreg Admin Service is required

    The Network Service is missing local activation permissions to the IIS WAMREG admin Service in accordance with the event ID 10016 in the system event log. For more information, see KB "Event ID error messages 10016 and 10017 are logged in the System log after you install Windows SharePoint Services 3.0" at http://go.microsoft.com/fwlink/?LinkId=128063. Note: This warning will continue to appear until at least 24 hours have passed since the most recent occurrence of event 10016

    The set up internet address task has not been run

    the firewall is disabled

    the windows sharepoin services routing extension does not exist

    two or more network adapter cards detected

    Per il problema riguardante l'EDSN Ho provato ad eseguire il comando indicato ma mi restituisce questo:

    Reimpostazione della proprietà del Registro di sistema sul server DNS non riuscita.
        Stato = 5 (0x00000005)
    Comando non riuscito:  ERROR_ACCESS_DENIED     5

    Mi date qualche altro suggerimento?

    The DNS Server service should listen on DNS port 53, but that port is owned by the process


    Luca
    giovedì 28 ottobre 2010 08:54
  • A me sembra che questo sbs abbia un po di problemi:

    ad es. deve esserci solo una scheda di rete, inoltre sembra che tu non abbia eseguito i task dalla console di sbs.

    se questo sbs non e`in produzione ti conviene rifarlo da zero.

     


    Alberto Lissoni MCSA, MCTS, MCITP Server
    giovedì 28 ottobre 2010 10:55
  • Per la scheda di rete non ci sono problemi, la disattivo dal bios e non avrò più il messaggio, giusto?

    Per gli altri "alert" (tranne i primi due): l'indirizzo internet non è impostato perchè (al momento) non ne hanno bisogno, inoltre al momento non possiedono un contratto con il provider di servizi internet che gli permetta di avere un indirizzo ip statico e un dominio di secondo livello tal da permettere di registrare il sito "remote.xxx.xxx".

    Volevo sapere se i primi due problemi elencati potrebbero avere a che fare con l'errore che mi restituisce Exchange ed eventualmente come risolverli (anche perchè l'SBS non è in produzione).

    L'ultima alternativa è reinstallare Exchange ma da SBS non se e come si fa

    Grazie comunque


    Luca
    giovedì 28 ottobre 2010 12:28
  • ok, disattiva la scheda, dopodiche` devi assolutamente far partire il wizard di sbs, altrimenti non fa partire gli altri servizi, in questo modo dovresti risolvere i problemi.

    un IP statico e`fortemente consigliato, anche se non usi i servizi remote etc..

     


    Alberto Lissoni MCSA, MCTS, MCITP Server
    giovedì 28 ottobre 2010 15:44
  • disattivata la scheda, fatto partire il wizard, ma l'echange mi restiutisce sempre nella verifica messaggi sempre lo stesso errore:

    Si può reinstallare exchange senza reinstallare sbs?


    Luca
    martedì 16 novembre 2010 10:34
  • Io non ho mai provato a disinstallare exchange da sbs2008, e non so se sia neanche possibile; in qualsiasi caso ti conviene rifare tutto sbs, altrimenti rischi di peggiorare la situazione.

    prova a fare un tentativo: lancia dalla console di sbs risolvi problemi di rete, lo trovi sotto rete/connettivita`, e vedi cosa ti dice.

    Puoi inoltre rispedire gli errori?

     

     


    Alberto Lissoni MCSA, MCTS, MCITP Server
    martedì 16 novembre 2010 16:46
  • Volendo puoi seguire qui:

    # Repair Microsoft Exchange Server roles in Windows Small Business Server 2008

    http://technet.microsoft.com/en-us/library/dd728006.aspx


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    martedì 16 novembre 2010 17:22
  • Già fatto, l'unico problema che mi dà riguarda il fatto che il server non ha il ruolo DHCP, cosa che fa il router (e che era già così prima dei problemi) . X il resto ho lanciato la BPA e gli errori sono stati postati sopra...
    Luca
    mercoledì 17 novembre 2010 09:01
  • Grazie, proverò e posterò i risultati.
    Luca
    mercoledì 17 novembre 2010 09:02
  • Però ti raccomando vivamente di configurare il DHCP di SBS anzichè quello del router.


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    mercoledì 17 novembre 2010 09:06
  • Il problema è che ci ho provato una volta, ed oltre al fatto che il telefono voip di telecom non funzionava più, non credo di averlo fatto a regola d'arte. Puoi indirizzarmi su una guida?

    Grazie


    Luca
    mercoledì 17 novembre 2010 09:44
  • sbs vuole il suo dhcp attivo, e nessun altro sulla rete.

    prova qui sotto, ma ne trovi anche altre di guide.

    http://technet.microsoft.com/it-it/library/cc732584(WS.10).aspx

     


    Alberto Lissoni MCSA, MCTS, MCITP Server
    mercoledì 17 novembre 2010 09:55
  • nelle istruzioni si parla di usare la cartella del SP2 se installato:

    You can skip this step if Microsoft Exchange Server 2007 with Service Pack 2 is installed on the server, and if you are using the Exchange Server 2007 SP2 installation folder as the source for the Exchange Server 2007 installation files.

    Se c'è l'SP3 devo usare sempre (quando richiesto) la cartella del SP2?


    Luca
    mercoledì 17 novembre 2010 10:39
  • Ciao a tutti, cercando una soluzione al mio problema, mi sono imbattuto in questo thread, che forse può aiutarmi. Nuova installazione Windows 2008 SBS x64. Prima configuriamo il dominio, poi migriamo gli utenti da windows 2003 server. Ci fermiamo per la pausa natalizia, a gennaio torniamo per configurare Exchange 2007...che non si trova nella cartella programmi. Nessun link, alla Managemente console. Pensando che nella sbs 2008 andasse installato a mano, inseriamo il 2° CD di WIndows SBS 2008 e sotto la cartella E:\CMPNENTS\Exchange12 troviamo il setup di Exchange 2007, si installa, parte, ma sorpresa: versione di prova che scade dopo 120 gg !!! Come facciamo a ripristinare la nostra (unica) copia di Exchange inclusa in Windows 2008 SBS senza avere un Serial number da dover inserire? Grazie per l'aiuto!!!
    giovedì 27 gennaio 2011 21:24