none
WSUS: Problema inserimento client per distribuzione RRS feed

  • Domanda

  • Ciao a tutti, ho un problema con l'inserimento dei client per la distribuzione all'interno della console di WSUS su Windows Server 2012.

    Non volendo agire su ogni singolo client configurando le policy locali, mi chiedevo se c'era un modo per inserire tutti i cliente della rete da WSUS.Ho già modificato le group policy da server WSUS abilitando windows update per tutti i dispositivi e indicando il percorso del server, continuo però a non vedere nemmeno 1 pc.

    Ho riavviato già il server e fatto gpupdate /force sul singolo client.

    Qualcuno ha qualche suggerimento?

    mercoledì 17 giugno 2015 08:36

Risposte

  • Grazie a tutti ragazzi per il vostro aiuto!

    Ho risolto, in pratica l'errore era molto più banale di quanto si potesse pensare.

    La configurazione era corretta solo che nella group policy, dove dovevo specificare il percorso del server tramite http://, era necessario inserire il nome completo specificando la porta di IIS:

    io avevo messo: http://mioserver

    ed invece andava scritto: http://mioserver.local:8530

    Grazie ancora a tutti!

    venerdì 19 giugno 2015 07:25

Tutte le risposte

  • ciao, ti giro l'ottimo step by step di un collega, controlla i passi che hai fatto se sono corretti, alla fine trovi anche il deployment per i client.

    A.

    https://mizitechinfo.wordpress.com/2013/08/19/step-by-step-installing-configuring-wsus-in-server-2012-r2/

    mercoledì 17 giugno 2015 09:05
    Moderatore
  • Purtroppo non è possibile, bisogna attendere la comunicazione dei client (che non è immediata e può richiedere del tempo a seconda dell'intervallo di ricerca aggiornamenti configurato nel computer client).

    Per prima cosa verifica con il WSUS Client Diagnostic Tool che le policy siano state configurate correttamente e che il server risulti effettivamente raggiungibile.

    Se non vengono segnalati errori prova ad attendere fino a 24 ore, se ancora non compare alcun PC in elenco immagino che tutti i computer siano stati preparati dalla stessa immagine. In tal caso potrebbe essere presente un'anomalia nella procedura di sysprep (ad esempio mancato sysprep durante la distribuzione o skipREARM abilitato) o nell'immagine master relativa ai componenti di Windows Update e quindi propagata ad ogni client(capita soprattutto se l'immagine master era stata preparata basandosi su un'immagine OEM invece di eseguire una nuova installazione).

    In quest'ultimo caso ti consiglio di provare a reimpostare i componenti di Windows Update seguendo le indicazioni presenti in questa pagina: https://support.microsoft.com/it-it/kb/971058

    mercoledì 17 giugno 2015 09:08
    Moderatore
  • Ciao, ho configurato il server creando una policy di gruppo chiamata WSUS Policy e applicata al gruppo dei computer di active directory chiamato: Dispositivi.

    Contestualmente ho creato un gruppo nella console WSUS avente lo stesso nome di quella di AD: Dispositivi.

    Ho fatto eseguire il tool e mi ha dato questo risultato. Sembra tutto ok, no? Al momento ancora non vedo alcun computer. E' normale?

    mercoledì 17 giugno 2015 12:13
  • a volte passano anche 24 ore perchè ci sia un aggancio corretto di client. ti consiglio di aspettare un po e vedere se compare qualcosa.
    mercoledì 17 giugno 2015 12:20
    Moderatore
  • Se possibile esegui nuovamente il tool di diagnostica in un client con installazione a 32 bit in quanto non funziona correttamente in client x64 (errore 0x80070002).

    In ogni caso riporta anche l'output del file di log "WindowsUpdate.log":

    https://support.microsoft.com/it-it/kb/902093

    mercoledì 17 giugno 2015 20:58
    Moderatore
  • Ciao, vi aggiorno sulla situazione.

    Ad oggi ancora non vedo nessun client nel gruppo di default "computer non assegnati" nella console di WSUS.

    Mi sorge un dubbio però, nelle impostazioni per l'aggiunta dei client ci sono 2 opzioni:

    1) Usa la console update services

    2) Usa criteri di gruppo o impostazioni del registro di sistema sui computer.

    Io ho scelto la prima opzione proprio perchè non voglio andare su ogni singolo pc a modificare le chiavi di registro visto che sono più di 100!!!

    La scelta è corretta?

    Anche se sicuramente in questo periodo i pc connessi sono veramente pochi mi sembra strano però che non ne veda nemmeno uno. Per vederli, i client si devono connettere in automatico almeno una volta in windows update giusto? Mi piacerebbe verificare se i client hanno ricevuto la policy di gruppo impostata su server dove specifico il percorso per gli aggiornamenti.....

    Dallo screenshot sopra, la configurazione lato server dovrebbe essere ok giusto?

    giovedì 18 giugno 2015 10:38
  • Il log di windows update lo devo estrarre dai client o dal server?
    giovedì 18 giugno 2015 10:48
  • Quindi mi confermi che basta configurare le group policy su Server WSUS per fare agganciare i client giusto?

    Non devo apportare alcuna modifica su di essi?

    giovedì 18 giugno 2015 13:36
  • Se si dovesse passare su ogni client a mettere una flag che AD sarebbe? ;-)
    giovedì 18 giugno 2015 14:07
    Moderatore
  • Il log di windows update lo devo estrarre dai client o dal server?
    Dal client.
    giovedì 18 giugno 2015 14:55
    Moderatore
  • Per vederli, i client si devono connettere in automatico almeno una volta in windows update giusto? Mi piacerebbe verificare se i client hanno ricevuto la policy di gruppo impostata su server dove specifico il percorso per gli aggiornamenti.....

    Dallo screenshot sopra, la configurazione lato server dovrebbe essere ok giusto?

    Si, un computer per essere visibile deve richiedere automaticamente al server gli aggiornamenti mediante il servizio Windows Update.

    Per verificare se la Group policy è applicata correttamente puoi anche utilizzare anche gli strumenti RSOP o Gpresult lato client.

    Come ti dicevo dallo screenshot si può solo vedere una parte dei test in quanto il client dove è stato eseguito è 64 bit e la procedura restituisce errore. Puoi utilizzare in alternativa questo tool della Solarwinds:

    http://www.solarwinds.com/products/freetools/diagnostic-tool-for-wsus-agent.aspx

    giovedì 18 giugno 2015 15:03
    Moderatore
  • Grazie a tutti ragazzi per il vostro aiuto!

    Ho risolto, in pratica l'errore era molto più banale di quanto si potesse pensare.

    La configurazione era corretta solo che nella group policy, dove dovevo specificare il percorso del server tramite http://, era necessario inserire il nome completo specificando la porta di IIS:

    io avevo messo: http://mioserver

    ed invece andava scritto: http://mioserver.local:8530

    Grazie ancora a tutti!

    venerdì 19 giugno 2015 07:25