none
Avviso di protezione di Outlook "il nome del certificato..." RRS feed

  • Discussione generale

  • Buongiorno,

    prima di essere lapidato pubblicamente sappiate che sono giorni che leggo i post del forum e tutto quello che sono riuscito a trovare su internet ma il problema rimane.

    Lo scenario è questo:

    Server SBS 2011 Standard con tutti gli aggiornamenti installati

    Ho comprato un certificato SSL per l'OWA e i servizi web con il solo nome esterno del server

    Client nel dominio con Outlook 2010: ogni tot minuti compare la famosa finestra di warning sul certitificato perchè il nome non corrisponde

    Cose fatte:

    Ho seguito quanto ho trovato su questi link e molti altri:

     http://support.microsoft.com/kb/940726/it 

    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover-part2.html

    http://geekswithblogs.net/BWCA/archive/2010/07/02/exchange-2010-deployment-notes-ndash-certificate-issue.aspx

    Ho creato l'host con il nome esterno sul DNS per la risoluzione del nome. Sempre sul DNS ho impostato anche l'host autodiscover per la risoluzione interna

    In exchange management console --> configurazione server--> accesso client in tutti i tab (Outlook web app, pannello di controllo exchange, exchange active sync, distribuzione  rubrica offline, pop3 e imap4) ho impostato l'URL interno uguale all'URL esterno.

    In questo momento sono piuttosto confuso e sinceramente non so più cosa fare!

    Qualche idea?

    Grazie a tutti per l'attenzione

    • Tipo modificato Anca Popa mercoledì 17 ottobre 2012 13:11 in attesa di ulteriori feedback
    lunedì 15 ottobre 2012 09:06

Tutte le risposte

  • Apri Outlook e lancia la Prova configurazione automatica posta elettronica:

    http://www.addictivetips.com/microsoft-office/outlook-2010-test-email-auto-configuration/

    Lascia lo spunto solo su "Usa AutoDiscover".

    Nel risultato, controlla a dove punta il protocollo RPC Exchange.

    Ciao,


    Dario Palermo

    mercoledì 17 ottobre 2012 09:32
  • Lancia anche questo comando:

    Get-ClientAccessServer -Identity <nomeserver> | FL

    e controlla la stringa: AutoDiscoverServiceInternalUri

    Dove punta?

    Ciao,


    Dario Palermo

    mercoledì 17 ottobre 2012 09:34
  • Ciao Leonardo,

    In attesa di ulteriori feedback, ho cambiato questo thread in discussione generale.

    Grazie di tenerci aggiornati sul tuo percorso,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    mercoledì 17 ottobre 2012 13:10
  • Grazie per le risposte.

    Ho fatto i test che mi hai suggerito, qua sotto incollo i risutati. Prima però faccio delle precisazioni

    Il certificato è stato emesso per l'host OWA.MioDominioPosta.IT

    Il server di Exchange si chiama MioServer.dominio.local

    MioDominioPosta e dominio.local sono differenti, come dire che il dominio si chiama pippo.local mentre le mail sono @pluto.it

    L'owa e gli altri servizi web funzionano perfettamente connettendosi all'indirizzo Https://OWA.MioDominioPosta.IT/owa

    Questo è il risultato del test Autodiscovery di Outlook

    <?xml version="1.0" encoding="utf-8"?>
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
      <Response xmlns="http://schemas.microsoft.com/exchange/autodiscover/outlook/responseschema/2006a">
        <User>
          <DisplayName>Utente Domino</DisplayName>
          <LegacyDN>/o=first organization/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=Utente Dominoc978ca1e</LegacyDN>
          <AutoDiscoverSMTPAddress>utente@MioDominioPosta.IT</AutoDiscoverSMTPAddress>
          <DeploymentId>54bcf4ce-c987-45ef-883f-1dc824fc42c9</DeploymentId>
        </User>
        <Account>
          <AccountType>email</AccountType>
          <Action>settings</Action>
          <Protocol>
            <Type>EXCH</Type>
            <Server>MioServer.dominio.local</Server>
            <ServerDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EDNFIRENZE</ServerDN>
            <ServerVersion>738180DA</ServerVersion>
            <MdbDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Configuration/cn=Servers/cn=EDNFIRENZE/cn=Microsoft Private MDB</MdbDN>
            <PublicFolderServer>MioServer.dominio.local</PublicFolderServer>
            <AD>MioServer.dominio.local</AD>
            <ASUrl>https://MioServer.dominio.local/EWS/Exchange.asmx</ASUrl>
            <EwsUrl>https://MioServer.dominio.local/EWS/Exchange.asmx</EwsUrl>
            <EcpUrl>https://OWA.MioDominioPosta.IT/ecp/</EcpUrl>
            <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>
            <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>
            <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>
            <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>
            <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>
            <OOFUrl>https://MioServer.dominio.local/EWS/Exchange.asmx</OOFUrl>
            <UMUrl>https://MioServer.dominio.local/EWS/UM2007Legacy.asmx</UMUrl>
            <OABUrl>https://OWA.MioDominioPosta.IT/oab/945a5fe7-9b6b-4204-aa04-3c33cd6e50e2/</OABUrl>
          </Protocol>
          <Protocol>
            <Type>EXPR</Type>
            <Server>OWA.MioDominioPosta.IT</Server>
            <SSL>On</SSL>
            <AuthPackage>Ntlm</AuthPackage>
            <ASUrl>https://OWA.MioDominioPosta.IT/</ASUrl>
            <EwsUrl>https://OWA.MioDominioPosta.IT/</EwsUrl>
            <EcpUrl>https://OWA.MioDominioPosta.IT/ecp/</EcpUrl>
            <EcpUrl-um>?p=customize/voicemail.aspx&amp;exsvurl=1</EcpUrl-um>
            <EcpUrl-aggr>?p=personalsettings/EmailSubscriptions.slab&amp;exsvurl=1</EcpUrl-aggr>
            <EcpUrl-mt>PersonalSettings/DeliveryReport.aspx?exsvurl=1&amp;IsOWA=&lt;IsOWA&gt;&amp;MsgID=&lt;MsgID&gt;&amp;Mbx=&lt;Mbx&gt;</EcpUrl-mt>
            <EcpUrl-ret>?p=organize/retentionpolicytags.slab&amp;exsvurl=1</EcpUrl-ret>
            <EcpUrl-sms>?p=sms/textmessaging.slab&amp;exsvurl=1</EcpUrl-sms>
            <OOFUrl>https://OWA.MioDominioPosta.IT/</OOFUrl>
            <OABUrl>https://OWA.MioDominioPosta.IT/oab/945a5fe7-9b6b-4204-aa04-3c33cd6e50e2/</OABUrl>
          </Protocol>
          <Protocol>
            <Type>WEB</Type>
            <Internal>
              <OWAUrl AuthenticationMethod="Basic, Fba">https://OWA.MioDominioPosta.IT/owa/</OWAUrl>
              <Protocol>
                <Type>EXCH</Type>
                <ASUrl>https://MioServer.dominio.local/EWS/Exchange.asmx</ASUrl>
              </Protocol>
            </Internal>
            <External>
              <OWAUrl AuthenticationMethod="Fba">https://OWA.MioDominioPosta.IT/owa/</OWAUrl>
              <Protocol>
                <Type>EXPR</Type>
                <ASUrl>https://OWA.MioDominioPosta.IT/</ASUrl>
              </Protocol>
            </External>
          </Protocol>
          <AlternativeMailbox>
            <Type>Delegate</Type>
            <DisplayName>Alias</DisplayName>
            <LegacyDN>/o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=Alias</LegacyDN>
            <Server>MioServer.dominio.local</Server>
          </AlternativeMailbox>
        </Account>
      </Response>
    </Autodiscover>

    Questo il risultato del comando sulla shell di Exchange

    AutoDiscoverServiceInternalUri       : https://autodiscover.MioDominioPosta.IT/autodiscover/autodiscover.xml

    Grazie per qualsiasi dritta possiate darmi

    PS: mi sono accorto che l'errore di certificato adesso viene emesso due volte. Sull'intestazione della prima finestra c'è scritto MioDominioPosta.IT, metre sulla seconda finestra c'è scritto MioServer.dominio.local

    Saluti

    mercoledì 17 ottobre 2012 14:11
  • Ci sono vari puntamenti al dominio locale. Prova a rifare la procedura di modifica degli url usando la shell.

    http://blogs.technet.com/b/danielkenyon-smith/archive/2010/05/13/the-name-on-the-certificate-is-invalid-or-does-not-match-the-name-of-the-site-part-2.aspx

    Ciao,


    Dario Palermo

    mercoledì 17 ottobre 2012 15:37
  • Grazie,

    rifaccio la procedura e vediamo un po'.


    Ciao

    mercoledì 17 ottobre 2012 15:44
  • Rifatta procedura come da tuo post,

    attendo feedback dagli utenti...

    giovedì 18 ottobre 2012 09:42