none
windows 2008 server desktop remoto blank screen RRS feed

  • Discussione generale

  • Buongionrno,

    ho il seguente problema accedendo tramite desktop remoto ad windows 2008 server 64bit foundation R2.

    In rete locale il seguente problema non si presenta.

    Non vi è alcun firewall attivato.

    La sede dispone di una connessione ALICE ADSL 20MB.

    Collegandomi dall'esterno (ADSL ALICE ) tramite desktop remoto riesco ad accedere senza problemi; i problemi nascono quando decido di ridurre a icona la sessione; infatti se dopo alcuni minuti ( circa 2 ma è un tempo variabile ) faccio doppio click sull'icona mi si presenta per almento 30 secondi una schermata completamente nera, che a volta dopo 30 secondi sparisce ripresentandomi la sessione a volte invece causa la disconessione della sessione.

    Il problema si presenta da qualunque sede esterna io mi colleghi, anche attraverso un connessione UMTS.

    • Tipo modificato Fabrizio Volpe martedì 15 febbraio 2011 11:22 Mancato feeedback utente
    martedì 26 ottobre 2010 09:24

Tutte le risposte

  • Se usi un TS gateway, il problema è che l'attività RDP viene vista come una normale connessione HTTPS e va in timeout dopo un tot di secondi.

    Se le cose stanno così, devi scoprire se è IIS o uno degli apparati di rete che termina la  sessione e alzare i timeout.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 26 ottobre 2010 09:38
  • Hai provato da qualche altra connessione piu' veloce dell' umts? Io proverei anche ad abbassare le prestazione dell' rdp, andando in OPZIONI sotto il tab PRESTAZIONI lo porterei sul valore WAN (con latenza elevata)

    Saluti

    martedì 26 ottobre 2010 09:55
  • cosa pubblica questo rdp su internet ?

    è semplicemente nattata la 3389 dall'ip pubblico del router all'ip privato del terminal server ?


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    martedì 26 ottobre 2010 09:56
    Moderatore
  • Non vi è nessun TS GATEWAY, grazie
    martedì 26 ottobre 2010 13:32
  • Non mi sono spiegato bene, le conessioni remoto che presentano sempre lo stesso problema sono di varia tipo: ADSL ALICE, ADSL TELE2 UMTS. Ecc.

    Il client RDP è cmq sempre configurato per lavorare a bassa risoluzione e lasciando l'audio sul pc remot.

     

    martedì 26 ottobre 2010 13:34
  • Esatto, la seconda che hai detto.
    martedì 26 ottobre 2010 13:34
  • non c'è alcun basic firewall di alcun tipo ?

    comunque capita spesso anche me quando uso l'rdp verso altre sedi connesse in vpn ma non mi faccio troppi problemi,

    chiudo la sessione rdp e la rilancio.


    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    martedì 26 ottobre 2010 14:35
    Moderatore
  • Non c'è nessun firewall e nessuna VPN, fa tutto il router.

    Per quanto riguarda la tua considerazione potrei essere d'accordo, se non chè con il server precedente ( dotato di WINDOWS 2003 SERVER ) il problema non si poneva. E il cliente non paga.....

    martedì 26 ottobre 2010 15:47
  • Prova a impostare i parametri di timeout delle sessioni tramite group policy o con una policy locale.

    http://technet.microsoft.com/en-us/library/cc758177(WS.10).aspx

    Comunque, se a parità di utente, il problema in LAN non si verifica e tramite rete remota invece si, mi sembra probabile che il problema NON sia il server terminal.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 26 ottobre 2010 17:46
  •  E il cliente non paga.....


    al giorno d'oggi qualsiasi scusa è buona per non pagare e questa è proprio una scusa bella e buona.
    Edoardo Benussi - Microsoft® MVP
    Management Infrastructure - Systems Administration
    https://mvp.support.microsoft.com/Profile/Benussi
    Windows Server Italian Forum Moderator
    edo[at]mvps[dot]org
    mercoledì 27 ottobre 2010 07:07
    Moderatore
  • I parametri erano già settati correttamente, come da tue undicazioni, grazie.

    lunedì 1 novembre 2010 21:06
  • Grazie della solidarieta.
    lunedì 1 novembre 2010 21:07
  • Ovvero il problema persiste ?
    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 2 novembre 2010 09:50
  • si persiste
    mercoledì 3 novembre 2010 17:27
  • Suggerimento banale (ma molti trascurano la cosa) : non è che PER CASO c'è lo screensaver impostato ?

    Prova a mettere in disble (sia dall'utente che tramite policy) lo screensaver.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    mercoledì 3 novembre 2010 22:50
  • Tuttto disattivo....
    giovedì 4 novembre 2010 11:50
  • A questo punto puoi provare ad attivare il logging e vedere se ci sono eventi significativi

    http://support.microsoft.com/kb/327508/en-us

    Comunque, se l'unica differenza è fra utenti LAN e utenti remoti, difficilmente il problema sarà sul server.

    Gli utenti LAN accedono allo stesso IP e stessa scheda di rete di quelli "remotizzati" ?

    Non è che il NAT che effettui ha dei timeout ? 


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 4 novembre 2010 14:40
  • Non penso che dipenda dalla connessione, o dal fatto di aver iconizzato la sessione...

    Probabilmente è più dovuto al tempo di inattività e alla sospensione della sessione che non si riesce più a riattivare da remoto..

    Io cercherei GPO o impostazioni che sospendono la sessione, ad esempio:

    Computer Configuration/Windows settings/Security Settings/Local Policy/Security Options/Microsoft network server: Amount of idle time before suspending session

    Oppure, come indicato da Fabrizio, impostazioni nelle screen saver, nei tempi di inattività....


    Adriano Mariolini MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]my.sysadmin.it
    giovedì 4 novembre 2010 15:53
  • @Adriano : dopo aver fatto le verifiche precedenti, io punterei a capire se c'è qualcosa legato agli apparati di rete lato Internet.

    Le GPO / Policy valgono (potenzialmente) per tutti quelli che utilizzano il server e qui l'unica discriminante sembra il tipo di connessione.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    venerdì 5 novembre 2010 08:58
  • Buongiorno,

    faccio parte di un ufficio IT che segue una catena di negozi che si collegano in remoto ad un server tramite RDP.

    Ho riscontrato ultimamente che con i nuovi apparati forniti da Telecom per ALICE ADSL si verifica l'inconveniente della disconnessione delle sessioni termial inattive.

    Presso un punto vendita abbiamo "risolto" la questione sostituendo il modem ALICE GATE 2 PLUS WI-FI con uno che avevamo a disposizione NON WI-FI e il problema non si è ripresentato.

    Navigando su altri forum ho trovato altre esperienze che sembrano indicare che ci sia un'impostazione negli ultimi modem ALICE che disconnette le sessioni internet inattive per liberare il traffico.

    Sono comunque anch'io alla ricerca di una soluzione anche perchè non in tutti negozi ho a disposizione un secondo modem da utilizzare.

    venerdì 5 novembre 2010 09:10
  • Grazie per l'indicazione Claudio.

    Potrebbe essere una ulteriore conferma del fatto che il problema non è lato "server".

    @Lorenzo : se hai modo di provare un altro router / modem mi sembrerebbe una buona idea.


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    venerdì 5 novembre 2010 09:21
  • Vero quanto dici, ma diverso è "risvegliare" un sistema andato in standby o una sessione sospesa dall'interno di una lan rispetto che da remoto...

    Comunque dai post che seguono si direbbe che il problema sia legato a un particolare tipo di router...


    Adriano Mariolini MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]my.sysadmin.it
    venerdì 5 novembre 2010 10:12
  • Ciao, la scheda di rete è una sola, tra l'altro già sostitiuita per cercare di rsiolvere questo problema. Ho controllato sul router se esiste dei timeout nel NAT ma non vi è nessun valore specifico; ho però visto che era attivo un servizio di firewall che ho provveduto momentaneamente a disabilitare. Vediamo.
    sabato 6 novembre 2010 15:41
  • Ciao, ti chiedo maggiori dettagli, non ho grande esperienza con le GPO, grazie.

     

    domenica 7 novembre 2010 15:31
  • Discorso lungo... (qui trovi una guida: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=73d96068-0aea-450a-861b-e2c5413b0485&DisplayLang=en)

    Dovresti dire se si tratta di un server all'interno di un dominio o meno.

    Nel secondo caso accedi alle policy con il comando gpedit.msc

    Altrimenti devi utilizzare la GPMC per gestire le varie gpo linkate al dominio...

    Se descrivi meglio la situzione della rete possiamo darti indicazioni più precise


    Adriano Mariolini MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]my.sysadmin.it
    domenica 7 novembre 2010 21:05
  • Visto che nemmeno la disattivazione del servizio di firewall del router ha sortito l'effetto desiderato, credo proprio che a questo punto suggerirò al cliente di sostituire il router di alice stesso.

    lunedì 8 novembre 2010 12:35
  • Visto che nemmeno la disattivazione del servizio di firewall del router ha sortito l'effetto desiderato, credo proprio che a questo punto suggerirò al cliente di sostituire il router di alice stesso.


    Mi sembra ragionevole.

    Attenzione perchè con alcuni contratti Alice il NAT funziona solo con il loro apparato.

    IMHO verifica il tipo di contratto PRIMA di proporre la faccenda :-)


    Fabrizio Volpe
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    lunedì 8 novembre 2010 12:43
  • Ho modificato questo thread in "Discussione" visti i tempi trascorsi.

    Restiamo a disposizione se il problema fosse ancora non risolto o per conoscere la soluzione eventualmente applicata.


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 15 febbraio 2011 10:51