none
Impossibile accedere ad un pc a dominio con un nome specifico RRS feed

  • Domanda

  • Salve,

    ho un problema particolare con un client 8.1 su server 2003: il computer effettua regolarmente il join al dominio ma se tengo o rimetto il suo nome originale quando cerco di accedere mi dà questo errore "Il database di sicurezza sul server non ha un account computer per la relazione di trust di questa Workstation".

    Se cambio nome funziona tutto regolarmente.

    In utenti e computer e nel dns sembra tutto a posto.

    Qualcuno mi può dare una mano?

    Grazie in anticipo

    venerdì 20 febbraio 2015 10:40

Risposte

  • Sono riuscito a risolvere con il terzo metodo proposto in questa pagina

    http://support.microsoft.com/en-us/kb/321044

    mentre i primi due non mi davano nessun risultato.
    Comunque ho trovato il pc con il serviceprincipalname duplicato (che oltretutto era doppio quello che mi dava problemi e quello legittimo) e ho risolto.
    Grazie a tutti per il supporto

    • Modificato Gonario mercoledì 25 marzo 2015 08:57
    • Contrassegnato come risposta NinoRCTNModerator mercoledì 25 marzo 2015 09:12
    mercoledì 25 marzo 2015 08:42

Tutte le risposte

  • Ciao, potresti chiarire cosa intendi con "il computer effettua regolarmente il join al dominio ma se tengo o rimetto il suo nome originale".

    Specifica esattamente quali attività esegui e verifica se il client è già presente in Active Directory. Se il client è già presente, prima di eseguire nuovamente il join devi eliminarlo.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    sabato 21 febbraio 2015 07:36
    Moderatore
  • Ciao, potresti chiarire cosa intendi con "il computer effettua regolarmente il join al dominio ma se tengo o rimetto il suo nome originale".

    Specifica esattamente quali attività esegui e verifica se il client è già presente in Active Directory. Se il client è già presente, prima di eseguire nuovamente il join devi eliminarlo.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    Ciao,

    da sysdm.cpl con cambia (ma lo stesso se uso id rete) passo in workgroup, verifico che il client non sia più presente in active directory riavvio e con cambia lo rimetto a dominio con il nome che aveva al primo join, il nome che deve avere, in questo caso mi da l'errore citato; se uso un altro nome funziona regolarmente.

    Se può essere d'aiuto il pc che prima aveva quel nome è morto d'improvviso e l'ho dovuto eliminare manualmente dal dominio.

    Ciao

    lunedì 23 febbraio 2015 08:15
  • Verifica il DNS, quell'errore è dovuto alla presenza di tracce del vecchio client. Una volta eseguita la verifica imposta il nome finale al client ed esegui un riavvio. Utilizza il wizard per l'inserimento a dominio.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    lunedì 23 febbraio 2015 08:34
    Moderatore
  • Ho verificato nel DNS e non trovo traccia del vecchio client, ne nella zona diretta ne in quella inversa
    lunedì 23 febbraio 2015 09:41
  • Io proverei a creare o ripristinare prima l'account computer in Utenti e Computer, attendere qualche minuto e poi effettuare il join. Tieni conto che se hai più domain controller è meglio attendere qualche minuto per essere sicuri che le info siano state replicate su tutti i DC

    lunedì 23 febbraio 2015 14:54
  • per caso il vecchio client risulta già presente in ADUC sotto computer o in qualche ou che contiene computers di dominio ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    martedì 24 febbraio 2015 13:23
    Moderatore
  • Ciao,

    riporta il pc in workgroup

    da "ad" rimuovi da sotto "computer" il vecchio nome computer,

    rifai il join al dominio con  il vecchio nome computer che ti serve.

    considera se hai delle policy a livello pc piuttosto che utente.

    Marco

    martedì 24 febbraio 2015 13:43
  • Io proverei a creare o ripristinare prima l'account computer in Utenti e Computer, attendere qualche minuto e poi effettuare il join. Tieni conto che se hai più domain controller è meglio attendere qualche minuto per essere sicuri che le info siano state replicate su tutti i DC

    Provato, non funziona
    martedì 24 febbraio 2015 14:52
  • per caso il vecchio client risulta già presente in ADUC sotto computer o in qualche ou che contiene computers di dominio ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    No
    martedì 24 febbraio 2015 14:53
  • Ciao,

    riporta il pc in workgroup

    da "ad" rimuovi da sotto "computer" il vecchio nome computer,

    rifai il join al dominio con  il vecchio nome computer che ti serve.

    considera se hai delle policy a livello pc piuttosto che utente.

    Marco

    Non funziona e no, non ho policy particolari
    martedì 24 febbraio 2015 14:54
  • Scusa,

    sono interessato al tuo problema.

    Tu hai un pc che quando è sotto dominio con un "nuovo"  nomepc entra regolarmente....giusto?

    ma cambiando il nome della macchina con il vecchio nomepc ti da l' errore indicato nel primo post giusto?

    In "ad" sotto computer c'è o non c'è il vecchio nomecomputer?

    grazie.....

    Marco

    martedì 24 febbraio 2015 15:00
  • Scusa,

    sono interessato al tuo problema.

    Tu hai un pc che quando è sotto dominio con un "nuovo"  nomepc entra regolarmente....giusto?

    ma cambiando il nome della macchina con il vecchio nomepc ti da l' errore indicato nel primo post giusto?

    In "ad" sotto computer c'è o non c'è il vecchio nomecomputer?

    grazie.....

    Marco

    Esatto.

    Quando il pc è rinominato il vecchio non c'è

    mercoledì 25 febbraio 2015 08:16

  • Esatto.

    Quando il pc è rinominato il vecchio non c'è

    la risposta è un po' ambigua: cosa significa ? che quando il client è rimosso dal dominio compare forse sotto ADUC il client con il vecchio nome ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    mercoledì 25 febbraio 2015 11:01
    Moderatore
  • >>la risposta è un po' ambigua: cosa significa ? che quando il client è rimosso dal dominio compare forse >>sotto ADUC il client con il vecchio nome ?

    Ciao Edoardo,

    effettivamente sto cercando di capire cosa intende con  "Quando il pc è rinominato il vecchio non c'è"

    Una traduzione grossolana mi fa pensare che

    quando fa il join con il "nuovo e funzionante nome pc ( ma in questo caso non dovrebbe avere nessun errore anche assegnando il vecchio nome pc )" l' accesso avviene regolarmente  ...

    aspettiamo aggiornamneti da Gonario

    Ciao Marco

    mercoledì 25 febbraio 2015 11:12
  • :-)

    intendevo dire che quando faccio il join con il nuovo nome il pc con il vecchio nome scompare da AD UC; se rifaccio il join con il vecchio nome il problema si ripresenta

    giovedì 26 febbraio 2015 07:41
  • :-)

    intendevo dire che quando faccio il join con il nuovo nome il pc con il vecchio nome scompare da AD UC; se rifaccio il join con il vecchio nome il problema si ripresenta

    bene! era proprio quello che immaginavo.

    allora rimuovi il pc dal dominio e mettilo in gruppo di lavoro.

    vai in ADUC ed elimina il vecchio nome con delete 

    a questo punto rifai il join al dominio dando al pc il vecchio nome prima di eseguire il join.

    ciao.


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    giovedì 26 febbraio 2015 11:45
    Moderatore
  • E' quello che faccio  di solito ma in questo caso non funziona
    giovedì 26 febbraio 2015 13:48
  • cioè?

    quando lo cancelli da ADUC cosa succede ?


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    giovedì 26 febbraio 2015 14:34
    Moderatore
  • Intendevo che anche seguendo la procedura indicata quando rifaccio il join con il vecchio nome il problema si ripresenta
    giovedì 26 febbraio 2015 16:51
  • prova ad usare adsiedit

    https://technet.microsoft.com/en-us/library/cc773354%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    per rimuovere il vecchio account computer prima di rifare il join


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    venerdì 27 febbraio 2015 10:13
    Moderatore
  • Oggi purtroppo non sono riuscito a testare la tua proposta, lo farò sicuramente Lunedi

    ciao

    venerdì 27 febbraio 2015 14:32
  • Ciao Gonario,
    Ad oggi il tuo quesito nel Forum di  Windows Server è ancora aperto per noi.
    Se i consigli ricevuti ti sono stati utili, ricorda di evidenziare la soluzione cliccando su "Segna come Risposta". Se invece hai trovato un'altra soluzione nel frattempo, ti saremmo grati di condividerla anche qui, a beneficio degli altri utenti che seguono il thread.
    Grazie.

    • Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è e non comporta alcuna responsabilità da parte dell’azienda.

    martedì 3 marzo 2015 09:42
  • Purtroppo il problema è ancora aperto.

    Non sono ancora riuscito a testare la cancellazione dell'account attraverso adsi edit

    Mi scuso per il ritardo

    giovedì 5 marzo 2015 10:56
  • prova ad usare adsiedit

    https://technet.microsoft.com/en-us/library/cc773354%28v=ws.10%29.aspx?f=255&MSPPError=-2147217396

    per rimuovere il vecchio account computer prima di rifare il join


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    Provato.

    Non Funziona :-(



    • Modificato Gonario giovedì 5 marzo 2015 13:57
    giovedì 5 marzo 2015 13:57
  • Sono riuscito a fare il test con ADSI Edit che non ha funzionato.

    Ho anche provato ad usare il nome incriminato su altre macchine e, ovviamente, ottengo lo stesso errore

    giovedì 5 marzo 2015 13:59
  • "non funziona" vuol dire che il nome incriminato non lo trovi in active directory ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    venerdì 6 marzo 2015 08:53
    Moderatore
  • Per sicurezza potresti inserire anche il nome che stai tentando di utilizzare?

    Comunque credo anch'io che possa dipendere da dati residui in Active Directory.

    venerdì 6 marzo 2015 09:09
    Moderatore
  • No, non lo trovo in nessuna query di Active Directory. Il nome che sto tentando di utilizzare è un semplice cognomeiniziale che sul vecchio pc funzionava benissimo.

    Penso anche io che ci sia dello sporco in AD ma come faccio ad individuarlo?

    venerdì 6 marzo 2015 11:38
  • il vecchio computer originariamente stava nel container Computers oppure dentro ad una OU ?

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    venerdì 6 marzo 2015 11:48
    Moderatore
  • Computers

    venerdì 6 marzo 2015 11:55
  • Prova a questo punto ad eseguire un'analisi di integrità del database di Active Directory utilizzando NTDSUTIL.
    lunedì 9 marzo 2015 15:48
    Moderatore
  • devo farlo in modalità ripristino?
    martedì 10 marzo 2015 14:13
  • Si, dovrai avviare in modalità ripristino servizio Directory.

    martedì 10 marzo 2015 16:38
    Moderatore
  • Non evidenzia problemi ne l'analisi d'integrità, ne l'analisi semantica
    venerdì 13 marzo 2015 14:31
  • Sono riuscito a risolvere con il terzo metodo proposto in questa pagina

    http://support.microsoft.com/en-us/kb/321044

    mentre i primi due non mi davano nessun risultato.
    Comunque ho trovato il pc con il serviceprincipalname duplicato (che oltretutto era doppio quello che mi dava problemi e quello legittimo) e ho risolto.
    Grazie a tutti per il supporto

    • Modificato Gonario mercoledì 25 marzo 2015 08:57
    • Contrassegnato come risposta NinoRCTNModerator mercoledì 25 marzo 2015 09:12
    mercoledì 25 marzo 2015 08:42
  • Grazie per aver condiviso la soluzione e chiuso il thread.

    Come vedi alla fine il problema era proprio quello che ti era stato prospettato, una duplicazione nome.

    Saluti
    Nino


    ...esistono i motori di ricerca, facci un salto e troverai molte delle risposte che ti darò io.

    mercoledì 25 marzo 2015 09:13
    Moderatore
  • Già :-) ma la maggior parte delle query non la trovava...
    mercoledì 25 marzo 2015 09:51