none
DPM vs SharePoint RRS feed

  • Domanda

  • Buongiorno, ho unproblema attivando un bck con DPM 2010 verso la farm di SharePoint 2010. Prima di attivare il protection group ho:

    Sul server Front di sharepoint: "ConfigureSharePoint.exe -EnableSharePointProtection" quindi "stsadm" -o registerwsswriter" quindi restart dei servizi di "Volume Shadow Copy Services", "SharePoint VSS Writer", "DPMRA".

    Fatto questo sul server DPM ho attivato un data protection manager. Effettuata la sincronizzazione il risultatpo è un "Backup metadata enumeration failed".

    Ho verificato anche che nel regedit  in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server" fosse presente solo la chiave "14".

    Potete darmi supporto.

    grazie

       Daniele

     

    venerdì 21 ottobre 2011 07:22

Risposte

  • Bene

    Passo 1) Forzare la creazione del catalogo dei metadati

    Get-ProtectionGroup yourdpmservername |get-datasource |where-object {$_.type -like "*sharepoint*"} | start-createcatalog

    Passo 2) Verificare che non ci sia questa chiave di registry

    HKLM\Software\Microsoft\Shared Tools\Web Server Extensions\12.0

    • Proposto come risposta Anca Popa giovedì 27 ottobre 2011 07:46
    • Contrassegnato come risposta Anca Popa giovedì 27 ottobre 2011 12:41
    mercoledì 26 ottobre 2011 07:12

Tutte le risposte

  • Hai degli errori precisi all'interno del registro eventi?
    Romeo Pruno | Microsoft MVP SharePoint Server | http://www.nonaka.eu/feed
    sabato 22 ottobre 2011 14:52
  • Ciao Romeo, ho delle segnalazioni di warning nell'event viewer relative a dpm:

    "DPM could not obtain backup metadata information for ZPVINTSHPSQL\ZPVINTSHP\POSTEVITA_Config on ZPVINTWFE.POSTEVITA.local. If the data source is a SharePoint farm then a valid recovery point has been created. However, content databases from this recovery point can be recovered using the alternate location option only. (ID: 3134)"

    "DPM failed to gather item level catalog for 5 database(s) of the SharePoint Farm ZPVINTSHPSQL\ZPVINTSHP\POSTEVITA_Config on ZPVINTWFE.POSTEVITA.local. Some of the recovery points for these databases in the farm would be associated with an earlier successful catalog. (ID: 3133)"

    "DPM could not obtain backup metadata information for ZPVINTSHPSQL\ZPVINTSHP\POSTEVITA_Config on ZPVINTWFE.POSTEVITA.local. If the data source is a SharePoint farm then a valid recovery point has been created. However, content databases from this recovery point can be recovered using the alternate location option only. (ID: 3134)"

    Queste sono le uniche segnalazioni e sono di warning che ricevo dopo aver lanciato un "create short protection". Nella schermata di DPM relativa ai protection group invece la dicitura dopo la sincronizzazione rimane sempre la stess "warning" "backup metadata enumeration failed"

    Grazie

     d


    Daniele
    lunedì 24 ottobre 2011 06:43
  • Sono nuovo del sito... è meglio se posto anche tradotto in lingua inglese?

    Grazie

     d


    Daniele
    lunedì 24 ottobre 2011 06:48
  • Ciao Daniele,

    non ho esperienze dirette con il DPM, prova questo thread: http://social.technet.microsoft.com/Forums/en-US/dpmsharepointbackup/thread/23cce380-3d56-45df-8ef9-80f3b9dedf3e/


    Romeo Pruno | Microsoft MVP SharePoint Server | http://www.nonaka.eu/feed
    lunedì 24 ottobre 2011 17:21
  • Non è che DPM sta proteggendo GIA i database SQLServer della farm SharePoint? Se vuoi farei i backup della farm sharepoint con DPM i suoi DB SQLServer non debbono esser inclusi in un Protection group diverso da quello che include la farm sharepoint.

     

    martedì 25 ottobre 2011 19:14
  • Buongiorno Gabriele, DPM è stato configurato per proteggere solo la farm di SHP. I suoi DB non sono inclusi in nessun protection group.

    Quello che invece ha segnalato Romeo nel post precedente era già stato fatto ma senza ottenere nessun risultato.

    Sono ancora con il problema!


    Daniele
    mercoledì 26 ottobre 2011 06:55
  • Bene

    Passo 1) Forzare la creazione del catalogo dei metadati

    Get-ProtectionGroup yourdpmservername |get-datasource |where-object {$_.type -like "*sharepoint*"} | start-createcatalog

    Passo 2) Verificare che non ci sia questa chiave di registry

    HKLM\Software\Microsoft\Shared Tools\Web Server Extensions\12.0

    • Proposto come risposta Anca Popa giovedì 27 ottobre 2011 07:46
    • Contrassegnato come risposta Anca Popa giovedì 27 ottobre 2011 12:41
    mercoledì 26 ottobre 2011 07:12
  • Ciao Daniele,

    Mi sono permessa di evidenziare la risposta di Gabriele, in attesa del tuo feedback.

    Grazie di tenerci aggiornati sul tuo percorso,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    giovedì 27 ottobre 2011 12:41
  • Buongiorno ragazzi, le operazioni suggerite da Gabriele purtroppo hanno dato esito negativo. Avevo già rimosso la chiave segnalata dal registro e dopo  aver eseguito il Get-ProtectionGroup e rilanciato un CreateRecoveryPoint il problema persiste. L'output del Get-ProtectionGroup non ha restituito errori.

    Nell'event viewer:

    warning: "DPM failed to gather item level catalog for 5 database(s) of the SharePoint Farm XXX\YYY\ZZZ_Config on CCCCCC.local. Some of the recovery points for these databases in the farm would be associated with an earlier successful catalog. (ID: 3133)"

    warning: "DPM could not obtain backup metadata information for  XXX\YYY\ZZZ_Config on CCCCCC.local. If the data source is a SharePoint farm then a valid recovery point has been created. However, content databases from this recovery point can be recovered using the alternate location option only. (ID: 3134)"

    Qualche idea?

    Grazie

     

     Daniele


    Daniele
    venerdì 28 ottobre 2011 08:48
  • Sei sicuro che il ConfigureSharePoint.exe sui front-end sia stato fatto con l'account di un farm admin SharePoint?

    Hai verificato che la chiave HKLM\Software\Microsoft\Shared Tools\Web Server Extensions\12.0
    non ci sia? (nel tuo post parlavi di questa chiave HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office Server\12

     

     

    venerdì 28 ottobre 2011 10:18
  • Buongiorno Gabriele,

    ti confermo che il ConfigureSharePoint.exe sui front-end è stato fatto girare con l'account di un farm admin di SharePoint.

    Per quel che riguarda la chiave del registro invece, dopo aver rimosso quella da te segnalata e aver risincronizzato il protection group, tutto ha cominciato a funzionare correttamente.

     

    Grazie e buon lavoro.


    Daniele
    • Contrassegnato come risposta DanieleGi lunedì 31 ottobre 2011 09:40
    • Contrassegno come risposta annullato Anca Popa lunedì 31 ottobre 2011 13:49
    lunedì 31 ottobre 2011 09:40
  • Scusa Daniele, mi sono accorta ora che hai segnato come risposto il riscontro che avevi dato a Gabriele. Mi sono permessa di deselezionarla, siccome nel forum TechNet non serve fare cosi', basta marcare come risposta l'intervento che ha condotto direttamente alla soluzione per aiutare gli altri utenti a trovarla (cliccando sul simbolo della V verde).  

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come inserire immagini nei post

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    lunedì 31 ottobre 2011 14:25