none
BDE (borland database engine) date inglesi

    Domanda

  • Ciao a tutti,
    ho sviluppato tempo fa un programma in delphi che usa BDE per la gestione dei dati. Ho il problema che con Windows 7 le
    date sono diventate mm/gg/yyyy
    Il programma funzionava perfettamente in Windows Vista (dopo aver fatto le opportune modifiche al registro) mentre in
    windows 7 mi da questo problema di date invertite.

    Qualcuno sa darmi qualche dritta ?

    Grazie in anticipo
    domenica 8 novembre 2009 10:11

Risposte

  • La conclusione del problema si è risolto aggiornando Windows 7 preinstallato su un PC nuovo LENOVO con uno
    in BOX acquistato ieri.
    Come pensavo probabilmente la versione di Windows7 preinstallata non era completamente localizzata
    per la lingua ITA.

    Posso quindi confermare che programmi fatti in Delphi e che utilizzano BDE funzionano perfettamente con WINDOWS 7

    sabato 14 novembre 2009 18:06

Tutte le risposte

  • Non sono  un dev, ma è l'applicazione che dovrebbe tener conto delle impostazioni regionali del sistema su cui gira, non il contrario.

    Setting the BDE Date Format from a Delphi Application
    http://edn.embarcadero.com/article/20844
    Adriano Arrigo
    Microsoft MVP Windows Desktop Experience 2008 - 2009
    ITALY
    Se la risposta ti ha aiutato clicca su Vota come Utile.
    domenica 8 novembre 2009 17:21
  • grazie per la risposta, ma appunto l'applicazione lo controlla dato che da anni con windows xp e anche con Vista funziona bene.
    Sebbene Windows 7 sia in Italiano, sembrerebbe che gli sia rimasta da qualche parte (non nelle impostazioni del pannello di controllo, perche ho controllato) un setting in Inglese.

    domenica 8 novembre 2009 18:13
  • La conclusione del problema si è risolto aggiornando Windows 7 preinstallato su un PC nuovo LENOVO con uno
    in BOX acquistato ieri.
    Come pensavo probabilmente la versione di Windows7 preinstallata non era completamente localizzata
    per la lingua ITA.

    Posso quindi confermare che programmi fatti in Delphi e che utilizzano BDE funzionano perfettamente con WINDOWS 7

    sabato 14 novembre 2009 18:06
  • Ho avuto lo stesso problema ed ho risolto nel seguente modo

     

    Pannello di controllo

    Paese e Lingua

    Tastiere e Lingue

    Cambia Tastiere

    Ho spostato Italiano all'inizio della lista (dove c'era Inglese) con la funzione sposta su

    E come per incanto.....

    Spero di essere stata utile

    mercoledì 1 settembre 2010 09:05