none
Problemi Exchange server 2010 e Gestione IIS RRS feed

  • Domanda

  • Ciao a tutti,

    ho un problema con exchange server e non mi fa connettere alla managment console.

    Girando su internet ho scoperto che devo aggiungere il modulo autenticazione kerberos nella directory virtuale PowerShell in Gesttione IIS ma purtroppo andando nella sezione moduli della PS mi dice: "Questa funzionalità è stata bloccata ed è in sola lettura".

    Ho fatto uno screenshot: http://www.alescan.it/errori%20server/immagine.png

    Qualcuno sa cosa può essere?

    Grazie

    • Tipo modificato Anca Popa venerdì 13 maggio 2011 10:35 ricerca di una soluzione
    • Tipo modificato Anca Popa lunedì 23 maggio 2011 06:14 domanda con risposta
    venerdì 6 maggio 2011 19:34

Risposte

  • Ciao Alessandro,

    Se le informazioni riportate finora non ti hanno aiutato, visto che non le virtual directories non sono presenti e che non si può neppure reinstallare il ruolo CAS, il mio consiglio rimane quello di aprire un ticket preso il supporto Microsoft per assistenza mirata. Trovi le modalita' di contatto qui:

    Opzioni supporto assistito online

    Grazie della comprensione,

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    • Contrassegnato come risposta Anca Popa mercoledì 1 giugno 2011 13:54
    martedì 31 maggio 2011 12:37

Tutte le risposte

  • Sei amministratore locale della macchina altre ad essere amministratore di Exchange 2010?


    Peppacci - MVP - Microsoft Exchange Server Microsoft MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    lunedì 9 maggio 2011 07:12
    Moderatore
  • Dimenticavo, che versione di exchange 2010 hai? Hai installato la sp1?
    Peppacci - MVP - Microsoft Exchange Server Microsoft MCTS - MCITP http://blogs.sysadmin.it/peppacci/Default.aspx
    lunedì 9 maggio 2011 07:13
    Moderatore
  • Si sono admin del server che poggia su win server 2008 r2. ho exchange 2010 standard ma il problema è quello nella foto che ho linkato. devo aggiungere due moduli in Gestione IIS ma non me lo lascia fare dicendo che è in sola lettura.
    lunedì 9 maggio 2011 16:55
  • Ciao ederasrl,

    Non sono molto sicura se questo è il consiglio giusto nel caso tuo, però in base allo screenshot allegato nel primo post potresti innanzitutto provare a ricreare la PowerShell application directory.

    Prova a dare uno sguardo a questo link: Creare un'applicazione Web (IIS 7)

    Spero che questa indicazione possa darti qualche spunto.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    SBS 2011 Essentials: download, documentazione e video

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    giovedì 12 maggio 2011 14:47
  • Non è un'application directory ma una directory virtuale (da sito microsoft dice di creare una virtual directory) e già provato ricreare la directory virtuale ma purtroppo non è cambiato nulla.
    giovedì 12 maggio 2011 18:20
  • Ciao ederasrl,

    Potresti per cortesia postare anche l’errore che ricevi quando provi a connetterti alla Management Console?

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    SBS 2011 Essentials: download, documentazione e video

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    venerdì 13 maggio 2011 07:11
  • Ecco l'errore:

    Tentativo di connessione a "http://nome.server/PowerShell" mediante l'autenticazione "Kerberos" non riuscito: Connessione al server remoto non riuscita con il seguente errore: Client di gestione remota Windows: impossibile elaborare la richiesta.

    Questo è il testo principale dell'errore però visto che sotto ci sono anche dei suggerimenti su come risolvere l'errore t posto uno screen che magari t torna utile.

    http://www.alescan.it/errori%20server/exchange.png

     

    Grazie a te


    venerdì 13 maggio 2011 07:43
  • In base alle mie ricerche, di seguito provo a lasciarti un paio di suggerimenti:

    In IIS, verifica se oltre al Default Web Site esiste anche un altro sito che ascolta sulla porta 80. Se così fosse, prova a cambiare la porta di quel sito.

    Sul server, da cmd, esegui winrm quickconfig e posta qui l’output.

    In IIS > Modules verifica se trovi Kerberos.

    Verifica inoltre se Kerberos.dll è presente sul disco in C:/Program Files/Microsoft/Exchange/V14/BIN.

    Prova anche a seguire tutti i passi descritti in questo blog post:

    Troubleshooting Exchange 2010 Management Tools startup issues

    Spero di esserti stata utile, tienici aggiornati.


    Anca Popa Follow ForumTechNetIt on Twitter

    Come calcolare la dimensione della Rubrica offline (OAB)

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    venerdì 13 maggio 2011 13:51
  • Come si vede dallo screen nel primo post c'è solo il default website sulla 80.

    Da cmd mi dice:"

    Microsoft Windows [Versione 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation. Tutti i diritti riservati.

    C:\Users\Administrator>winrm quickconfig
    Gestione remota Windows già impostato per la ricezione di richieste in questo co
    mputer.
    Gestione remota Windows già impostato per la gestione remota in questo computer."

    Quindi penso sia giusto.

    Il modulo kerberos e WSman sono presenti nei moduli configurabili e posso anche modificarli (ho guardato le dll sia kerberos che wsman e sono presenti) ma ho sempre il problema della sola lattura in IIS>defautlwebsite>PowerShell>moduli (come da screen primo post)i e quindi non posso aggiungerli come metodo di autenticazione accettato dalla PowerShell, di conseguenza non mi fa entrare nella console di managament exchange.

    venerdì 13 maggio 2011 15:36
  • Ciao ederasrl,

    Torno un po’ allo screenshot linkato nel primo thread, dove sotto il Default Web Site non vedo la Virtual Directory per Exchange Server. Si tratta dell’IIS per il server Exchange oppure su un’altra macchina che usi solo per la gestione?

    Visto anche il piccolo punto d’interrogazione sul Default Web Site: hai già provato ad eseguire Exchange Best Practices Analyzer? Prova eventualmente ad allegare sul forum il risultato di uno scan, in formato xml.

    Uso di SkyDrive per caricare file e postare screenshot/ immagini nel forum TechNet

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come calcolare la dimensione della Rubrica offline (OAB)

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    lunedì 16 maggio 2011 14:46
  • Si è l'IIS del server con su exchange.

     

    L'analyzer non posso farlo andare perché:

    "Note Exchange Best Practices Analyzer v2.8 should not be used to scan Exchange Server 2007 and Exchange Server 2010. In Exchange Server 2007 and Exchange Server 2010, the Best Practices Analyzer is installed during Exchange Setup and can be run from the Exchange Management Console Toolbox. "

    Copia,incolla da : http://www.microsoft.com/downloads/en/details.aspx?familyid=dbab201f-4bee-4943-ac22-e2ddbd258df3&displaylang=en

    Se il mio inglese mi assiste (nella pagina in italiano non c'è) dice che è già integrato dal 2007 e seguendo il link del sito dice che devo farlo partire della Managment Console(cosa che non posso fare).

    Saluti

    Alessandro


    lunedì 16 maggio 2011 17:15
  • Ciao Alessandro,

    A questo punto, ti posso suggerire di ricreare la directory virtuale. Visto che l’avevi già provato, il mio consiglio sarebbe di rimuovere poi reinstallare il ruolo CAS del server.

    Spero di esserti stata utile, fai sapere se risolvi.

    Saluti,  


    Anca Popa Follow ForumTechNetIt on Twitter

    Come calcolare la dimensione della Rubrica offline (OAB)

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    • Contrassegnato come risposta Anca Popa lunedì 23 maggio 2011 06:15
    • Contrassegno come risposta annullato ederasrl martedì 24 maggio 2011 09:40
    mercoledì 18 maggio 2011 13:35
  • Ho provato come mi ha detto a disinstallare il ruolo CAS ma appena clicco avanti mi da errore. Ecco uno screen.

    http://www.alescan.it/errori%20server/disinstallazione.png

     

    Ho guardato ed effettivamente quei file non ci sono.

    Si possono recuperare o si può ovviare in qlc modo?

     

    Saluti

    Alessandro

    martedì 24 maggio 2011 09:43
  • Ciao Alessandro,

    Ci do uno sguardo, intanto volevo fare una pronta domanda: hai provato a rimuovere il ruolo CAS del tuo Exchange Server 2010 seguendo esattamente i passi descritti qui?

    Modifica o eliminazione di Exchange 2010

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come calcolare la dimensione della Rubrica offline (OAB)

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 24 maggio 2011 11:41
  • Si ho fatto come descritto.

    Dal pannello di controllo ho selzionato disinstalla/cambia su exchange, poi fatto avanti come dice e mi viene fuori quell'errore.

     

    Saluti

    Alessandro

    martedì 24 maggio 2011 12:05
  • Ciao Alessandro,

    Purtroppo se stai seguendo “alla lettera” i passi nell’articolo della TechNet Library dovresti ritrovarti con una schermata differente, prova a vedere ciò che ho ottenuto io seguendo gli stessi passi:

    Mentre lo screenshot che avevi postato oggi mi fa pensare che stai provando piuttosto questo scenario:

    Upgrade Exchange Server 2010 To SP1

    Potresti per cortesia controllare ancora una volta?

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come calcolare la dimensione della Rubrica offline (OAB)

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 24 maggio 2011 14:53
  • Da pannello di controllo di controllo la schermata è quella sia facendo disisntalla che facendo cambia (comunque mi ricordo che avviandolo da lì mi faceva rimuovere i ruoli), penso venga fuori scritto SP1 perché comunque è installato il service pack.

    Comunque ho provato anche ad avviare il setup.exe nella cartella bin di exchange con il seguente risultato:

    http://www.alescan.it/errori%20server/setup.png

     

    Saluti

    Alessandro


    martedì 24 maggio 2011 15:39
  • Ciao Alessandro,

    Purtroppo l’ultimo errore è normale, di seguito ti lascio la spiegazione per la versione 2007:

    Se sono stati installati aggiornamenti cumulativi per Exchange 2007, è necessario utilizzare Installazione applicazioni per rimuovere i ruoli del server di Exchange o di Exchange oppure eseguire Setup.com dal supporto di installazione originale o dai file di origine. Non è possibile utilizzare Setup.com dalla cartella \bin per modificare o rimuovere un'installazione di Exchange. Se non si rimuovono gli aggiornamenti cumulativi e si utilizza Setup.com dalla cartella \bin, verrà visualizzato il seguente messaggio di errore: Mancata corrispondenza tra la versione dell'applicazione in esecuzione e quella dell'applicazione installata.

    Fonte: Come rimuovere i ruoli server di Exchange 2007

    Hai provato anche a rilanciare il setup d'installazione dal supporto o dalla iso ?

    Se ancora non riesci a rimuovere il ruolo CAS, potresti eventualmente valutare di reinstallare il server oppure di aprire un caso preso il supporto Microsoft per ulteriori ricerche. (Questa tipo di assistenza è a pagamento.)

    Spero che possa risolvere, tienici aggiornati.

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Come calcolare la dimensione della Rubrica offline (OAB)

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    mercoledì 25 maggio 2011 07:43
  • Facendo partire il setup dal cd non mi fa selezionare i componenti da rimuovere, fa il controllo conformità e poi mi dice che posso aggiornare(non so cosa visto che sul cd non c'è la versione SP1 mentre sul server si).

    Comunque per quello ho capito leggendo su internet se risolvo il problema al primo post riesco ad accedere alla managment cosnole e poi da li posso rimuovere le cassette postali e di conseguenza disinstallare exchange.

    Saluti

    Alessandro


    venerdì 27 maggio 2011 07:00
  • Ciao Alessandro,

    Se le informazioni riportate finora non ti hanno aiutato, visto che non le virtual directories non sono presenti e che non si può neppure reinstallare il ruolo CAS, il mio consiglio rimane quello di aprire un ticket preso il supporto Microsoft per assistenza mirata. Trovi le modalita' di contatto qui:

    Opzioni supporto assistito online

    Grazie della comprensione,

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    • Contrassegnato come risposta Anca Popa mercoledì 1 giugno 2011 13:54
    martedì 31 maggio 2011 12:37