none
windows server 2016 wbadmin backup errore su share smb2 RRS feed

  • Domanda

  • Ciao a tutti,

    riscontro un problema da un cliente che ha un server Window Server 2016 da un paio di mesi ed esegue i backup tramite script wbadmin su un nas con share smb. Il problema si è presentato da una settimana circa.

    I backup si interrompono con questo errore

    Operazione di backup avviata alle ore '‎2017‎-‎12‎-‎13T10:42:37.004917200Z' non riuscita. Codice errore: '0x807800C5' (Errore durante la preparazione dell'immagine di backup di uno dei volumi inclusi nel set di backup.). Per una soluzione esaminare i dettagli dell'evento, quindi eseguire di nuovo l'operazione di backup dopo aver risolto il problema.

    Leggevo che potrebbe essere un problema di compatibilità con smb3.

    Lato nas ho attivato smb2 ma non è cambiato nulla. Il nas è un Buffalo Linkstation 220.

    A parte disattivare smb3 e smb2 lato server tornando a smb1 avete qualche idea? Ho anche cercato sul web dei nas compatibili smb3 ma per ora non ho trovato nulla con ben indicata questa compatibilità quindi faccio anche fatica a proporre al cliente un cambio del nas.

    Grazie mille!


    Adl Srl

    mercoledì 13 dicembre 2017 17:08

Tutte le risposte

  • Ciao, il nas non ha un initiator iscsi? crei una lun, agganci il disco con l'intiator al 2016 ed hai risolto. Non sono sicuro che sia un problema di Windows, magari controlla che non ci sia un aggiornamento firmware del nas..il 220 è abbastanza economico come nas e Buffalo non fa molti aggiornamenti. Comunque per i backup basta un normale nas attuale, non devi cercare nas SMB3, ho Qnap e Synology dappertutto e non ho mai riscontrato problemi su 2016.

    Ciao!

    A.

    mercoledì 13 dicembre 2017 17:46
    Moderatore
  • Se ha funzionato fino a qualche tempo fa, sicuramente non è legato al protocollo smb, l'unica patch che ha cambiato qualcosa su windows era relativa a smb v1 e al virus wannacry (mi sembra rilasciata ad aprile).

    Un consiglio, lato server non mi avventurerei in disabilitazioni  varie del protocollo smb, si rischia di fare danni gravi!

    Tornando al problema ho letto qua e là, ed alcuni consigliano di ripulire la share, io proverei su di una share "vergine"

    https://superuser.com/questions/508932/windows-backup-failed-with-error-0x807800c5

    ciao Gas


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    mercoledì 13 dicembre 2017 19:52
    Moderatore
  • Ciao,

    purtroppo niente iSCSI e niente update firmware per il nas. Proverò con un reset dell'unità.

    Grazie.


    Adl Srl

    giovedì 14 dicembre 2017 07:44
  • Ciao,

    purtroppo ho già provato su di una share vergine. Al link dicono anche di aggiungere il gruppo Domain Computers con permessi di scrittura ma la share vergine è senza restrizioni, aperta a tutti in scrittura, quindi non credo sia nemmeno un problema di permssi.

    Tenterò un reset del nas e dello storage.

    Grazie.


    Adl Srl

    giovedì 14 dicembre 2017 08:04
  • Ciao,

    giusto per aggiornare la situazione.

    Ho installato dal cliente un disco usb provvisorio. Il backup pianificato del server 2016 su questo disco funziona senza problemi. Come test, sullo stesso disco usb, ho creato una share ed ho avviato il backup tramite script via rete, funziona.

    Ho quindi rientrato il nas del cliente, l'ho collegato in rete nel nostro laboratorio, ho avviato un backup via rete tramite script nelle stesse share in uso dal cliente da una macchina win7, funziona senza problemi.

    La macchina da cui ho lanciato il backup non dispone di UEFI, è un hardware totalmente diverso ed un sistema operativo diverso, tuttavia il principio credo di backup sia lo stesso.

    La cosa si fa intricata....


    Adl Srl

    venerdì 15 dicembre 2017 17:05
  • non più di tanto...;-) cambia il NAS al cliente vedrai che funziona senza problemi. Non hai un NAS che tieni in sostituzione da dare ai clienti?? Magari riutilizzi i dischi, con un Synology o Qnap vedrai che il problema non esiste...così..per non perdere ore su un Buffalo che comunque non va male..ma il 220 è vecchiotto. Devi sempre tenere conto del tempo che investi in una soluzione. Con 250€ dai un nas nuovo ed il problema è risolto.

    ciao.

    A.

    venerdì 15 dicembre 2017 17:11
    Moderatore
  • Questo ad es. potrebbe andare bene secondo te? E' del 2015.

    https://www.qnap.com/it-it/product/ts-231p


    Adl Srl


    • Modificato Support ADL venerdì 15 dicembre 2017 17:24 url
    venerdì 15 dicembre 2017 17:24
  • si ne ho fuori di 231 non hanno problemi di sorta.
    venerdì 15 dicembre 2017 17:40
    Moderatore