none
Creazione sito in Locale su localhost in windows 8 RRS feed

  • Domanda

  • Mi scuso se sbaglio la categoria a cui imputare il problema, ma non trovo uno specifico gruppo migliore di questo.

    Devo configurare un sito in localhost.

    Ho una macchina windows 8.0 eho implementato la funzionalità IIS.

    Il nuovo sito si chiama "TEST"

      fig. 1

    Ho fatto "Aggiungi Applicazione" e ho creato la cartella virtuale "TEST" nella quale ho inserito le pagine sviluppate in visual studio.

    Nelle precedenti versioni di IIS (Attualmente ho la versione 8.0.920.16384) ero abituato a vedere solo la voce "Aggiungi Directory Virtuale" con la quale creavo la cartella del sito.

    Domanda:  Che differenza c'è tra "Aggiungi Applicazione" e "Crea Direcory Virtuale" ?

                       per la creazione del sito devo crearle entrambe e poi le pagine .aspx e code behind e il resto vanno messe nella directory irtuale contenuta dentro all'applicazione ?Facendo la prova di connessione (Vedi Fig. 2 e Fig. 3), va in errore come specificato in "Dettagli" di Fig. 3

    Credo che qui stia il problema attuale.

    Dove e come posso verificarequanto documentato nelle fig. 2 e 3 ?

    Grazie

    Moreno

      Fig. 2

      Fig. 3

    giovedì 28 aprile 2016 13:52

Risposte

  • Io posterei la domanda sui forum MSDN dove trovi anche quello di IIS, qui risolviamo problemi sistemistici legati al sistema operativo il tuo a mio avviso è chiaramente un problema di configurazione.

    Ti ricordo che per le urgenze è sempre disponibile il supporto a pagamento (vista la scritta finale sottolineata, qui non hai tempi di risposta garantiti)

    ps, ma il firewall di Windows l'hai configurato/abbassato del tutto almeno? 

    Ciao!

    A.

    • Contrassegnato come risposta Misonsan martedì 3 maggio 2016 16:37
    sabato 30 aprile 2016 18:21
    Moderatore
  • non ho esperienza di iis, non sono uno sviluppatore, quando non va di solito cambio piattaforma e rifaccio la config, tanto con delle VM è presto fatto. Per l'assistenza a pagamento non devi avere abbonamenti, basta chiamare Microsoft al numero che trovi sul sito.

    comunque qui sicuramente troverai aiuto

    https://forums.iis.net/

    non devi comunque postare nelle pagine di benvenuto ma in quelle dei forum specifici. Tieni conto però che sui forum per professionisti IT (TechNet ed MSDN) non si fa formazione, quindi se sei un neofita ed operi nel campo difficilmente troverai aiuto, si parte dando per scontato che uno conosca a fondo il prodotto.

    Prova su iis.net

    ciao.

    A.

    • Contrassegnato come risposta Misonsan lunedì 9 maggio 2016 08:51
    martedì 3 maggio 2016 08:22
    Moderatore

Tutte le risposte

  • Sto letteralmente impazzendo.

    Sto verificando IIS in tutte le sue personalizzazione; ho messo abilitato le cartelle, gli utenti e continua a darmi erroreHTTP 403.3

    MA COSA MANCA ?

    Il problema potrebbe essere nella non corretta WEB.Config.

    Allego la WEB.Config

    <?xml version="1.0" encoding="UTF-8"?>
    <!--
      Per ulteriori informazioni sulla configurazione dell'applicazione ASP.NET, visitare
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <configuration>
      <connectionStrings>
        <add name="ConnectionString" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\CircoloSanfra.mdb" providerName="System.Data.OleDb" />
        <add name="ConnectionString2" connectionString="Provider=Microsoft.Jet.OLEDB.4.0;Data Source=|DataDirectory|\CircoloSanfra.mdb" providerName="System.Data.OleDb" />
      </connectionStrings>
    
      <system.web>
        <httpHandlers>
          <add path="ChartImg.axd" verb="GET,HEAD,POST" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false" />
        </httpHandlers>
        <pages>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI.DataVisualization.Charting" assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </controls>
        </pages>
        <compilation debug="true" targetFramework="4.5.2">
          <assemblies>
            <add assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
          </assemblies>
        </compilation>
        <httpRuntime targetFramework="4.5.2" />
        <httpModules>
          <add name="ApplicationInsightsWebTracking" type="Microsoft.ApplicationInsights.Web.ApplicationInsightsHttpModule, Microsoft.AI.Web" />
        </httpModules>
      </system.web>
      <system.codedom>
        <compilers>
          <compiler language="c#;cs;csharp" extension=".cs" type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.CSharpCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" warningLevel="4" compilerOptions="/langversion:6 /nowarn:1659;1699;1701" />
          <compiler language="vb;vbs;visualbasic;vbscript" extension=".vb" type="Microsoft.CodeDom.Providers.DotNetCompilerPlatform.VBCodeProvider, Microsoft.CodeDom.Providers.DotNetCompilerPlatform, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" warningLevel="4" compilerOptions="/langversion:14 /nowarn:41008 /define:_MYTYPE=\&quot;Web\&quot; /optionInfer+" />
        </compilers>
      </system.codedom>
      <system.webServer>
         <validation validateIntegratedModeConfiguration="false" />
        <modules>
          <remove name="ApplicationInsightsWebTracking" />
          <add name="ApplicationInsightsWebTracking" type="Microsoft.ApplicationInsights.Web.ApplicationInsightsHttpModule, Microsoft.AI.Web" preCondition="managedHandler" />
        </modules>
        <handlers>
          <remove name="ChartImageHandler" />
          <add name="ChartImageHandler" preCondition="integratedMode" verb="GET,HEAD,POST" path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </handlers>
    
       <security>
          <authentication>
    <windowsAuthentication enabled="true">
      <providers lockElements="remove,clear">
        <add value="Negotiate" />
        <add value="NTLM" />
      </providers>
    </windowsAuthentication>
          </authentication>
        </security>
            <directoryBrowse enabled="true" />
    
    
    
    
      </system.webServer>
    
    
      <appSettings>
        <add key="ValidationSettings:UnobtrusiveValidationMode" value="None" />
        <add key="ChartImageHandler" value="storage=file;timeout=20;dir=c:\TempImageFiles\;" />
      </appSettings>
    </configuration>

    Potete Aiutarmi ?

    Sono completamente FERMO

    Grazie

    Moreno

    venerdì 29 aprile 2016 13:14
  • Io posterei la domanda sui forum MSDN dove trovi anche quello di IIS, qui risolviamo problemi sistemistici legati al sistema operativo il tuo a mio avviso è chiaramente un problema di configurazione.

    Ti ricordo che per le urgenze è sempre disponibile il supporto a pagamento (vista la scritta finale sottolineata, qui non hai tempi di risposta garantiti)

    ps, ma il firewall di Windows l'hai configurato/abbassato del tutto almeno? 

    Ciao!

    A.

    • Contrassegnato come risposta Misonsan martedì 3 maggio 2016 16:37
    sabato 30 aprile 2016 18:21
    Moderatore
  • Ciao Alessandro

    Ho postato la richiesta su "Benvenuti sul Forum MSDN", ma ancora nessuna risposta.

    Sono un neofita e non ho abbonamenti a MSDN per assistenza specialistica.

    Riesci a darmi una mano ?

    Grazie

    Moreno

    martedì 3 maggio 2016 06:18
  • non ho esperienza di iis, non sono uno sviluppatore, quando non va di solito cambio piattaforma e rifaccio la config, tanto con delle VM è presto fatto. Per l'assistenza a pagamento non devi avere abbonamenti, basta chiamare Microsoft al numero che trovi sul sito.

    comunque qui sicuramente troverai aiuto

    https://forums.iis.net/

    non devi comunque postare nelle pagine di benvenuto ma in quelle dei forum specifici. Tieni conto però che sui forum per professionisti IT (TechNet ed MSDN) non si fa formazione, quindi se sei un neofita ed operi nel campo difficilmente troverai aiuto, si parte dando per scontato che uno conosca a fondo il prodotto.

    Prova su iis.net

    ciao.

    A.

    • Contrassegnato come risposta Misonsan lunedì 9 maggio 2016 08:51
    martedì 3 maggio 2016 08:22
    Moderatore