none
Robocopy cartella nascosta Windows Server 2008 RRS feed

  • Domanda

  • ho trasferito dei file con robocopy da un winserver 2003 a un winserver 2008. La copia non è andata a buon fine e la cartella dove avrei dovuto copiare i file non c'è. Se però cerco di creare una cartella con lo stesso nome mi dice che la cartella è esistente. Ho provato a fare una ricerca, ma della cartella non c'è traccia. Grazie in anticipo.
    • Modificato Anca Popa lunedì 8 ottobre 2012 10:16 chiarimento titolo
    giovedì 4 ottobre 2012 06:37

Risposte

  • Ciao sbrugola,

    Aggiungo il mio suggerimento a quanto già consigliato finora. 

    Durante il trasferimento dei file, Robocopy potrebbe aver modificato la cartella di destinazione in una cartella di sistema nascosta. Togliere la spunta su "hide protected operating system files" dovrebbe aiutare, anche utilizzare il commando Attrib per esempio con i parametri:

    attrib -r -s -h drive:\<path>\<foldername>
    
    

    Facci sapere se risolvi,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 


    lunedì 8 ottobre 2012 10:11

Tutte le risposte

  • Ciao, controlla che non ci siano residui nelle copie shadow del server e riavvia la macchina di destinazione, la cartella a quel punto non dovrebbe esistere più.

    A.

    giovedì 4 ottobre 2012 08:11
    Moderatore
  • se usi un prompt di dos per vedere il contenuto della cartella vedi qualcosa in formato 8:3 ?

    Edoardo Benussi
    Microsoft MVP - Management Infrastructure
    edo[at]mvps[dot]org



    giovedì 4 ottobre 2012 08:31
    Moderatore
  • Ciao sbrugola,

    Aggiungo il mio suggerimento a quanto già consigliato finora. 

    Durante il trasferimento dei file, Robocopy potrebbe aver modificato la cartella di destinazione in una cartella di sistema nascosta. Togliere la spunta su "hide protected operating system files" dovrebbe aiutare, anche utilizzare il commando Attrib per esempio con i parametri:

    attrib -r -s -h drive:\<path>\<foldername>
    
    

    Facci sapere se risolvi,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 


    lunedì 8 ottobre 2012 10:11
  • Anche io ho un caso analogo.
    Ho un HD USB avente due partizioni: una piena e l'altra vuota.
    Ho usato robocopy per copiare il contenuto dalla partizione I: a quella J:\PATH_DEST 
    Inspiegabilmente al termine della copia la cartella non è visibile però esiste!!

    Questa è l'istruzione di robocopy usata:

    robocopy I:\ J:\PATH_DEST /mir /w:3 /r:3 > J:\Backup.log

    Al termine, dopo parecchie ore, vista la mole di dati....
    Se provo però a fare in cmd.exe una cosa del genere...

    j:
    cd \
    dir ==> VUOTO
    cd \PATH_DEST

    lì entro ed ho tutto ....
    Quindi ?? La domanda è: come faccio a far diventare visibile j:\PATH_DEST??

    PS - La cartella di destinazione non è nascosta... ho già verificato

    Grazie

    sabato 2 aprile 2016 11:40
  • OK ci sono!!
    Era nascosta e di SISTEMA
    Quindi al fine di un ripristino è bastato un cmd.exe:

    attrib -S -H j:\PATH_DEST

    sabato 2 aprile 2016 11:53
  • Ciao Marco, una soluzione alternativa è quella di utilizzare l'opzione /A:-SH

    robocopy I:\ J:\PATH_DEST /mir /w:3 /r:3 /A:-SH > J:\Backup.log

    http://ss64.com/nt/robocopy.html

    Saluti
    Nino

    sabato 2 aprile 2016 13:08
    Moderatore
  • Ciao Marco, una soluzione alternativa è quella di utilizzare l'opzione /A:-SH

    robocopy I:\ J:\PATH_DEST /mir /w:3 /r:3 /A:-SH > J:\Backup.log


    Nino ero curioso e ho approfondito la cosa su parametro /A-:SH o /A+:SH

    robocopy I:\ J:\PATH_DEST /mir /w:3 /r:3 /A-:SH /log:J:\_log_mir.log

    Il problema se si usa il parametro /A-:SH tutti gli attributi hidden e  system sono tolti da TUTTI i file copiati... (se usato con il + /A+: aggiunge gli attributi a TUTTI i file...) e invalida l'idea di fare un MIRROR.

    Robocopy  senza /A-:SH  e un  attrib finale per me possono bastare

    ciao


    Gastone Canali >http://www.armadillo.it


    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    sabato 2 aprile 2016 16:13
    Moderatore
  • Concordo con te sul risultato finale sugli hidden, ma spesso Robocopy viene utilizzato per file non di sistema. L'alternativa è quella di utilizzare attrib dopo aver eseguito la copia.

    sabato 2 aprile 2016 16:35
    Moderatore