none
Problema con lo stack TCP di Windows Vista RRS feed

  • Domanda

  • Su windows vista con gli ultimi service pack installati riesco a collegarmi sia tramite LAN sia tramite Wi-Fi, ma per entrambe le reti ho questo problema:

    * ping e tracert funzionano perfettamente

    * lo stack TCP e UDP invece non va per nulla. Non riesco a navigare ne' con Firefox, ne' con Explorer, ne' tramite curl da linea di comando

    Ho gia' provveduto a disabilitare il TCP IPv6 e l'IP Helper, reinstallare i driver delle schede di rete, disabilitarne una per volta, resettare winsock, il tutto senza successo. Installando l'ultima versione di netmon quando lancio curl da linea di comando non vedo nulla nonostante netmon sia in ascolto. Invece ping e tracert vengono "catturati" da netmon regolarmente.

    Come se ne esce?

    sabato 30 ottobre 2010 00:05

Risposte

  • Trovata la soluzione qui: http://social.answers.microsoft.com/Forums/en-US/vistanetworking/thread/aa562352-eeb1-48cf-8961-eabc3e169d52

    In pratica Norton 360 si era inspiegabilmente corrotto e bloccava il traffico TCP. La cosa strana e' che non c'era modo di capirlo perche' tutte le procedure ufficiali di reset di winsock, reinstallazione driver, disabilitazione tcp v6 non andavano. Neanche NetMon aiuta perche' evidentemente Norton si pone a monte del traffico tcp (e comunque prima di NetMon) e bloccava i pacchetti in uscita.

    Norton 360 neanche appariva in esecuzione, me ne sono accorto della sua esistenza andando per tentativi.

    Credo che le varie guide disseminate qui e li' per risolvere i problemi di networking dovrebbero includere una procedura che sia in grado di ripristinare il traffico in uscita superando le modifiche introdotte da programmi di terze parti, benevoli o malevoli. Norton 360 neanche si disinstallava correttamente, fortunatamente c'e' un tool di uninstall ad-hoc che ha risolto il problema. Se neanche tale tool avesse funzionato, da quello che mi pare di capire non ci sarebbe stato un modo semplice per far funzionare la rete se non la reinstallazione dell'intero sistema operativo.

    • Contrassegnato come risposta blackab122 lunedì 1 novembre 2010 20:47
    lunedì 1 novembre 2010 20:47

Tutte le risposte

  • Trovata la soluzione qui: http://social.answers.microsoft.com/Forums/en-US/vistanetworking/thread/aa562352-eeb1-48cf-8961-eabc3e169d52

    In pratica Norton 360 si era inspiegabilmente corrotto e bloccava il traffico TCP. La cosa strana e' che non c'era modo di capirlo perche' tutte le procedure ufficiali di reset di winsock, reinstallazione driver, disabilitazione tcp v6 non andavano. Neanche NetMon aiuta perche' evidentemente Norton si pone a monte del traffico tcp (e comunque prima di NetMon) e bloccava i pacchetti in uscita.

    Norton 360 neanche appariva in esecuzione, me ne sono accorto della sua esistenza andando per tentativi.

    Credo che le varie guide disseminate qui e li' per risolvere i problemi di networking dovrebbero includere una procedura che sia in grado di ripristinare il traffico in uscita superando le modifiche introdotte da programmi di terze parti, benevoli o malevoli. Norton 360 neanche si disinstallava correttamente, fortunatamente c'e' un tool di uninstall ad-hoc che ha risolto il problema. Se neanche tale tool avesse funzionato, da quello che mi pare di capire non ci sarebbe stato un modo semplice per far funzionare la rete se non la reinstallazione dell'intero sistema operativo.

    • Contrassegnato come risposta blackab122 lunedì 1 novembre 2010 20:47
    lunedì 1 novembre 2010 20:47
  • La risposta l'hai data da solo.

    Se "software" distruttivi , malscritti , che corrompono funzioni vitali del sistema operativo vengono continuamente installati malgrado gli avvertimenti costanti di chi giornalmente li combatte ecco che occorre reinstallare di nuovo ed in modo pulito il sistema per liberarlo.

    Non so se hai usato un software di ricerca nel registro per verificare le chiavi/sottochiavi/valori modificati da Norton 360 (ma non solo , basta verificare qualsiasi altro software Symantec).

    L'ultimo nostro (Laboratori privati , nulla a che vedere con Microsoft) report di una "pulizia" eseguita su una macchina con quel software installato ha segnalato 2743 riferimenti.

    Fai tu le valutazioni.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    lunedì 1 novembre 2010 22:43
    Moderatore