none
Indirizzo IP errato del Name Server su DNS del RODC. RRS feed

  • Domanda

  • Aiuto.

    Dopo due anni di attività, improvvisamente oggi pomeriggio sul DNS del RODC di una sede remota ho trovato impostato l'IP del Name Server (residente sul DC e connesso in VPN) su un indirizzo sbagliato: 192.168.10.168 invece di 192.168.10.1.

    Il risultato è che non si riesce più a contattare il Domain Controller e gli utenti senza cache locale non riescono nemmeno più a loggarsi in rete !

    Ho provato sul DNS locale a dare un "Clear cache" ed un "Reload zone" ma senza risultati.

    Quali altre verifiche posso fare ?

    Abbiamo praticamente una sede ferma ...

    Grazie.

    ALex.




    • Modificato Alex_B_ venerdì 11 aprile 2014 19:26
    venerdì 11 aprile 2014 18:26

Tutte le risposte

  • Ciao, prima di tutto devi assicurarti che il tunnel sia su e che i pacchetti passino correttamente. Riesci a pingare il DC? Si? Bene, prova a rimettere il dns corretto sul rodc ed a riavviarlo. Se non riparte proverei un force della replica del rodc, qui trovi le informazioni necessarie. Poi vediamo come evolve. Quanti client nella sede remota? http://technet.microsoft.com/en-us/library/cc816926(v=ws.10).aspx Ciao. A.
    venerdì 11 aprile 2014 20:03
    Moderatore
  • Ciao, prima di tutto devi assicurarti che il tunnel sia su e che i pacchetti passino correttamente. Riesci a pingare il DC? Si? Bene, prova a rimettere il dns corretto sul rodc ed a riavviarlo. Se non riparte proverei un force della replica del rodc, qui trovi le informazioni necessarie. Poi vediamo come evolve. Quanti client nella sede remota? http://technet.microsoft.com/en-us/library/cc816926(v=ws.10).aspx Ciao. A.

    Ciao !

    Dunque, il tunnel era regolarmente su, ed il DC si pingava regolarmente l'unica cosa fuori posto era l'IP del Name Server errato (192.168.10.198 invece di 192.168.10.1). 

    Purtroppo anche forzando la replica più volte la situazione non cambiava.

    La configurazione dei server (2008-R2) è:

    Sede (DC/DNS/DHCP server: 192.168.10.1)  >>>----- VPN ----->>> Filiale (RODC/DNS/DHCP: 192.168.20.1)

    Sul server della Filiale i ruoli DC/DNS sono in sola lettura e le impostazioni di rete sono:

    SERVER: 
    IP: 192.168.20.1
    DNS1: 192.168.20.1
    DNS2: 192.168.10.1

    CLIENTS:
    IP: da DHCP
    DNS1: 192.168.20.1
    DNS2: 192.168.10.1

    Come ho risolto momentaneamente (ma non so perchè):

    a) sulla scheda di rete del SERVER di Filiale ho impostato come unico DNS l'IP del DC SERVER (192.168.10.1).

    b) sulle impostazioni del DHCP della Filiale ho fatto la stessa cosa (unico DNS=192,168.10.1)

    Fatto questo dopo pochi secondi sul DNS del RODC della Filiale, il record relativo al Name Server è improvvisamente tornato giusto: 192.168.10.1 !!!

    Ma non capisco il motivo ...

    Adesso è tornato tutto a funzionare, ma con grandi limiti visto che con queste nuove impostazioni ho di fatto oscurato il DNS locale e tutto fa riferimento al DNS del Domain Controller, quindi l'autenticazione degli utenti e tutte le chiamate al DNS passano per la VPN.

    Infatti adesso sia l'autenticazione che la risoluzione dei nomi sono diventati molto lenti e TEMO che se dovesse andare giù la VPN si fermi tutto :( ...

    ALex.



    • Modificato Alex_B_ sabato 12 aprile 2014 05:57
    sabato 12 aprile 2014 05:54
  • scusa ma non riesco a capire bene. parli del nameserver che ottieni da

    nslookup

    set type=ns

    <domain name> 

    ?


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    venerdì 18 aprile 2014 12:43
    Moderatore
  • scusa ma non riesco a capire bene. parli del nameserver che ottieni da

    nslookup

    set type=ns

    <domain name> 

    ?


    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    Scusa, capisco che possa non essere chiarissimo.

    Dunque, i records DNS del mio RODC dovrebbero essere identici per numero e valore a quelli del DNS del DC (al netto di modifiche ancora da sincronizzare).

    Bene, l'altra sera il Servizio Active Directori del mio RODC ha iniziato a produrre raffiche di logs che evidenziavano l'impossibilità di contattare il DC, con conseguente impossibilità di sincronizzare l'albero di Active Directory ecc ...

    Bene ... sul RODC, aprendo la console del Server Manager -> Ruolo DNS Server -> nomeRODC -> Forward Lookup Zones -> miodominio  ho trovato i seguenti primi due records:

    - Start Of Authority (SOA) = "nomeDC"  ... (ok)
    - Name Server (NS) = "nomeDC", IP Address=192.168.10.168 (sbagliato: doveva essere 192.168.10.1)

    Invece lo stesso record sul DC riportava il valore giusto: 192.168.10.1

    e anche forzare la sincronizzazione non ha portato ad alcun risultato.

    Il problema è che non ho capito come sia comparso quell'IP nel record del DNS locale, visto che è una replica di ciò che è scritto nel Domain Controller e che era giusto.

    Non le lo spiego.

    ALex.



    • Modificato Alex_B_ venerdì 18 aprile 2014 15:01
    venerdì 18 aprile 2014 15:00
  • ok. ora se sul RODC nel dns manager, fai click destro su quel record "Nameserver", scegli Proprietà, selezioni di nuovo il server con l'ip sbagliato, clicchi su Edit, lo vedi con il segno di spunta verde ? se non è così, clicca sopra e modifica l'ip mettendo quello corretto e conferma.

    Edoardo Benussi
    Microsoft MVP - Directory Services
    edo[at]mvps[dot]org

    venerdì 18 aprile 2014 15:29
    Moderatore