none
quali utenti sono "logged in"? RRS feed

  • Domanda

  • ciao a tutti,
    ho una piccola rete con alcuni pc, tutti in un workgroup.
    vorrei sapere quali sono gli utenti che sono loggati.

    ho provato coi seguenti comandi:

    PSLOGGEDON \\nomepc

    quser /server:nomepc

    WMIC /node:"nomepc" COMPUTERSYSTEM GET USERNAME

    query session /server:nomepc

    e se li lancio dal mio pc, funzionano bene ma, per alcuni pc solamente, mi ritorna errore 5 accesso negato

    ho attivato il servizio "remote registry" su tutti i pc

    per tutti i pc ho effettuato questa modifca nel registro:

    reg delete "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v AllowRemoteRPC
    reg add "HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server" /v AllowRemoteRPC /t REG_DWORD /d 1

    ma niente, continua, solo per alcuni pc, a darmi accesso negato.

    cosa posso fare?

    grazie, ciao
    venerdì 13 ottobre 2017 13:02

Risposte

  • Inserisci nella riga di comando di WMIC le credenziali di un account con diritti amministrativi sulla macchina, per fare questo puoi utilizzare i parametri /user: e /password:
    https://msdn.microsoft.com/en-us/library/aa394531(v=vs.85).aspx

    In alternativa, dovresti modificare le impostazioni di sicurezza DCOM e del namespace WMI, ma sinceramente non lo consiglio.
    Tutti questi passaggi sono necessari perché ti trovi in un ambiente workgroup, in dominio la cosa sarebbe molto più semplice perché le autorizzazioni sulla macchina vengono gestite dal dominio stesso.

    venerdì 13 ottobre 2017 19:55
    Moderatore

Tutte le risposte

  • Ciao, quale dei comandi non funziona? Hai verificato wmi?

    Saluti
    Nino


    www.testerlab.it

    venerdì 13 ottobre 2017 13:45
    Moderatore
  • ciao nino,

    per tutti i comandi ho accesso negato, per wmi per esempio ho questa risposta:

    Node - nomepc
    ERROR:
    Description = Access is denied.

    con PSLOGGEDON ho (solo per alcuni pc):

    PsLoggedOn v1.31 - Logon Session Displayer
    Copyright (C) 1999-2003 Mark Russinovich
    Sysinternals - www.sysinternals.com

    Error opening HKEY_USERS for \\nomepc
    Make sure that the Remote Registry service is started on \\nomepc
    Unable to query resource logons




    • Modificato danimarco92 venerdì 13 ottobre 2017 14:08
    venerdì 13 ottobre 2017 13:58
  • Per prima cosa assicurati di aver impostato su tutti i computer questo valore DWORD a 1:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\LocalAccountTokenFilterPolicy

    venerdì 13 ottobre 2017 14:28
    Moderatore
  • si scusa dimenticato di scriverlo

    su tutti i pc fatto

    venerdì 13 ottobre 2017 17:01
  • Inserisci nella riga di comando di WMIC le credenziali di un account con diritti amministrativi sulla macchina, per fare questo puoi utilizzare i parametri /user: e /password:
    https://msdn.microsoft.com/en-us/library/aa394531(v=vs.85).aspx

    In alternativa, dovresti modificare le impostazioni di sicurezza DCOM e del namespace WMI, ma sinceramente non lo consiglio.
    Tutti questi passaggi sono necessari perché ti trovi in un ambiente workgroup, in dominio la cosa sarebbe molto più semplice perché le autorizzazioni sulla macchina vengono gestite dal dominio stesso.

    venerdì 13 ottobre 2017 19:55
    Moderatore
  • grazie mille Fabrizio!

    ottimo suggerimento, adesso tutto ok

    oltre ad inserire le opzioni /user: e /password: (occhio che se avete caratteri speciali nella pwd va inserita tra doppi apici...) ho dovuto anche abilitare sotto windows firewall l'eccezione per "windows management instrumentation (WMI)" che non avevo ancora abilitato

    il comando finale quindi è:

    WMIC /node:"nomepc" /USER:miouser /PASSWORD:"miapwd" COMPUTERSYSTEM GET USERNAME

    grazie ancora, ciao!

    sabato 14 ottobre 2017 14:47