none
Sysprep Windows 10 RRS feed

  • Domanda

  • Salve come avevo scritto in un altro post ho dei problemi con la sysprep su dei PC clonati, in pratica la sysprep funziona sul PC in cui ho installato W10 ma non funziona in quelli clonate.

    Mi chiedevo se è sempre necessaria la sysprep per inserire dei pc W10 clonati  in un dominio.

    Saluti

    Giuseppe


    lunedì 5 settembre 2016 14:01

Tutte le risposte

  • Ciao, certo, per forza, altrimenti se li "cloni" solamente avranno tutti lo stesso SID. il sysprep è fatto apposta per assegnare in fase di aggancio un SID diverso ad ognuno.

    ciao.

    A.

    lunedì 5 settembre 2016 14:11
    Moderatore
  • In che senso non funziona? Ti restituisce un errore durante la procedura di sysprep?

    Il caso più frequente è che nel frattempo le App di sistema si sono aggiornate automaticamente via internet (KB Microsoft), quindi prima di eseguire sysprep dovresti scollegare il computer da internet ed eseguire questi comandi PowerShell (come amministratore):

    Get-AppXPackage -AllUser | % {if ($_.PackageUserInformation.InstallState -eq "Staged"){$_.PackageFullname}}
    get-appxpackage | remove-appxpackage

    Una volta terminato il processo (è normale ricevere uno o più errori) puoi provare ad eseguire il sysprep.

    PS: Se l'immagine ha già ricevuto l'errore perché non avevi eseguito lo script, solitamente non può essere riutilizzata perché passa in uno stato incoerente. Solitamente in questi casi è preferibile ripartire dall'immagine originale.




    lunedì 5 settembre 2016 14:33
    Moderatore
  • Sul pc dove ho installato w10 se faccio la sysprep ho un errore, se elimino il valore upgrade dal registry come indicato qui http://www.wintips.org/fix-sysprep-not-able-validate-windows-installation/

    la sysprep funziona, se clono partendo da quel pc verso un  pc identico con un immagine fatta prima della sysprep oppure quando faccio la sysprep (spengo senza riavviare) al riavvio del nuovo pc sembra funzioni ma dopo le prime schermate invece di continuare la configurazione il pc si riavvia e riparte dall'inizio.

    lunedì 5 settembre 2016 15:54
  • ok, ma qui siamo passati da una semplice domanda a doppiare il post precedente.

    Ti giro un link uscito pochi giorni fa per generalizzare l'immagine. Seguendo la procedura passo passo dovresti risolvere.

    https://technet.microsoft.com/en-us/itpro/windows/deploy/create-a-windows-10-reference-image

    A.

    lunedì 5 settembre 2016 16:34
    Moderatore
  • Ciao Giuseppe, come ti è già stato risposto nel precedente thread dovresti partire da una installazione pulita.

    Installi il sistema operativo, esegui gli aggiornamenti, installi le applicazioni, esegui il Sysprep ed esegui il clone.

    Per inquadrare meglio le attività che stai svolgendo, puoi rispondere alle seguenti domande:

    1) Parti da una installazione pulita o dalla versione di Upgrade?

    2) Il PC fa parte di un dominio?

    3) Come viene eseguito il clone ed il successivo restore?

    Saluti
    Nino

    lunedì 5 settembre 2016 16:42
    Moderatore
  • Parto da una installazione pulita da un ISO scaricato da dreamspark,

    il pc fa parte di dominio

    Uso il software Acronis True Image 2014 boot da una penna usb

    scusate se ho sdoppiato se volete apro un altro post

    lunedì 5 settembre 2016 17:10
  • perchè lo agganci a dominio prima di generallizzare??

    lunedì 5 settembre 2016 17:19
    Moderatore
  • perchè avevo usato il pc come test per il dominio, però ho provato anche a toglierlo dal dominio prima di fare la sysprep

    lunedì 5 settembre 2016 17:33
  • domanda:

    se clono il pc prima di fare la sysprep e poi eseguo la sysprep sul pc clonato di regola dovrebbe funzionare ?

    Con W7 non ho mai avuto problemi

    lunedì 5 settembre 2016 17:36
  • Ma sysprep ti restituisce esattamente l'errore riportato nell'articolo? Oppure è un errore "simile"? Perché quella chiave di registro gestisce diverse cose.

    Verifica attentamente la problematica che ti ho descritto precedentemente (ti ho inserito anche un link alla KB ufficiale), la maggior parte dele volte i problemi di sysprep in Windows 10 sono causati da quello.



    lunedì 5 settembre 2016 17:53
    Moderatore