none
Hypervisor 2016 - non riesco a connettermi da pc W10 (console di gestione HV) sulla stessa LAN

    Domanda

  • Ciao,

    come da oggetto, non riesco a connettermi dal PC W10 nella stessa lan tramite la console di gestione Hyper-V ad un server Hyper-V 2016
    riesco a collegarmi in desktop remoto, ma non a gestire da remoto la console per la creazione/gestione delle VM

    ho già guardato in giro diversi siti sull'argomento, provati diversi comandi pshell, ma senza successo

    la console sul PC W10 mi dice errore durante il tentadivo di connettersi al server 192.168.1.x controllare che il servizio virtual machine management sia in esecuzione ecc..

    il servizio vmms ovviamente è in running

    massimo



    martedì 4 aprile 2017 15:01

Risposte

Tutte le risposte

  • Esattamente qual è la build di Windows 10 e di Hyper-V 2016?
    Potresti descrivere anche le prove che hai eseguito? Ti trovi in dominio oppure host o client sono in workgroup?
    Mi confermi di aver provato i comandi riportati in questa pagina?
    https://technet.microsoft.com/en-us/windows-server-docs/compute/hyper-v/manage/remotely-manage-hyper-v-hosts
    martedì 4 aprile 2017 22:05
    Moderatore
  • - server e pc in workgroup nella stessa lan (no dominio)
    - build W10 pc 1607 143939.969 GA
    - build HV 2016 server 10.0.14393 server autonomo

    i comandi già impartiti:

    Enable-PSRemoting (ad entrambi, pc e server)

    Enable-WSManCredSSP -Role server (ovviamente al solo server)


    questi ovviamente solo al pc desktop
    Set-Item WSMan:\localhost\Client\TrustedHosts -Value "nome srv"
    Enable-WSManCredSSP -Role client -DelegateComputer "nome srv"




    mercoledì 5 aprile 2017 10:28
  • Sul pc desktop hai abilitato anche la policy locale "Allow delegating fresh credentials with NTLM-only server authentication" come specificato nella guida? Successivamente hai eseguito un riavvio del computer?
    Se ancora non funziona prova, come test, a disabilitare momentaneamente Windows Firewall sull'host per escludere una problematica con le regole WinRM.
    mercoledì 5 aprile 2017 10:49
    Moderatore




  • ovviamente ho riavviato il pc
    non posso disabilitare il firewall sul server HV perché chiude completamente tutte le comunicazioni IP, non lo pinghi nemmeno più

    una domanda
    è possibile avere la console di gestione delle VM sul server HV?
    almeno quello sarebbe già sufficiente


    mercoledì 5 aprile 2017 11:22
  • non posso disabilitare il firewall sul server HV perché chiude completamente tutte le comunicazioni IP, non lo pinghi nemmeno più
    Ma lo hai disabilitato con il comando "netsh advfirewall set AllProfiles state off"?
    Sinceramente non mi è mai successo che la disabilitazione di Windows Firewall rendesse impossibile ogni comunicazione, oppure ti riferisci a qualcos'altro?

    Comunque vedi se questa web GUI ti può interessare: http://hv-manager.org/
    mercoledì 5 aprile 2017 15:25
    Moderatore
  • Ma lo hai disabilitato con il comando "netsh advfirewall set AllProfiles state off"?

    si

    http://hv-manager.org/

    provo subito ad installarlo, magari per me è sufficiente
    (però questo HV deve avere una VM WS2016STD in replica su un altro server, speriamo la webgui mi permetta di fare la configurazione)

    installato, non puoi nemmeno creare una nuova VM
    giusto fare riavvii, shutdown, start ecc..
    grazie, ma è inutile per me :(

    ragazzi che faccio un bel format C: e ci metto W2016 STD ED
    e poi dentro creo la VM?

    questo HV è interessante, ma se poi non posso gestirlo da una console HV io sono bloccato.. :(
    (potrei gestirlo da power shell, ma lo trovo troppo dispendioso di tempo, non mi sta bene)









    venerdì 7 aprile 2017 09:41
  • Se proprio non riesci ed hai la licenza puoi anche utilizzare un'altra edizione come host Hyper-V, non ci sono controindicazioni. Tuttavia un'installazione Core offre dei vantaggi in fatto di utilizzo delle risorse e di minore esposizione agli attacchi (proprio per il fatto che vengono eseguiti solo i servizi essenziali).
    Se invece vuoi fare un altro tentativo, potresti anche provare (sempre se possibile) ad aggiungere host e client ad uno stesso dominio, in questo modo si semplifica di molto la configurazione.
    Ti consiglio inoltre di abilitare queste regole firewall in Hyper-V Server:
    https://www.ivobeerens.nl/2015/08/28/manage-hyper-v-in-a-workgroup-remotely/
    Anche l'allineamento di cumulative pack tra Server 2016 e Windows 10 è secondo me fondamentale per la buona riuscita della connessione.


    venerdì 7 aprile 2017 11:50
    Moderatore
  • Visto che avevo un po' di tempo ti ho scritto un articolo:
    http://itlabz10.tk/archives/1025
    Seguendo tutti i passaggi dovresti risolvere.
    sabato 8 aprile 2017 10:39
    Moderatore
  • grazie 10000 per la guida, utilissima
    ho seguito passo per passo, ri-verificato

    Ora è cambiato l'errore che mi da la console sul pc desktop w10, però credo quanto meno
    di aver fatto un passo avanti

    aggiornamento, se ci accedo con l'hostname funziona tutto!!!!
    (è con l'ip che non va)
    grazie 10000 :)

    sabato 8 aprile 2017 14:47
  • Infatti nella guida avevo specificato di utilizzare il nome host :)
    Utilizzando l'indirizzo IP è normale che non funzioni, succedeva la stessa cosa anche con le versioni precedenti di Hyper-V.
    sabato 8 aprile 2017 23:41
    Moderatore
  • portato il server nella rete del Cliente
    messo su non riesco a collegarmi con la console hvmanager da un PC della rete del Cliente W10

    ho anche provato a mettere in dominio l'hyperV, non mi fa collegare con la console HV dal pc desktop nemmeno con le credenziali di domain admin

    sono fermo dinuovo al punto di partenza :(

    al momento sono riuscito a lavorare installando su un pc 5 9 manager

    https://www.5nine.com/5nine-manager-for-hyper-v-product.aspx

    ma vorrei potermi connettere anche dalla console HV di MS...



    mercoledì 12 aprile 2017 16:47
  • Forse c'è un firewall/router tra client e server oppure sul client la rete non è identificata come privata.
    L'unica cosa è andare per esclusione, ma il messaggio di errore è sempre lo stesso (relativo alle autorizzazioni)?
    Non è che hai dimenticato di eseguire qualche passaggio sul client?
    mercoledì 12 aprile 2017 19:34
    Moderatore
  • calcola che 5-9 manager si collega senza problemi...
    al volo subito appena installato

    ora per lo meno ho messo la macchina WS2016STD guest in dominio si è presa le policy e posso collegarmici in RDP, almeno posso andare avanti col lavoro, promuoverla a DC ecc.. ecc..

    il riavvio e spegnimento della VM posso farlo con l'utility di hv-manager.org
    non sono più fermo col lavoro, però vorrei poter usare tutte le funzionalità avanzate della console HV Microsoft
    anche perché presto dovrò mettere in replica la macchina guest..

    i passaggi vari sul PC desktop W10 pro 64bit ita in dominio (OS 1607) li ho fatti tutti
    compreso questo

    Set-NetConnectionProfile -interfacealias Ethernet -NetworkCategory Private

    che mi sbrodola giù un errore lungo un kilometro
    cmq firewall tra il pc e il server hw non ce ne sono, la rete l'ho creata io e la conosco come le stanze di casa mia :)

    mercoledì 12 aprile 2017 19:40
  • Il fatto che un manager di terze parti si colleghi senza problemi non significa nulla: potrebbe utilizzare meccanismi di comunicazione molto più semplici rispetto a WinRM.
    In ogni caso probabilmente le difficoltà che stai riscontrando sono dovute al fatto che il client si trova in dominio mentre il server no (molto strano che non ti abbia subito funzionato inserendo l'host Hyper-V in dominio).
    In questi casi (client in dominio e server no) quando utilizzi il comando cmdkey assicurati di utilizzare la notazione completa ( /user:nomeserver\username ) in modo che il client non provi ad autenticarsi per errore con un account di dominio.
    Un'altra cosa da verificare è il suffisso DNS assegnato al server: se stai utilizzando ad esempio il DNS di dominio invece del file host devi utilizzare l'FQDN completo (per tutti i comandi e anche per la connessione).
    mercoledì 12 aprile 2017 19:55
    Moderatore
  • Fabrizio, preso dalla disperazione :) ho joinato in dominio anche l'hypervisor
    e non va lo stesso..

    purtroppo non va né con l'FQDN es. "hv-srv.dominio.local", né con l'hostname "hv-srv"

    fin lì ci arrivo anch'io ;)

    normalmente io installo sempre Windows server standard come virtualizzatore e poi creo i server come guest...
    questa è la prima installazione dell'Hypervisor diretto su bare metal
    'sti capperi... 

    una cosa che mi viene in mente è che la rete del Cliente ha una classe C diversa da quella del mio studio dove l'hv manager funzionava, potrebbe essere questo il problema?



    mercoledì 12 aprile 2017 19:58
  • Ti dico tutte le cose che possono essere, se non me lo dici non lo so se hai già utilizzato per tutti i comandi anche l'FQDN.
    In ogni caso in dominio ti deve funzionare per forza altrimenti c'è qualcosa che non va sul client (tutti i passaggi di autorizzazione sono praticamente automatici).
    Comunque non mi hai ancora detto se l'errore è lo stesso o no....
    mercoledì 12 aprile 2017 20:12
    Moderatore
  • domani quando vado dal Cliente ti so dire i dettagli
    mercoledì 12 aprile 2017 20:25
  • secondo me è qualche problema di firewall dell'hypervisor/wcore
    la classe di ip della lan è diversa da quella che aveva nel mio studio
    di fatto non pingo più l'ip dell'hypervisor e non posso nemmeno più accedere alla porta 8097 della web app di hvmanager...


    update: l'icmp ora va e l'hvmanager lo raggiungo, ho ri-dato i comandi di apertura delle porte sul fw
    (probabilmente con la classe C nuova i comandi vanno ri-impartiti) 
    la pagina web dell'hvmanager la raggiungo, ma non vede nessuna VM... stranissimo

    ho provato a collegarmi dalla console di gestione HV sul vecchio DC 2008R2
    sembra collegarsi poi dopo un po' mi da "operazione non riuscita nel computer hv-srv1"





    venerdì 14 aprile 2017 09:25
  • Secondo me per qualche motivo l'utente che esegue il servizio web, che probabilmente è lo stesso che utilizzi per eseguire la connessione dalla console del client, non ha più i privilegi per la gestione delle VM.
    Dal client riesci ad accedere tramite MMC ad altri servizi oltre alla gestione Hyper-V? Ad esempio la gestione computer. 
    Per sicurezza prova inoltre ad aggiungere l'account locale presente sul server al gruppo locale "Hyper-V Administrators": https://blogs.msdn.microsoft.com/virtual_pc_guy/2014/06/11/allowing-non-administrators-to-control-hyper-vupdated/
    venerdì 14 aprile 2017 12:07
    Moderatore
  • scusate se non ho più risposto al thread (purtroppo ho problemi più urgenti, quello della sysvol...)

    ho trovato questo tool gratuito

    https://pshvm.codeplex.com/

    che al momento per le funzioni base è sufficiente
    però appena ho sistemato le cose più urgenti voglio andare in fondo e sistemare anche questo problema 



    giovedì 11 maggio 2017 21:25
  • ciao a tutti,

    aggiornamento dopo aver messo appunto l'host HV in dominio
    provo a collegarmi da un pc w10 pro ovviamente joinato allo stesso dominio

    ora l'errore è diverso

    mi dice "Impossibile abilitare la delega delle credenziali al server "taldeitali" :)
    L'autenticazione CredSSP è attualmente disabilitata nel client locale:
    Per abilitare CredSSP è necessaria l'esecuzione con privilegi di amministratore

    venerdì 19 maggio 2017 16:40
  • Sul client apri una console PowerShell come amministratore e digita:
    Enable-WSManCredSSP -Role "Client" -DelegateComputer "server.dominio.local"

    venerdì 19 maggio 2017 20:41
    Moderatore