none
Impossibile sfogliare i computer in VPN, con una rete AD SBS 2008 RRS feed

  • Domanda

  • Buonasera.

    Ho un dominio (SBS 2008) installato in una sede perfettamente funzionante, con classe IP C 192.168.0.x. Tramite Zywall 5 (in sede) e Zywall 2 (nelle 3 sedi staccate) ho creato le VPN (ZYXELL) e le 3 filiali hanno IP 192.168.9.x, 192.168.11.x, 192.168.21.x.

    I pc, dopo aver eseguito http://connect (comando SBS x la registrazione pc al dominio) diventano pc del dominio, viene creato il PTR DNS e sembra tutto corretto.

    Dal server se sfoglio la rete vedo solo il ramo 192.168.0.x

    Se pingo le macchine degli altri rami (le filiali) le vedo ed il DNS (del server AD installato in sede) risolve correttamente l'IP.

    nslookup sui client della sede e delle filiali non dà errori.

    Nelle 3 reti delle filiali, dove ho pc e stampanti, dai pc se sfoglio la rete vedo solo i dispositivi appartenenti alla rete da cui eseguo il comando.

    Tutto questo avviene, a mio giudizio, dopo aver elevato il server 2008 (PDC) da dominio compatibile 2003 a 2008.

    Come posso risolvere?

    Grazie a chiunque si presti a suggerimenti!

     

    sabato 30 aprile 2011 21:50

Risposte

Tutte le risposte

  • Ciao Stefano, le VPN sono di tipo ANY ovvero ci fai passare tutto?

    Leggi questi articoli:

    http://technet.microsoft.com/it-it/library/cc754938(WS.10).aspx

    http://technet.microsoft.com/en-us/library/409fb2fa-8eb8-45af-b063-4f50f5a77b29

     

    Saluti

    Nino


    • Contrassegnato come risposta Stefano Marossi domenica 1 maggio 2011 21:01
    • Contrassegno come risposta annullato Stefano Marossi domenica 1 maggio 2011 21:01
    sabato 30 aprile 2011 22:09
    Moderatore
  • Grazie Nino,

    Le VPN ZYXEL sono ANY (Netbios compreso).

     

    le filiali hanno pc con xp sp3 e alcuni thin client HP.

    Ho installato, come da Suo suggerimento, il componente LLTD responder x il map creator di Vista e 2008, ma senza successo.

    Il mio vero problema è il PDC SBS W2K8 in sede. Per le filiali risolvererò dopo.

    Sfogliando la rete dal server, prima dell'elevazione a dominio 2008, quindi in modalità 2003 compatibile, vedevo l'intera infrastruttura.

    E' una mia deduzione; ma non ho fatto altre procedure di configurazione o manutenzione al di là di questa operazione, ottenendo ad oggi, sistematicamente questo difetto.

    Dopo essere passato al modo 2008, vedo solo la rete 192.168.0.x, ma se pingo le filiali i pc mi rispondono (ho aggiunto io staticamente nel DNS i PTR A delle macchine Thin Client non inserite nel dominio).

    Tutto ciò è fastidioso. Gli utenti della sede (sui pc del ramo 192.168.0.x) hanno lo stesso problema e sono tutte macchine XP SP3.

    Sembra stupido lo sò (gli utenti sono utenti), ma le persone sfogliano la rete per vedere se c'è o non c'è una persona.

    qualche altro spunto?

    Grazie ancora!

     

    domenica 1 maggio 2011 21:19
  • hai provato a installare il ruolo WINS sul server e distribuire l'indirizzo di questo server alla reti periferiche?

    potresti postare un ipconfig /all di un client della rete periferica?

     

     

     


    Adriano - MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]adcoop.it
    lunedì 2 maggio 2011 17:11
  • Penso che ricadiamo in questa tipologia, legata proprio all'upgrade a Windows 2008 del PDC emulator

    NetBIOS browsing across subnets may fail after upgrading to Windows Server 2008

    http://blogs.technet.com/b/networking/archive/2008/07/25/netbios-browsing-across-subnets-may-fail-after-upgrading-to-windows-server-2008.aspx

    Dovresti mettere il servizio Computer Browser in avvio automatico sul PDC emulator (comunque per maggiori dettagli ti invito a leggere l'articolo)

     


    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    martedì 3 maggio 2011 06:33
  • Grazie ma volevo evitare di installare WINS.

    Fino a settimana scorsa funzionava.

     

    martedì 3 maggio 2011 21:01
  • mi sa che ci simao.

    Domani faccio delle prove.

    Grazie molte per ora.

     

    martedì 3 maggio 2011 21:01
  • Grande!!!!!

    In SBS 2K8 dopo che si eleva a dominio compatibile solo 2800, mamma Microsoft disabilita il Browser di computer a livello di servizio e porta il Server Message Block alla 2.0 (VISTA e 2008 Compatible).

    Soluzione:

    Riabilitato il servizio Browser Computer sul PDC e ripristinato il Redirector al SMB 1.0 così:

    1. Run "regedit" on Windows Server 2008 based computer.
    2. Expand and locate the sub tree as follows.
    HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters
    1. Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)
    2. Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.
    3. Reboot the server.

    Et Voilat appena il Server PDC riparte e si sfoglia la rete appaiono tutti i computer del dominio e non di tutte le sottoreti, e non solo, tutti i pc (anche i TrmSrv Thin Client HP) delle sottoreti vedono tutto.

     

    Grazie a tutti per il prezioso aiuto.

    !!Stefano!!

    mercoledì 4 maggio 2011 20:57
  • Grazie a te per il feedback
    Fabrizio Volpe
    MVP Directory Services
    MCSE (NT4)(2000)(2003) - MCSA (2003)
    MCTS (SQL 2005)(Exchange 2007)(Windows 2008)
    Fortinet Certified Network Security Professional (FCNSP)
    Fabrizio[_dot_]Volpe[_at_]GMX[_dot_]com
    giovedì 5 maggio 2011 07:52