locked
IE 8 Impossibile installare e aggiornare ActiveX RRS feed

  • Domanda

  • ciao a tutti,

    come da oggetto sono su un pc con windows 7 completamente aggiornato (no antivirus, no antispyware): quando da ie8 tento di installare un qualsiasi activex (ad esempio anche il semplice controllo di genuinità presente in questa pagina http://www.microsoft.com/downloads/details.aspx?familyid=C7D4BC6D-15F3-4284-9123-679830D629F2&displaylang=it ) succede questo:

    compare la "Internet Explorer Information Bar" > autorizzo l'installazione > compare la maschera "controllo accaunt utente " in cui mi viene richiesta conferma dell'installazione  > sembra faccia qualcosa ed in basso a sinistra copare "finito".
    sembra essere installato ma in realtà non ha fatto niente e rimango in un loop infinito.

    Ovviamente sono amministratore del pc e ho gia provato a mettere al minimo le impostazioni di sicurezza di IE8.
    nei file temporanei il file viene scaricato ma non installato.

    qualche consiglio??

    grazie a tutti in anticipo.

    martedì 6 luglio 2010 15:34

Risposte

  • Come accennato da Vincenzo fai un avvio pulito:

    Digita :
    msconfig
    e dai invio nel box di ricerca del menù start.
    Vai alla sezione Avvio.
    Togli tutte le spunte meno quelle relative all'antivirus.
    Dai ok.
    Non riavviare.
    Vai alla sezione Servizi.
    Metti la spunta per nascondere tutti i servizi Microsoft.
    Disabilita tutti gli altri.
    Dai ok.
    Non riavviare.
    Vai in C:\windows\prefetch
    Cancella tutti i file (compresa la cartella ReadyBoot che verrà ricreata)
    meno il file layout.ini.
    Vai in C:\windows\temp
    Cancella tutti i file cancellabili.
    Pannello di controllo > opzioni internet , clicca su Elimina per ripulire i
    temporanei e la cronologia.
    Dai ok.
    Vuota il cestino.
    Riavvia.
    Al riavvio scarica Wise Registry Cleaner Free Portable:
    http://www.wisecleaner.com/soft/WRCFree.zip
    Estrai il file e lo lanci (oppure lo installi se hai scelto di scaricare la versione con l'installer).
    Metti tutte le spunte nella finestra di sinistra.
    Avvia la scansione.
    Ripara , per il momento , tutte le voci verdi.
    Riavvia.
    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 10 luglio 2010 11:42
    Moderatore
  • Repost...

    -----
    "Verosimilmente un servizio o programma di terze parti che impedisce il corretto funzionamento di Internet Explorer.

    E' necessario procedere con un'investigazione partendo dall'avvio di Windows in "Modalità provvisoria con rete".

    Quindi con l'Avvio selettivo:
    http://windows.microsoft.com/it-IT/windows7/Run-Selective-Startup-using-System-Configuration
    "Eseguire l'avvio selettivo utilizzando Configurazione di sistema"."
    -----

    Se non risolvi è necessario reinstallare Windows "In place", su se stesso.

    Se il problema persiste nonostante una reinstallazione "In place" di Windows, devi procedere ad una formattazione del disco rigido ed alla reinstallazione "In pulito" di Windows e dei programmi, avendo cura di scegliere applicazioni che siano perfettamente compatibili e certificate per Windows 7.

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    mercoledì 21 luglio 2010 05:12
    Moderatore

Tutte le risposte

  • Segui attentamente tutti i passaggi indicati in questo articolo:
    http://windows.microsoft.com/it-IT/windows7/Tips-for-solving-problems-with-Internet-Explorer

    "Suggerimenti per risolvere i problemi con Internet Explorer".
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    mercoledì 7 luglio 2010 07:22
    Moderatore
  • fatto tutto ma il problema persiste...

     

    help me!

     

    mercoledì 7 luglio 2010 09:19
  • Verosimilmente un servizio o programma di terze parti che impedisce il corretto funzionamento di Internet Explorer.

    E' necessario procedere con un'investigazione partendo dall'avvio di Windows in "Modalità provvisoria con rete".

    Quindi con l'Avvio selettivo:
    http://windows.microsoft.com/it-IT/windows7/Run-Selective-Startup-using-System-Configuration
    "Eseguire l'avvio selettivo utilizzando Configurazione di sistema".

    Esegui inoltre un'accurata verifica antimalware.
    Software da scaricare ed eseguire, in successione, riavviando ogni volta in computer...
         1a - Scarica ed esegui lo Strumento di rimozione malware Microsoft
         
    2a - Scarica, aggiorna ed esegui Malwarebytes' Anti-Malware   
         3a - Scarica, aggiorna ed esegui anche SUPERAntiSpyware.
    2 - Fai una scansione on-line (in "Modalità provvisoria con rete", se possibile):
    http://onecare.live.com/site/it-it/center/howsafe.htm
    Solo per Windows Vista e Windows 7:
    http://onecare.live.com/site/it-it/center/whatsnew.htm 
    "Analisi di protezione per Windows Vista e Windows 7"
    Alert: la scansione può durare ore, attendi pazientemente che lo scanner termini il proprio lavoro.
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    mercoledì 7 luglio 2010 09:25
    Moderatore
  • ciao, ho risolto la mia urgenza appoggiandomi a un altro browser ma il problema persiste e sono intenzionato a risolverlo.
    alora : i punti 1 lo ho seguito tutti aggiungendo anche un controllo con Spyboot e 1 con Nav 2010 ma di virus/spyware nemmeno l'ombra (e per fortuna: la macchina ha 2 settimane di vita e non ha praticamente mai avuto contatto con il mondo internet)

     

    la seconda parte non sono riuscito perche non riesco in nessun modo ad installare gli activex.

    sto pensando di reinstallare explorer 8... dite che puo essere di aiuto??

    sabato 10 luglio 2010 08:47
  • Non è possibile reinstallare Internet Explorer in Windows 7.

    http://windows.microsoft.com/it-IT/windows7/Reset-Internet-Explorer-settings
    Reimposta IE.

    Rimuovi SpyBot S&D, inutile con IE8.
    Rimuovi anche Norton Antivirus, per test.
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    sabato 10 luglio 2010 09:22
    Moderatore
  • gia rimossi...
    sabato 10 luglio 2010 09:27
  • gia rimossi...
    Beh, che aggiungere. Internet Explorer 8 funziona perfettamente in Windows 7, quindi, come ho già affermato nella mia precedente risposta, la causa del malfunzionamento nella tua macchina va ricercata in qualche software/servizio di terze parti. E' necessario indagare escludendo dall'avvio tutti i programmi/servizi "Non Microsoft" e verificare attentamente, puntigliosamente, quale o quali di essi impedisce il corretto funzionamento di Internet Explorer.

    Ciao,
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    sabato 10 luglio 2010 11:21
    Moderatore
  • Come accennato da Vincenzo fai un avvio pulito:

    Digita :
    msconfig
    e dai invio nel box di ricerca del menù start.
    Vai alla sezione Avvio.
    Togli tutte le spunte meno quelle relative all'antivirus.
    Dai ok.
    Non riavviare.
    Vai alla sezione Servizi.
    Metti la spunta per nascondere tutti i servizi Microsoft.
    Disabilita tutti gli altri.
    Dai ok.
    Non riavviare.
    Vai in C:\windows\prefetch
    Cancella tutti i file (compresa la cartella ReadyBoot che verrà ricreata)
    meno il file layout.ini.
    Vai in C:\windows\temp
    Cancella tutti i file cancellabili.
    Pannello di controllo > opzioni internet , clicca su Elimina per ripulire i
    temporanei e la cronologia.
    Dai ok.
    Vuota il cestino.
    Riavvia.
    Al riavvio scarica Wise Registry Cleaner Free Portable:
    http://www.wisecleaner.com/soft/WRCFree.zip
    Estrai il file e lo lanci (oppure lo installi se hai scelto di scaricare la versione con l'installer).
    Metti tutte le spunte nella finestra di sinistra.
    Avvia la scansione.
    Ripara , per il momento , tutte le voci verdi.
    Riavvia.
    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 10 luglio 2010 11:42
    Moderatore
  • grazie mille per la guida molto dettagliata.

    lunedi provo e vi faccio sapere.

    sabato 10 luglio 2010 12:34
  • Bene.

    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 10 luglio 2010 12:45
    Moderatore

  • Rimuovi SpyBot S&D, inutile con IE8.
    [ot]
    davvero?? non lo sapevo ...
    L'ho sempre considerato un programma valido...
    bhe che dire: si impara sempre qualcosa :)
    mi dareste altre info al riguardo?? grazie!!
    [/ot]
    • Modificato Dario Bonini giovedì 15 luglio 2010 07:57 formattazione testo
    giovedì 15 luglio 2010 07:57
  • Si.

    L'immunizzazione che applica rallenta enormemente IE8 e i controlli Tea Timer e IE Helper confliggono con l'antivirus/suite di protezione installati.

    Inoltre , da tempo , l'individuazione e rimozione delle infezioni è carente.

    Ciao

     


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    giovedì 15 luglio 2010 08:12
    Moderatore
  • Capisco che sei sempre nella fase di testare i suggerimenti di Vincenzo e di Franco?


    Anca Popa
    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft.
    giovedì 15 luglio 2010 08:13
  • Capisco che sei sempre nella fase di testare i suggerimenti di Vincenzo e di Franco?


    Anca Popa
    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft.


    si ci sto mettendo un po perche non ho molto tempo e voglio essere sicuro di non tracurar i dettagli... ad ogni modo per ora posso dire che la macchina è esnte da spiware/ virus (suggerimento di vincenzo)

    per quanto riguarda le prove suggerite da franco devo fare altri controlli.
    cmq appena riesco posto i risultati.

    grazie dell'aiuto.

    domenica 18 luglio 2010 01:13
  • Si.

    L'immunizzazione che applica rallenta enormemente IE8 e i controlli Tea Timer e IE Helper confliggono con l'antivirus/suite di protezione installati.

    Inoltre , da tempo , l'individuazione e rimozione delle infezioni è carente.

    bhe buono a sapersi.
    qualche consiglio spassionato su una suite alternativa di buon livello????  ovviamente free :)

    domenica 18 luglio 2010 01:15
  • qualche consiglio spassionato su una suite alternativa di buon livello????  ovviamente free :)


    Non esistono suite di sicurezza gratuite. Puoi provare Microsoft Security Essentials, freeware per uso personale, leggero, efficace, perfettamente compatibile con Windows 7. MSE dispone di un proprio modulo antispyware, quindi Windows Defender viene disattivato durante l'installazione di Microsoft Security Essentials, ad evitare conflitti.
    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    domenica 18 luglio 2010 04:40
    Moderatore
  • Come accennato da Vincenzo fai un avvio pulito:

    Digita :
    msconfig
    e dai invio nel box di ricerca del menù start.
    Vai alla sezione Avvio.
    Togli tutte le spunte meno quelle relative all'antivirus.
    Dai ok.
    Non riavviare.
    Vai alla sezione Servizi.
    Metti la spunta per nascondere tutti i servizi Microsoft.
    Disabilita tutti gli altri.
    Dai ok.
    Non riavviare.
    Vai in C:\windows\prefetch
    Cancella tutti i file (compresa la cartella ReadyBoot che verrà ricreata)
    meno il file layout.ini.
    Vai in C:\windows\temp
    Cancella tutti i file cancellabili.
    Pannello di controllo > opzioni internet , clicca su Elimina per ripulire i
    temporanei e la cronologia.
    Dai ok.
    Vuota il cestino.
    Riavvia.
    Al riavvio scarica Wise Registry Cleaner Free Portable:
    http://www.wisecleaner.com/soft/WRCFree.zip
    Estrai il file e lo lanci (oppure lo installi se hai scelto di scaricare la versione con l'installer).
    Metti tutte le spunte nella finestra di sinistra.
    Avvia la scansione.
    Ripara , per il momento , tutte le voci verdi.
    Riavvia.
    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience


    ciao,

    do seguito alla lettera le tue indicazioni ma il problema non è risolto.

    l'unica "anomalia" nel procedimanto è in fase di pulizia del registro: 3 voci non vengono elimiate: riporto sotto i log.

    avete altri consigli da darmi??

    Time: 5:22:25 PM Problems:
    =======================================================================
    Key: HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-ms-license
    Reason: Remove Key failed.
    ErrorCode:0
    -----------------------------------------------------------------------
    Time: 5:22:25 PM Problems:
    =======================================================================
    Key: HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-informationCard
    Reason: Remove Key failed.
    ErrorCode:1008
    -----------------------------------------------------------------------
    Time: 5:22:25 PM Problems:
    =======================================================================
    Key: HKEY_CLASSES_ROOT\AcroExch.Document.7\protocol\StdFileEditing\server\Default
    Reason: Remove value failed.
    ErrorCode:1008
    -----------------------------------------------------------------------

    martedì 20 luglio 2010 15:25
  • Repost...

    -----
    "Verosimilmente un servizio o programma di terze parti che impedisce il corretto funzionamento di Internet Explorer.

    E' necessario procedere con un'investigazione partendo dall'avvio di Windows in "Modalità provvisoria con rete".

    Quindi con l'Avvio selettivo:
    http://windows.microsoft.com/it-IT/windows7/Run-Selective-Startup-using-System-Configuration
    "Eseguire l'avvio selettivo utilizzando Configurazione di sistema"."
    -----

    Se non risolvi è necessario reinstallare Windows "In place", su se stesso.

    Se il problema persiste nonostante una reinstallazione "In place" di Windows, devi procedere ad una formattazione del disco rigido ed alla reinstallazione "In pulito" di Windows e dei programmi, avendo cura di scegliere applicazioni che siano perfettamente compatibili e certificate per Windows 7.

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    mercoledì 21 luglio 2010 05:12
    Moderatore
  • ok... purtroppo non ce l'ho fatta...

    prima o poi formatto..... :(

    sabato 24 luglio 2010 08:11
  • ok... purtroppo non ce l'ho fatta...

    prima o poi formatto..... :(
    Come affermavo nella mia precedente risposta, purtroppo in alcuni (rari) casi è necessario un Format & Reinstall. Sii prudente nell'installazione dei programmi, verifica che siano certificati e perfettamente compatibili con Windows 7.

    Best of Luck,

    Vincenzo Di Russo
    Microsoft® MVP Windows Internet Explorer, Windows Desktop Experience & Security since 2003.
    Moderator in the Microsoft Answers and TechNet Forums Italy
    My MVP Profile: https://mvp.support.microsoft.com/profile/Vincenzo
    sabato 24 luglio 2010 09:02
    Moderatore