none
RDS: Server licenze non disponibile RRS feed

  • Domanda

  • Buon giorno a tutti,

    ho installato, presso un cliente, una Windows Server 2008R2 Standard su cui ho attivato il ruolo Remote Desktop con i servizi RD Session Host e RD Licensing. Ho registrato ed attivato sia i servizi sia le CAL's di accesso, nel registro eventi non ho rilevato messaggi d'errore od allerta e tutte le console di gestione davano (e danno) tutto funzionante ed in ordine.

    Al termine del "periodo di prova" nella traybar, all'accesso di una sessione (ed anche dalla console del server), compare questo baloon d'allerta

    Ho verificato lo stato del servizio licenze ed era (è) funzionante, le CAL's sono regolarmente registrate ed indicate, non sono presenti messaggi negli eventi eppure questo alert mi perseguita. Ho anche provato a reinstallare il servizio licenze e ri-registrare le CAL's ma non ho ottenuto soluzione al problema.

    Qualcuno di voi ha delle indicazioni da fornirmi e/o indirizzarmi sulla strada della soluzione?

    Grazie,

    Riccardo


    ®i©ky

    • Tipo modificato Anca Popa lunedì 12 novembre 2012 10:36 attesa di feedback
    • Tipo modificato Anca Popa giovedì 22 novembre 2012 11:40 domanda con risposta
    lunedì 5 novembre 2012 10:03

Risposte

Tutte le risposte

  • quando parli di CAL ti riferisci alle RDS CAL ?

    ci sono errori nel registro eventi in particolare nelle sezioni system, application ?


    Edoardo Benussi
    Microsoft MVP
    edo[at]mvps[dot]org

    lunedì 5 novembre 2012 10:47
    Moderatore
  • Si, faccio riferimento alle RDS CAL's.

    Non riscontro messaggi di errore o di allerta in nessun registro eventi (sia application sia system) e questo mi ha messo in forte difficoltà poiché non ho un'evidenza oggettiva su cui lavorare, il messaggio allegato non mi ha portato a nessuna "causa" od anomalia o mancanza di configurazioni (ed affini).


    ®i©ky

    lunedì 5 novembre 2012 11:04
  • Ciao, secondo me hai attivato in fase di installazione la versione di prova da 90gg e poi hai messo su le cal ancora con la versione di prova di TS attiva. Disinstallando il ruolo e reinstallandolo di sana pianta con annessa registrazione delle licenze dovresti ripartire. Almeno a me era successo questo su un cliente.

    A.

    lunedì 5 novembre 2012 12:24
    Moderatore
  • Come descritto nel messaggio iniziale ho reinstallato ambedue i service roles.

    Considerando che non sono presenti segnalazioni d'errore ho il sospetto che si tratti di uno o più valori di registry "disallineati" rispetto al settaggio del role. Ma questa è solo una mia ipotesi.


    ®i©ky

    lunedì 5 novembre 2012 19:43
  • Dubbio...

    RD LS ammette come discovery scope workgroup, domain o forest. Il mio è impostato su Workgroup. Non è che per qualche motivo il server abbia provato a registrare il SCP in AD DS (che non c'è perché è questo è l'unico server presente in rete ed è un server stand-alone) senza riuscirci ed abbia scritto comunque la configurazione in locale?


    ®i©ky

    giovedì 8 novembre 2012 14:38
  • scusa ma se fai proprio quello che c'è scritto nell'avviso:

    "Fare clic sul messaggio per avviare Configurazione server host sessione Desktop remoto e utilizzare diagnosi gestione"

    cosa succede ?


    Edoardo Benussi
    Microsoft MVP
    edo[at]mvps[dot]org

    giovedì 8 novembre 2012 15:02
    Moderatore
  • Stando alle console di gestione ed al registro eventi è tutto in ordine. Ho approfondito la ricerca nel registro eventi ed in  "Registri applicazioni e servizi\Microsoft\Windows\TerminalServices-Licensing\Admin" ho visto alcuni errori (in date diverse e senza una ricorrenza specifica o ad orari simili, ed il più recente è dello scorso mese) con ID=85 ed il testo è il seguente:

    Impossibile registrare il server licenze Desktop remoto come punto di connessione del servizio in Servizi di dominio Active Directory. Verificare che sia disponibile la connessione di rete tra il server licenze e Servizi di dominio Active Directory. Per registrare il server licenze come punto di connessione del servizio in Servizi di dominio Active Directory, utilizzare Verifica configurazione nello strumento Gestione licenze Desktop remoto.

    Motivo per cui ho esposto il mio dubbio. Non saprei cos'altro controllare e credo di aver fornito tutti gli elementi a mia disposizione.


    ®i©ky

    giovedì 8 novembre 2012 16:35
  • vedi la possibile soluzione qui

    http://technet.microsoft.com/en-us/library/ee891215(v=ws.10).aspx


    Edoardo Benussi
    Microsoft MVP
    edo[at]mvps[dot]org

    lunedì 12 novembre 2012 09:14
    Moderatore
  • Ciao,

    Ho evidenziato la risposta di Edoardo che ti offre qualche spunto valido per molti scenari simili.

    Se vuoi condividere la tua esperienza con gli altri utenti del forum e darci anche il tuo feedback, il tuo contributo sarà sicuramente utile per gli altri utenti del forum che magari riscontrano problematiche simili.

    Grazie,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda. 

    giovedì 22 novembre 2012 11:42
  • Scusatemi per la lunga assenza. Sono tornato recentemente sul tema e dopo aver rivisto la configurazione e preso in considerazione le opinioni espresse ho ritenuto opportuno attivare ADDS.

    Evidentemente aver specificato lo scope o dichiarato espressamente il server licenze ha, in qualche modo, innescato dei problemi con la gestione delle notifiche di sistema (essendo un server di produzione non ho avuto molte possibilità di approfondire e soprattutto non ho potuto rifare la macchina :-( ) che probabilmente erano solo dei falsi positivi. Dopo l'attivazione di ADDS il baloon di notifica non è più comparso e, come prima, nulla compare nel registro eventi.

    Forse un mio click "maldestro" ha generato questa condizione operativa (che potrebbe anche rientrare in quelle che sono definite "condizioni non verificate"), certo è che non mi pare ragionevole attivare ADDS, ove non necessario, per porre rimedio ad una configurazione. Sicuramente questo problema non è ascrivibile al sistema operativo, ma un controllino in più avrebbe fatto comodo :-P

    ringrazio tutti per la disponibilità prestata e la pazienza per il mio feedback!

    BUON ANNO A TUTTI!


    ®i©ky

    venerdì 4 gennaio 2013 15:50
  • grazie del feedback, ciao.

    Edoardo Benussi
    Microsoft MVP
    edo[at]mvps[dot]org

    venerdì 4 gennaio 2013 15:59
    Moderatore
  • Stando alle console di gestione ed al registro eventi è tutto in ordine. Ho approfondito la ricerca nel registro eventi ed in  "Registri applicazioni e servizi\Microsoft\Windows\TerminalServices-Licensing\Admin" ho visto alcuni errori (in date diverse e senza una ricorrenza specifica o ad orari simili, ed il più recente è dello scorso mese) con ID=85 ed il testo è il seguente:

    Impossibile registrare il server licenze Desktop remoto come punto di connessione del servizio in Servizi di dominio Active Directory. Verificare che sia disponibile la connessione di rete tra il server licenze e Servizi di dominio Active Directory. Per registrare il server licenze come punto di connessione del servizio in Servizi di dominio Active Directory, utilizzare Verifica configurazione nello strumento Gestione licenze Desktop remoto.

    Motivo per cui ho esposto il mio dubbio. Non saprei cos'altro controllare e credo di aver fornito tutti gli elementi a mia disposizione.


    ®i©ky

    Navigando in tutti i thread sono finito anche qui.

    Anche io, ora ho la stessa situazione sul un Server 2019 che ha solo i ruoli rds installati mentre il ruolo di DC è in mano ad un server 2008. Anche io ho l'evento 85 e mi sono letto il bellissimo link proposto da Edoardo: https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/ee891215(v=ws.10)?redirectedfrom=MSDN

    Anche seguendo alla lettera tutta la sequenza di verifiche, è tutto ok. Compresa la verifica in ADSI e il controllo di TS-Enterprise-License-Server. Il server 2019 risulta essere in elenco ma non viene visto come server licenze nonostante non ci sia nessun errore. 

    Come successo a te, anche io sono in difficoltà in quanto tutto pare funzioni ma in realtà gli accessi non vanno. Sapete se ci sono altri punti di verifica da poter analizzare ?

    Grazie


    martedì 11 febbraio 2020 19:23