none
iSCSI target, riconnessione in corso dopo riavvio server RRS feed

Tutte le risposte

  • Ciao, fermiamoci.

    Tu hai un nas collegato in iscsi da 900 TB?? Ok partiamo di li. per una cosa del genere devi avere un supporto cubico sempre attivo. (PS..ma quanti dischi ha???)

    Il nas ha 2 schede di rete in F.O..che sta per? Failover? quindi ne usa 1. Quindi hai 1 scheda di rete 10Gb.

    Poi hai un server come? fisico, virtuale, con che sistema operativo, con quante schede di rete 10Gb (perchè avrai almeno un canale simile sullo stesso switch per il server...).

    ci manca poi sapere il problema da quanto te lo fa. dubito che una macchina del genere lo faccia da sempre, l'averesti sollevato al fornitore immediatamente.

    Senza queste informazioni non andiamo da nessuna parte. Ma oltre le info, hai sollevato la questione al supporto del NAS? perchè potrebbe essere banalmente un problema di firmware, di networking, ecc. 

    aggiornaci.

    A.

    lunedì 24 giugno 2019 16:08
    Moderatore
  • Tu hai un nas collegato in iscsi da 900 TB?? Ok partiamo di li. per una cosa del genere devi avere un supporto cubico sempre attivo. (PS..ma quanti dischi ha???)

    In effetti 900 TB sono veramente tanti...
    Comunque, oltre alla descrizione dell'infrastruttura, può essere utile anche sapere se ci sono eventi di errore in Windows in concomitanza con la mancata connessione.
    lunedì 24 giugno 2019 20:20
    Moderatore
  • Alessandro buongiorno

     il nas in oggetto ha 10 dischi da 10 tb (raid--5) più 2 dischi ssd per gestione cache, + 1 hd hotspare

    lo stesso ha 2 sk in fibra ottica (f.o.) da 10 gb in broadcasting che si attestano su uno switch al quale sono collegate 2 sk rame dal server (fisico) in teaming.

    Il server fisico ha Windows server2016.

    il problema si verifica solo alla riaccensione del server, una volta scollegato e ricollegato il disco in iscsi tutto funziona correttamente.

    Il mio dubbio, visto che iscsi lo uso abbastanza frequentemente, non sia legato alla dimensione del filesystem troppo grande.

    Grazie

    martedì 25 giugno 2019 08:19
  • Beh' intanto siamo passati da 900 TB a 90...che non sono pochi...ma 900TB di storage penso non esistano nemmeno...

    Detto questo secondo me una roba del genere doveva almeno avere 2 dischi di spare, quindi raid 6 e non 5...anche se lo spare è presente. Comunque...

    il problema secondo me non è la dimensione del volume. il problema secondo me è il tipo di connessione. Non capisco la scelta di passare da fibra a rame quando bastava mettere tutto in fibra. Per me questa ibridizzazione crea il problema. Qui però mi fermo. Io non avrei fatto Iscsi per una dimensione del genere e sicuramente non avrei usato l'initiator di windows server. Avrei usato una struttura virtuale ed agganciato lo storage sull'hypervisor base.

    Ma al di la delle opinioni tecniche per me devi appoggiarti al fornitore del NAS per capire se hai configurato correttamente il tutto e se è supportata come configurazione. Se te la danno per buona devono darti la soluzione al problema...in caso contrario...devi farla supportata come consigliano loro. Ci è impossibile diagnosticarti un problema con una macchina che hai solo tu, quel che posso dirti è che il comportamento è anomalo, quindi c'è qualcosa che fa ricollegare automaticamente l'initiator ma come ti dicevo saranno 10 anni anni almeno che non si vedono server fisici con iscsi agganciati..oggi è tutto virtuale...

    Non mi hai risposto però ad una domanda: da quanto è in piedi questa struttura? Non è che avevi già il 2016 e hai attaccato il NAS? chiedo..perchè un 2016 fisico...boh...

    A.

    martedì 25 giugno 2019 12:38
    Moderatore
  • Alessandro ciao, mi scuso per i 900 tb.. la soluzione (nuova) è legata ad un sistema di videosorveglianza e il produttore del software preferiva una macchina fisica. Normalmente io virtualizzo..

    La scelta del raid è ininfluente sul comportamento del iscsi initiator…

    Sicuramente contatterò qnap per vedere se esiste uno loro software per la gestione iscsi.

    Grazie per il supporto.

    mercoledì 26 giugno 2019 07:08

  • La scelta del raid è ininfluente sul comportamento del iscsi initiator…


    certo. Mai detto il contrario. Ma se fossero 90TB di dati sensibili un raid 5 non è proprio la scelta corretta. Sulla sorveglianza..ci può stare. e' che se facevi un raid 6 evitavi di avere un disco di spare fermo li a fare niente per tutta le vita nas visto il costo di un 10TB. Sono sicuro che se facevi tutto fiber il problema non esisteva, chiaramente lo vedeva come storage locale.

    Comunque essendo Qnap secondo me ti rispondono picche. Il supporto di Qnap e Synology è ad essere gentili inutile. Prova, poi magari ci aggiorni.

    ciao.

    A.

    mercoledì 26 giugno 2019 08:26
    Moderatore