none
Parentesi quadra non digitabile in modulo vba editor RRS feed

  • Domanda

  • Buongiorno, 

    non riesco a digitare la parentesi quadra nel modulo in vba editor, con relativa difficoltà a modificare macro. La combinazione "Opzione(⌥) + è" oppure "Opzione(⌥) + +) non funziona. Utilizzo tastiera italiana. Sul foglio di lavoro Excel contestuale viene invece inserita correttamente. Sto attualmente bypassando il problema con copia e incolla, ma è frustrante e con grande perdita di tempo. Con Microsoft Excel 2011 per Mac il problema non si presentava.

    Grazie per qualsiasi suggerimento.

    (Excel 2016 per Mac versione 16.11.1 - Macbook Pro, macOS High Sierra 10.13.4)

    venerdì 6 aprile 2018 09:02

Tutte le risposte

  • Curiosità,

    @ e # funzionano?

    Ciao

    Marco

    venerdì 6 aprile 2018 10:13
  • No, esatto, non funzionano. Sembra che il tasto Opzione in editor smetta di funzionare (sul foglio excel e su qualsiasi altro programma funziona).

    L'altra alternativa al copia e incolla è, mentre si compila sul modulo, aprire la piccola finestra per l'inserimento degli accenti diacritici (con Opzione + 8 o 9 o ì o U o N), qui il tasto Opzione funziona, ma prima bisogna cancellare l'accento inserito, immettere la [ o ]@# e poi digitare Invio. Per carità, funziona, ma non è così immediato.

    Sto cercando di capire in primis se è un problema del mio computer, se devo attivare/disatt. qualcosa (ad una ricerca veloce sul web in ita e eng non son riuscito a trovare granchè) o se è normale che sia così.

    Federico


    • Modificato FedeSerjio venerdì 6 aprile 2018 12:46
    venerdì 6 aprile 2018 12:08
  • Bah,

    si comporta come se prendesse il layout US.

    Fai così ,

    in pannello di controllo elimina del tutto la tastiera inglese,

    riavvia e riprova

    Marco

    venerdì 6 aprile 2018 14:10
  • Il problema è che non è installata nessuna tastiera inglese; tra le sorgenti di input nelle Preferenze di Sistema Tastiera è solo presente quella italiana. Ho provato ad installare quella USA, attivarla e disattivarla (con i vari riavvii in mezzo) ma nulla da fare. Stesso lavoro ho fatto con le preferenze di Lingua e Zona, ma niente. Il visore tastiera mi conferma il layout italiano e il funzionamento del tasto opzione... ma non in editor... sigh...

    domenica 8 aprile 2018 23:09
  • N.B.

    a parte consigliarti una nuova reinstallazione del pacchetto Office,per semplificarti la vita dai vari taglia ed incolla leggi sotto.

    Ho fatto una piccola simulazione,

    Ho creato una tastiera castomizzata , è una tastiera italiana standard con in più questa combinazione di tasti

    ctrl + "," = [

    ctrl + "." = ]

    Questo è il link

    http://www.mb0339.online/file/Utility/technet1_custom_kb.rar

    che scompattato contiene questo:

    Nel mio caso ho installato direttamente Technet1_amd64 ed una volta lanciato ottieni:

    Automaticamente:

    una volta installata, partendo da una keyboard italiana te la trovi già inclusa nell' elenco attivo delle keyboard

    Testata in vb di excel e word funziona,

    direttamente nel foglio di lavoro no poichè parte dalla combinazione CTRL, ma visto che l' errore ti si presenta solo nell' imput dei moduli.....

    !!!Naturalmente il driver del link è li per mie simulazioni quindi non mi ritengo responsabile di nulla!!!

    Lo puoi creare anche tu con un qualsiasi tool che trovi online :-)

    Non è una soluzione al problema ma se può esserti utile ben venga.

    Marco

    lunedì 9 aprile 2018 07:54
  • Grazie! Ottimi suggerimenti!

    Provo a reinstallare il tutto, poi provo a customizzare la tastiera sul Mac e vedo che succede.

    Federico

    martedì 10 aprile 2018 08:16