none
Non riesco a connettermi a un hyper-v server "bare-metal" 2019 fuori da un dominio RRS feed

  • Domanda

  • Ho installato hyper-v 2019 su "bare-metal", ho installato su un diverso server windows la gestione di hyper-v

    Se provo a connettermi al server hyper-v 2019 "bare-metal" indicando i corretti parametri per nome ID e password ho il messaggio

    "Errore    Hyper-V-2019: aggiornamento della configurazione non riuscito con l'errore seguente:
    Impossibile recuperare i metadati dal server a causa dell'errore seguente: Client Gestione remota Windows:
    impossibile elaborare la richiesta. Se lo schema di autenticazione è diverso da Kerberos o il computer client non fa parte di un dominio, è necessario utilizzare il trasporto HTTPS oppure aggiungere il computer di destinazione all'impostazione di configurazione TrustedHosts. Per configurare TrustedHosts, utilizzare winrm.cmd.
    Si noti che i computer inclusi nell'elenco TrustedHosts potrebbero non essere autenticati. Per ulteriori informazioni, eseguire il comando seguente: winrm help config. "

    Ho inserito il server "bare-metal" nell'elenco dei trusted host con il comando:

    winrm set winrm/config/client ‘@{TrustedHosts="machineA"}’

    ma ancora non funziona, ho sempre errore di accesso.

    Qualche suggerimento ?

    Grazie

    giovedì 12 settembre 2019 13:02

Risposte

  • La procedura cambia notevolmente a seconda se server e client si trovano nello stesso dominio o meno.
    Immagino che nel tuo caso entrambi siano in workgroup, quindi ti consiglio la lettura di questa pagina:
    https://itlabz10.tk/archives/1025

    Ti consiglio di non utilizzare configurazioni "miste", ad esempio dominio-fuori dominio, due differenti domini, ecc.. in quanto il funzionamento potrebbe essere ancora più difficoltoso.

    PS: Non capisco perché hai specificato sempre il termine bare-metal...se si tratta di un hypervisor installato da te non può essere sicuramente un server fisico condiviso….


    giovedì 12 settembre 2019 20:07
    Moderatore

Tutte le risposte

  • La procedura cambia notevolmente a seconda se server e client si trovano nello stesso dominio o meno.
    Immagino che nel tuo caso entrambi siano in workgroup, quindi ti consiglio la lettura di questa pagina:
    https://itlabz10.tk/archives/1025

    Ti consiglio di non utilizzare configurazioni "miste", ad esempio dominio-fuori dominio, due differenti domini, ecc.. in quanto il funzionamento potrebbe essere ancora più difficoltoso.

    PS: Non capisco perché hai specificato sempre il termine bare-metal...se si tratta di un hypervisor installato da te non può essere sicuramente un server fisico condiviso….


    giovedì 12 settembre 2019 20:07
    Moderatore
  • Grazie,

    ho seguito tutta la procedura descritta nell'articolo ma la stessa funziona solo "a metà"..

    Ovvero dalla consolle di gestione ora vedo il servere hyper-v con indirizzo IP, nome etc. ma quando tento di collegarmi con "Gestione computer"  ho il messaggio di seguito :

    e non riesco ancora a gestire il server hyper-v dalla console "remota"

    Preciso che i due PC sono sulla stessa rete uno di fianco all'altro connessi sullo stesso switch e entrambi non sono dentro un dominio.

    P.S. ho sempre scritto bare-metal perchè l'hyper-v è su un hardware dedicato specifico e non si appoggia su un SO già installato

    Grazie, saluti


    • Modificato plhmk giovedì 19 settembre 2019 15:28
    giovedì 19 settembre 2019 15:26
  • Dentro "un dominio" o nello stesso dominio? Perché sono cose diverse.
    La guida si riferisce a configurazioni in workgroup (client e server), se si tratta di una configurazione "mista" le cose cambiano.
    In ogni caso, come si evince dal messaggio di errore, il problema sta nelle regole firewall. Assicurati che siano abilitate per tutti i profili di rete e che la rete stessa non venga rilevata da Windows come "Non identificata".

    giovedì 19 settembre 2019 19:52
    Moderatore
  • Grazie, ma ancora non mi funziona...

    i miei 2 PC (server hyper-v e PC server con la console di gestione hyper-v) sono nello stesso workgroup ma non hanno specificato nessun dominio

    Inoltre i comandi da dare (secondo la procedura indicata) sul server hyper-v nella schermata del prompt dei comandi che dovrebbero predisporre il firewall  :

    netsh advfirewall firewall set rule group="Windows Management Instrumentation (WMI)" new enable=Yes
    netsh advfirewall firewall set rule group="Remote Event Log Management" new enable=Yes

    Danno entrambi come risultato

    "Nessuna regola corrispondente al criterio specificato."

    Così come tutti gli altri comandi che iniziano con netsh

    Quindi sul server hyper-v non posso fare altro, sul PC con la consolle di gestione la rete è invece identificata senza problemi

    Ho provato a fare il ping dal PC con la consolle di gestione al server hyper-v e questo non viene trovato neanche se inserisco l'indirizzo IP

    Il contrario invece (dal prompt di comandi del server hyper-v verso il pc con la console)  funziona.

    Immagino che il problema sul firewall sia sul server hyper-v e non sull'altro, giusto ?

    Ma non so come cambiarne le regole, i comandi indicati non funzionano.

    Ancora non riesco a connettermi per gestire la macchina hyper-v...

    Grazie, saluti

    domenica 22 settembre 2019 15:20
  • Per i sistemi operativi in lingua italiana le regole hanno un nome differente.
    Leggi i commenti presenti in fondo alla pagina della guida per vedere i comandi validi per i sistemi operativi in lingua italiana.
    PS: Solitamente è preferibile installare i server sempre in lingua inglese
    domenica 22 settembre 2019 17:40
    Moderatore
  • Salve,

    le ho provate tutte ma proprio i comandi in italiano non li trovo.

    sull'help del server in italiano i comandi sono in inglese, quindi dovrebbe prenderli ma la traduzione di

    Windows Management Instrumentation (WMI)

    e di

    Remote Event Log Management

    proprio non la trovo...

    In alternativa come si disattiva il FW da comandi, a me non serve, il sistema è su una rete interna.

    Grazie ancora

    venerdì 27 settembre 2019 16:55
  • Il firewall va sempre sbloccato altrimenti non funzionerà mai, non importa se ti trovi già sotto firewall hardware. Anche se disabiliti completamente Windows Firewall non funzionerà ugualmente.
    Comunque forse non mi ero spiegato bene, i comandi erano presenti tra i commenti dell'articolo che ti avevo consigliato precedentemente, non nella guida di Windows.
    In ogni caso te li riporto qui:
    netsh advfirewall firewall set rule group="Strumentazione gestione Windows (WMI)" new enable=Yes
    netsh advfirewall firewall set rule group="Gestione remota registro eventi" new enable=Yes
    netsh advfirewall firewall set rule group="Condivisione file e stampanti" new enable=Yes
    netsh advfirewall firewall set rule group="Gestione volumi remota" new enable=Yes

    PS: I sistemi operativi in lingua italiana non accettano i comandi in inglese, questo è uno dei motivi per cui di solito si consiglia di installare i server in lingua inglese (c'è molta più documentazione).



    venerdì 27 settembre 2019 19:14
    Moderatore
  • Grazie dell'aiuto, ora funziona tutto (da Server Manager)!

    Comunque sto proseguendo ed ho visto che viene consigliato di usare Windows Admin Center per la gestione.

    l'ho installato su PC Windows 10 e questo ancora non mi permette la connessione al server Hyper-V

    Da Mozilla proprio non funziona, da Edge il WAC parte ma non si connette al server, l'errore è simile a prima:

    Da notare che il collegamento allo stesso server da Server Manager ora funziona come pure da Desktop Remoto.

    Grazie, saluti...

    mercoledì 2 ottobre 2019 16:07
  • Dallo snap-in di Hyper-V puoi già gestire tutte le funzioni, non è indispensabile utilizzare Windows Admin Center.
    Comunque se lo vuoi proprio utilizzare devi ovviamente seguire la sua guida per la configurazione:
    https://docs.microsoft.com/it-it/windows-server/manage/windows-admin-center/deploy/prepare-environment
    mercoledì 2 ottobre 2019 21:37
    Moderatore