none
Server su VmWare Workstation che non riesce ad andare su internet. RRS feed

  • Domanda

  • Ciao a tutti,

    domanda forse stupida, ma da cui non riesco a venirne a capo.

    Ho un dominio con W2K12 dentro VmWare Workstation, la rete di VmWare è configurata così:

    VmNet0->bridged, no

    VmNet1->host-only, con DHCP, 192.168.159/24

    VmNet2->host-only, no DHCP, 169.154.0.0/24

    VmNet8->Nat, con DHCP, 192.168.166.0/24

    Su una VM c'è il Domain Controller (W2K12), che per comodità chiamerò DC, che è collegato a VmNet2 (con Ip statico 192.168.1.1, no gateway e dns 192.168.1.1 e 8.8.8.8) e VmNet0 (senza l'opzione di replicare l'indirizzo della scheda fisica). Il DC fa da DHCP su 192.168.1.0/24 con impostato lo scope per Router 192.168.1.1, DNS server 192.68.1.1, 8.8.8.8, e opzione 0015 con il nome del mio dominio e fa anche da DNS server. Questa VM va correttamente su internet, poiché essendo collegata a VmNet0 riesce a uscire. Lanciando il tracert vedo che i pacchetti passano per questa scheda di rete.

    Su un'altra VM c'è un server con W2K12, che per comodità chiamerò VM1, collegato a VmNet2 con ip fornito dal DHCP e ha come gateway DC (192.168.1.1), ma quando provo a fare un ping a qualsiasi indirizzo mi da richiesta scaduta, e facendo un tracert mi da sempre richiesta scaduta.

    La mia domanda è: come posso fare per far andare su internet VM1 tramite DC?

    Prima di scrivere ho provato a googlare, ma non ho trovato niente. Non posso utilizzare Hyper-V poiché durante l'installazione, non dentro VmWare, si blocca.


    mercoledì 1 aprile 2015 15:11

Risposte

  • se il server 2 non ha una classe di indirizzo "navigabile" non hai molte soluzioni se non mettere delle route statiche oppure fare un routing ed accesso remoto sul server 1 e far in modo che faccia quello da router, personalmente non metto mai il server a fare da router, lo faccio fare al router quel lavoro ma con la versione Workstation di Vmware sei limitato per queste cose perché le schede virtuali sono comunque limitate e spesso a meno che tu non abbia un client con fisicamente più di un nic i pacchetti non girano perfetti. La Workstation infatti è solo per test non per altro, non confonderla quindi con Hyper-v. non sono nemmeno parenti, il suo omologo lato VMWARE è l'exi o vpshere che dir si voglia e li la virtualizzazione è di secondo livello. Ma ripeto qui siamo OT, non è un problema di MS, è networking.

    Ciao

    A.

    • Contrassegnato come risposta Andry79 giovedì 2 aprile 2015 09:32
    giovedì 2 aprile 2015 09:30

Tutte le risposte

  • "DC, che è collegato a VmNet2 (con Ip statico 192.168.1.1, no gateway e dns 192.168.1.1 e 8.8.8.8)"

    I dns devono essere quelli atuoritativi per il tuo dominio AD.

    "VM1, collegato a VmNet2 con ip fornito dal DHCP e ha come gateway DC (192.168.1.1)"

    Non ne so molto di VmWare, ma "host-only" non é una rete isolata?

    Al limite puoi inserire un server o virtual appliaance che ti faccia da router.


    You wouldn't demand your Doctor a therapy just because you told him "I don't feel very well"
    You wouldn't expect your accountant to know how much your taxes are just because you told him "I have earned some money"
    Do not expect any IT Pro to suggest you a solution just because you said "It doesn't work"

    mercoledì 1 aprile 2015 15:29
  • Ciao, scusa ma perchè posti la domanda su un forum Microsoft? Dovresti usare i forum Vmware. Se comuque vuoi far funzionare tutte le Vm correttamente o le metti tutte su una VM Network Nat oppure tutte in Bridged con il "replicate phisical network of the connection state".

    Io di Vmware qualcosina ne so ;-) ma non è il forum giusto, qui si tratta di configurare il networking su una piattaforma non MS. quindi forum VmWare.

    Grazie per la collaborazione.

    A.

    mercoledì 1 aprile 2015 16:18
  • Ciao Alessandro, allora riformulo la domanda... 

    se avessi due server:

    il primo server con due schede di rete, una scheda di rete collegata direttamente alla WAN con configurazione fornitami dal mio ISP e la seconda collegata alla LAN interna.

    Il secondo con una solo scheda di rete, collegata alla LAN interna.

    Come potrei fare per fare in modo che il secondo server possa andare su Internet passando per il primo?

    Grazie.

    giovedì 2 aprile 2015 09:00
  • se il server 2 non ha una classe di indirizzo "navigabile" non hai molte soluzioni se non mettere delle route statiche oppure fare un routing ed accesso remoto sul server 1 e far in modo che faccia quello da router, personalmente non metto mai il server a fare da router, lo faccio fare al router quel lavoro ma con la versione Workstation di Vmware sei limitato per queste cose perché le schede virtuali sono comunque limitate e spesso a meno che tu non abbia un client con fisicamente più di un nic i pacchetti non girano perfetti. La Workstation infatti è solo per test non per altro, non confonderla quindi con Hyper-v. non sono nemmeno parenti, il suo omologo lato VMWARE è l'exi o vpshere che dir si voglia e li la virtualizzazione è di secondo livello. Ma ripeto qui siamo OT, non è un problema di MS, è networking.

    Ciao

    A.

    • Contrassegnato come risposta Andry79 giovedì 2 aprile 2015 09:32
    giovedì 2 aprile 2015 09:30
  • Ok. Anch'io stavo pensando di utilizzare RRAS.

    Ciao e grazie.

    giovedì 2 aprile 2015 09:33
  • Andry, solo perché mi sembri un po lanciato...spero che sia solo un test perché tutti i sistemi operativi installati sul Workstation NON SONO SUPPORTATI...quindi fai pure tutte le prove del caso ma NON mettere in produzione un VMWare Workstation perché non ha nemmeno servizi che girano con l'utente non loggato...

    Ciao.

    buon lavoro.

    A.

    giovedì 2 aprile 2015 09:40
  • I server fanno parte del mio laboratorio personale per studio, e sono VmWare Workstation perché il mio pc (un pò datata) non supporta l'installazione nativa di Hyper-V.
    giovedì 2 aprile 2015 09:45
  • benissimo allora sto tranquillo ;-)

    ciao.

    A.

    giovedì 2 aprile 2015 10:16