none
VPN Windows Server 2012 Essentials connesso ma... RRS feed

  • Domanda

  • Ciao a tutti,

    da un po' di giorni la VPN di Essentials non mi fa più accedere alle risorse aziendali. Però la connessione avviene correttamente.

    Dapprima pensavo dipendesse dal fatto che utilizzavo un client W7 (VM parallels) non in dominio ma poi mi sono accorto che è lo stesso anche dai client in dominio correttamente connessi ad Essentials.

    Suggerimenti?

    Grazie, Lorenzo.

    domenica 7 maggio 2017 18:04

Tutte le risposte

  • Sei tu che ti occupi dell'amministrazione della rete aziendale?
    domenica 7 maggio 2017 19:20
  • Si, perché?
    domenica 7 maggio 2017 19:51
  • Ho domandato perché ieri la piattaforma del forum non faceva vedere i nomi utente.
    Quando avviene la connessione alla VPN al computer viene rilasciato un indirizzo IP valido?
    La risoluzione DNS funziona?
    lunedì 8 maggio 2017 08:43
  • Scusa se la risposta sembrava polemica ma un semplice "si" era lungo meno di 4 caratteri :-)

    Detto questo, in realtà si becca un ip autoassegnato del tipo 169.254.103.237 e, direi chiaramente, non risolve i nomi...

    Se esplicito l'ip con uno della classe della lan aziendale e inserisco anche il dns (che poi è il server essentials) quando riavvio la connessione non si connette più... si blocca a "registrazione del computer sulla rete in corso". Tutto questo da client W7 NO dominio.


    lunedì 8 maggio 2017 22:42
  • Se ha IP autoassegnato sicuramente qualcosa non sta funzionando correttamente. Solitamente la configurazione standard di una VPN Windows Server prevede che sia di tipo routed con DHCP abilitato, quindi il range dei client è differente da quello della rete interna (da qui il problema nell'assegnazione dell'indirizzo).
    Il problema si verifica con ogni client? Se si, va rivista tutta la configurazione della VPN sul server.
    Questa pagina potrebbe esserti di aiuto: https://blogs.technet.microsoft.com/sbs/2014/05/19/understanding-vpn-configuration-in-windows-server-2012-r2-essentials/
    martedì 9 maggio 2017 11:37
  • nel RRAS come hai impostato l'assegnazione degli ip ai client che tentano la connessione in VPN ?

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    mercoledì 10 maggio 2017 10:00
    Moderatore
  • Ho controllato le impostazioni seguendo la pagina postata da Fabrizio e tutto è conforme. In RRAS nella tab IPv4 l'impostazione è DHCP.
    mercoledì 10 maggio 2017 13:09
  • e il server dhcp funziona correttamente ?

    https://technet.microsoft.com/it-it/library/dd469667%28v=ws.11%29.aspx?f=255&MSPPError=-2147217396


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    mercoledì 10 maggio 2017 14:32
    Moderatore
  • e il server dhcp funziona correttamente ?

    https://technet.microsoft.com/it-it/library/dd469667%28v=ws.11%29.aspx?f=255&MSPPError=-2147217396


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    Se funziona correttamente non riesco a verificarlo. In base al post che mi hai suggerito direi che la configurazione sia corretta per l'utilizzo di indirizzi ottenuti da un server DHCP. 

    Facendo delle prove da casa (in VM W7 su Parallels per Mac) vedo che quando abilito la connessione VPN non riesco neanche più a navigare, sia che utilizzi la rete condivisa sia prendendo le impostazioni direttamente dal dhcp del router.

    Controllando dal server il client è presente tra quelli connessi ma lo stato riporta "Non idoneo per protezione accesso alla rete".

    Ho anche provato a specificare un pool di indirizzi, ho utilizzato la stessa classe del server. Il client lo prende correttamente e in questo caso riesco a navigare in internet anche con la vpn on (in effetti vedo che esco con l'ip dell'ufficio).

    Però continuo a non accedere alle risorse del server...

    venerdì 12 maggio 2017 06:34
  • per caso in NPS Network Policy Server hai attivato e configurato NAP Network Access Protection ?

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    venerdì 12 maggio 2017 06:59
    Moderatore
  • per caso in NPS Network Policy Server hai attivato e configurato NAP Network Access Protection ?

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    Intendi lato server o lato client?

    Lato server sicuramente no... almeno non coscientemente (ho utilizzato il wizard di Essentials)

    Lato client ho seguito parzialmente questa guida (ho saltato l'ultima sezione le indicazioni non combaciavano al mio SO e non ho voluto fare ulteriori danni).

    C'è da dire che se disabilito "imposizione quarantena accesso remoto" (precedentemente abilitato seguendo la guida) la connessione non va a buon fine...

    ***Addendum

    Se utilizzo l'indirizzo IP anziché il nome funziona. Quindi un problema di DNS oltre che di DHCP...


    domenica 14 maggio 2017 20:28
  • allora prova a tirare su la connessione vpn, eseguire un ipconfig /all, verificare quale dns server risulta assegnato e poi prova ad eseguire un paio di nslookup verso una risorsa condivisa della rete remota. posta qui i risultati.

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    lunedì 15 maggio 2017 07:00
    Moderatore
  • allora prova a tirare su la connessione vpn, eseguire un ipconfig /all, verificare quale dns server risulta assegnato e poi prova ad eseguire un paio di nslookup verso una risorsa condivisa della rete remota. posta qui i risultati.

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    Ho fatto un ipconfig /all e in corrispondenza della vpn il dns è 0.0.0.0

    Ho provato con nslookup ma non sono molto pratico dello strumento.

    Ho lanciato neslookup --> server 192.168.10.x (indirizzo server dns)

    poi? 

    Grazie


    mercoledì 17 maggio 2017 08:05
  • ma il server dhcp che rilascia gli indirizzi è configurato anche per fornire dns, gateway e quant'altro attraverso le scope options ?

    quando viene assegnato un ip ad una macchina dovrebbero venir forniti anche questi parametri.


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    giovedì 18 maggio 2017 06:44
    Moderatore
  • ma il server dhcp che rilascia gli indirizzi è configurato anche per fornire dns, gateway e quant'altro attraverso le scope options ?

    quando viene assegnato un ip ad una macchina dovrebbero venir forniti anche questi parametri.


    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    Beh in azienda il dhcp fornisce tutto correttamente. E fino a qualche tempo fa anche in vpn...

    In questo momento la vpn è configurata con un lease specifico con la stessa subnet aziendale (non dhcp dunque) poiché altrimenti non riceveva alcun indirizzo...

    giovedì 18 maggio 2017 08:13
  • e allora è il lease specifico che non passa i parametri opzionali della connessione di rete. a questo punto potresti allora assegnare l'indirizzo ip e gli altri paramentri sulla connessione vpn in maniera statica ricordandoti di permettere questa possibilità lato server.

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    edo[at]mvps[dot]org

    lunedì 22 maggio 2017 11:35
    Moderatore