none
Più di un domain controller RRS feed

  • Domanda

  • Ciao a tutti,

    A seguito di un attacco per cui sono stati criptati una serie di server fra cui quello che funge da DC, l'utente - dopo il decrypt per cui ha dovuto pagare - non si fida più di questo DC e mi ha chiesto di crearne un altro.

    Fin quì nessun problema; ho creato il nuovo DC 2016 e spento quello che teoricamente potrebbe essere ancora infetto. Tutto funziona senza problemi.

    A questo punto ho voluto creare un nuovo DC come backup e quì nascono i problemi.

    Quando cerco di promuoverlo a DC, ho un errore nei prerequisiti per cui mi si avvisa che non si può proseguire perchè il vecchio DC è spento.

    E' evidente che ho saltato qualche passaggio. Qualcuno può aiutarmi?

    Grazie e cordiali saluti.


    Gaetano

    lunedì 9 aprile 2018 17:37

Tutte le risposte

  • Probabilmente avevi solo aggiunto un nuovo DC al dominio esistente non spostando i ruoli FSMO, che sono rimasti quindi sul vecchio server.
    Visto che il DC era stato compromesso ti consiglio di creare direttamente un nuovo dominio ed eventualmente di migrare i dati dal vecchio.
    lunedì 9 aprile 2018 19:27
    Moderatore
  • Grazie per la risposta,

    mi sai indicare un articolo o un best practice che spiega come migrare i dati?

    Grazie ancora e ciao


    Gaetano

    martedì 10 aprile 2018 05:44
  • Ciao Gaetano,
    Prova a guardare QUI se può aiutarti.

    Ciao
    martedì 10 aprile 2018 06:59
  • Ciao

    Grazie per il link.

    Sono riuscito a trasferire i 5 ruoli al nuovo DC 2016.

    Però mi è nato un nuovo problema. Quando accedo come DOMINIO\Administrator ho questo messaggio:

    Non è possibile accedere al tuo account.

    Questo problema spesso può essere risolto eseguendo la disconnessione dell'account quindi accedendo di nuovo etc etc.

    Ho provato più e più volte, ma mi crea sempre un utente temporaneo ed il problema non si risolve.

    Avete qualche idea?


    Gaetano

    martedì 10 aprile 2018 08:30
  • Forse è corrotto il profilo utente locale del server, prova ad eliminarlo accedendo con un altro utente amministratore (l'operazione elimina solo i dati del profilo, non l'account Administrator vero e proprio).
    Se non hai altri utenti di dominio con privilegi amministrativi sul server probabilmente dovrai riprepararlo...
    martedì 10 aprile 2018 08:41
    Moderatore
  • Ciao,

    dovrò probabilmente riprepararlo.

    A questo proposito c'è un modo per esportare utenti e computer dal vecchio DC e registrarli nel nuovo?

    Rifarli tutti potrebbe essere un bagno di sangue, visto il numero.

    Grazie per la risposta.


    Gaetano

    martedì 10 aprile 2018 10:22
  • Basta:
    - Creare e configurare un nuovo DC temporaneo per il dominio (anche in virtuale)
    - Spostarci sopra tutti i ruoli FSMO
    - Depromuovere il vecchio DC
    - Installare il nuovo DC aggiungendolo al dominio ancora ospitato dal server temporaneo.
    - Spostare nuovamente tutti i ruoli FSMO
    - Depromuovere il DC temporaneo

    Ovviamente se nel dominio già sono presenti altri DC non serve fare tutti questi passaggi.

    martedì 10 aprile 2018 11:00
    Moderatore
  • Figurati Gaetano!

    Comunque, non è consigliato accedere ai client con l'utenza amministratore. Comunque, come consigliato sotto, prova a creare un nuovo utente amministratore e vedi se con quello riesci a loggare.

    Il problema persiste solo con l'utente administrator o anche con altri? Se così fosse, controlla le impostazioni di rete che almeno il gateway punti al server (sarebbe meglio anche il DNS).

    Questo problema esiste esclusivamente su quel singolo client? Se così fosse e persiste ancora: togli il PC dal dominio e fai nuovamente la join a dominio.

    Fammi sapere!

    Ciao,
    Federico

    martedì 10 aprile 2018 14:03

  • Se così fosse, controlla le impostazioni di rete che almeno il gateway punti al server (sarebbe meglio anche il DNS).


    sei sicuro di questa informazione ?

    Edoardo Benussi
    Microsoft MVP - Cloud and Datacenter Management
    e[dot]benussi[at]outlook[dot]it

    lunedì 16 aprile 2018 09:36
    Moderatore