none
Installazione AD FS - errore durante il setup: SPN duplicato RRS feed

  • Domanda

  • Buongiorno a tutti,

    Cercando di installare i servizi federativi su una macchina windows 2012r2 ottengo questo errore.

    An error occurred during an attempt to set the SPN for the specified service account. Set the SPN for the service account manually.  For more information about setting the SPN of the service account manually, see the AD FS Deployment Guide.  Error message: The SPN required for this Federation Service is already set on another Active Directory account.  Choose a different Federation Service name and try again.

     in seguito a questo errore il setup va in timeout durante l'avvio dei servizi.

    nel registro eventi trovo questi errori molto generici

    Log Name:      System
    Source:        Service Control Manager
    Date:          04/03/2014 18:36:50
    Event ID:      7023
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      Ad2012fs5.ad2012.test
    Description:
    The Active Directory Federation Services service terminated with the following error: 
    An exception occurred in the service when handling the control request.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7023</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2014-03-04T17:36:50.824991300Z" />
        <EventRecordID>2028</EventRecordID>
        <Correlation />
        <Execution ProcessID="472" ThreadID="2848" />
        <Channel>System</Channel>
        <Computer>Ad2012fs5.ad2012.test</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">Active Directory Federation Services</Data>
        <Data Name="param2">%%1064</Data>
        <Binary>61006400660073007300720076000000</Binary>
      </EventData>
    </Event>

    la macchina su cui installo è una 2012r2  completamente aggiornata e dedicata solo a questo ruolo;
    il certificato è stato generato dalla mia CA  interna e come database utilizzo quello integrato di sistema.

    Il DC è un'altra macchina Windows 2012r2 con i ruoli di DC + DNS + CA. il livello di funzionalità del dominio è 2012r2.

    ho visto sui vari forum che si tratta di un problema per lo più legato ai database ma non ho trovato soluzioni applicate ai servizi FS.

    Qualcuno può aiutarmi?

    mercoledì 5 marzo 2014 08:16

Risposte

  • ... ok... ho risolto con questa guida.

    in particolare seguendo alla lettera la parte relativa al certificato.

    https://blogs.technet.com/b/askpfeplat/archive/2013/12/09/how-to-build-your-adfs-lab-on-server-2012-part-1.aspx

    • Contrassegnato come risposta Dario Bonini mercoledì 5 marzo 2014 11:09
    mercoledì 5 marzo 2014 11:09

Tutte le risposte

  • ... ok... ho risolto con questa guida.

    in particolare seguendo alla lettera la parte relativa al certificato.

    https://blogs.technet.com/b/askpfeplat/archive/2013/12/09/how-to-build-your-adfs-lab-on-server-2012-part-1.aspx

    • Contrassegnato come risposta Dario Bonini mercoledì 5 marzo 2014 11:09
    mercoledì 5 marzo 2014 11:09
  • Ciao Bon Re,

    Grazie per averci fatto sapere (tornera' sicuramente utile a qualcun'altro).

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda.

    venerdì 7 marzo 2014 14:53
  • Ciao a tutti,

    anch'io ho lo stesso problema. Ho verificato il link segnalato per quanto riguarda il certificato. Io sto usando un certificato SelfSigned con il CN che corrisponde al nome della FARM. Nonostante ciò il servizio non parte con Event ID 7023.

    Ho provato anche a rimuove la registrazione SPN ma il problema non si risolve. Ho provato ad utilizzare sia un account gMSA sia un account standard. Niente.

    Grazie,

    Simone


    Simone

    giovedì 13 marzo 2014 17:02