none
Internet Explorer 32bit non va, 64bit sì RRS feed

  • Domanda

  • Strano problema. Dopo formattazione e reinstallazione s/o Vista x64 e relativi programmi bundle di Packard Bell su PC quad-core mediante utility di Recovery totale del produttore, fin dal primo riavvio la connessione a internet con modem adms hsdpa avviene con successo, ma non tutti i programmi riescono ad accedere ad internet: ad esempio la navigazione è possibile SOLO con Internet Explorer 64bit, mentre il 32 bit non va. Anche altri programmi che necessitano di connessione a internet non riescono ad accedervi, rilevando la connessione assente: ad es Liveupdate del Norton NIS 2009, registrazione del prodotto norton, update di software packard bell... (rilevano tutti internet non connesso, al pari di IE32). Gli unici che funzionano perfettamente sono il Windows Update, il Windows Mail e il già citato IE 64bit (forse perché sono tutti 64 bit?)
    Provvedo a ri-effettuare nuovamente altre volte il ripristino totale del computer (recovery), ma il problema si ripresenta lo stesso: solo IE64 e pochi altri eletti vedono la connessione a internet, tutti gli altri non navigano e la rilevano assente (anche IE32).
    Premetto che non ho altri firewall a parte il NIS2009, ed il NIS stesso non rileva la connessione perché non mi pone le domande sui vari programmi che vogliono andare su internet. Infine il NIS stesso non riesce ad aggiornare il database dei virus perché la connessione per lui è ancora assente.

    Provvedo quindi a disinstallare il NIS con strumento adeguato (Norton Removal Tool) e lascio il firewall di windows ancora disattivo. Ma niente, nessun esito migliorativo per il problema succitato.
    Che sarà mai??
    Grazie, Roberto

    venerdì 15 gennaio 2010 11:41

Risposte

  • Franco ho trovato!!

    Patch della Packard Bell quanto mai evocativa: "32 bit application cannot access the internet on a Vista 64bit platform".
    Guarda qua http://support.packardbell.com/it/item/index.php?i=topic_02810&pi=platform_amadeus_imedia

    "Sistemi che utilizzano NVIDIA network controller e Windows Vista 64 bit, le applicazioni 32-bit come Internet Explorer 32, Norton Live Update e Windows Live Messenger non accedono ad internet, mentre le restanti applicazioni 64-bit funzionano.
    Problema causato da FILE MANCANTE a 32-bit dell'NVIDIA application filter (installato con i chipset driver).
    La patch esegue il comando "netsh winsock reset" (meglio segnarselo) che resetta il catalogo Winsock ai valori di default e previene l'uso dell'utility di rete "NVIDIA network management tools". "Winsock" è una specifica tecnica che definisce come come le applicazioni Windows devono accedere ad internet, specialmente con protocollo TCP/IP".

    Come dire... scusa Franco se noi utenti ti disturbiamo senza prima contattare neanche le faq del produttore... però grazie dell'ottimo supporto e dell'attenzione prestata!
    Tanti saluti e ottimo lavoro
    e buona continuazione
    Roberto
    venerdì 15 gennaio 2010 23:56

Tutte le risposte

  • Una prova da fare:

    Pannello di controllo > programmi predefiniti , imposta programmi predefiniti.
    Clicca su Internet Explorer ed impostalo come predefinito per tutte le sue funzioni.
    In precedenza le connessioni con quello stesso modem erano viste in modo completo dal sistema?
    Ciao

    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    venerdì 15 gennaio 2010 11:54
    Moderatore
  • Ciao Franco,
    la risposta è sì, il modem ha sempre funzionato bene sin dall'acquisto del computer, tutti i programmi accedevano a internet senza restrizioni, e il firewall compiva il suo lavoro di smistarmi le richieste di connessione da parte dei programmi.
    Ora dopo il ripristino del computer alle impostazioni di fabbrica, non più.

    Riconfermo che ora tutti i firewall sono disattivati e/o disinstallati (windows e nis).

    Ho fatto quello che mi hai chiesto (programmi predefiniti), IE aveva già tutte le sue funzioni predefinite, e gliele ho confermate per scrupolo.

    Aggiungo che anche il Windows Live Messenger mi dice che internet è disconnesso o assente. Ma intanto IE64 di sotto naviga senza difficoltà.
    Il contatore dei byte trasmessi e ricevuti del modem cicla correttamente sin dall'inizio della connessione (presumo Windows Update che fa i suoi primi controlli), e comunque i byte avanzano in base alle richieste di navigazione di IE64.
    Per tutti gli altri programmi non citati all'inizio del thread, la connessione è trasparente.

    Una volta WinXP aveva il file di sistema "netdetect.com" nella root di c: ... avvisava tutto il sistema di una connessione attiva. Ora il Vista non ce l'ha più o lo ha spostato da qualche altra parte.

    Come posso procedere?
    Grazie ancora
    venerdì 15 gennaio 2010 17:25
  • Secondo me il sistema va lasciato così e va reinstallato "su se stesso" affinchè riscriva di nuovo tutti i files.
    Hai il DVD di Windows Vista?
    Ciao
    venerdì 15 gennaio 2010 18:33
    Moderatore
  • Negativo... non ho il dvd di Windows Vista, perché la reinstallazione dell'intero sistema avviene mediante un'utility di recovery Packard Bell che accede ad una partizione nascosta dell'hardisk e contiene il sistema operativo già preinstallato con i driver adeguati e software di terze parti del produttore stesso. Il completamento dell'installazione avviene in maniera analoga al primo giorno che ho acquistato il computer, ovvero senza introdurre alcun cd di alcun tipo (comunque non forniti) ma rispondendo già alle ultime domande finali su "nome utente", "data/ora", e infine installazione automatizzata (non interattiva) dei restanti software "in-bundle" regalati dal costruttore (Office 60 giorni, NIS 90 giorni, Works, Nero basic, Packard Bell Updator...).
    E a proposito di "Packard Bell updator": neanche lui vede la connessione internet attiva, altrimenti sarebbe già mezzo passo avanti. Eppure il primo giorno che ho acquistato il computer è avvenuto tutto in maniera identica ed è andato liscio, e non ho fatto alcuna aggiunta hardware da allora.
    O forse potrei specificare che adesso ho una tastiera e mouse cordless (non bluetooth) che prima non avevo, ma che non hanno mai causato problemi a internet.
    Devo provare a rimettere le vecchie periferiche ps/2 e riformattare anche una volta?
    venerdì 15 gennaio 2010 23:03
  • Secondo me il sistema è compromesso.
    Il mio consiglio è :
    ripristina il sistema con il recovery.
    Non installare NIS , se viene preinstallato rimuovilo ( se è preinstallato va rimosso con il suo tool di rimozione altrimenti lascierà tracce).
    Dopo la configurazione del sistema operativo scarica subito Microsoft Security Essentials :
    http://www.microsoft.com/Security_Essentials/
    e lo installi dando ok all'aggiornamento ed alla analisi del sistema.
    Usa sempre Internet Explorer 32bit (quello di default).
    Vai in Windows Update ed aggiorna.
    Poi tieni il sistema così e testalo.
    Ciao


    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    venerdì 15 gennaio 2010 23:22
    Moderatore
  • Franco ho trovato!!

    Patch della Packard Bell quanto mai evocativa: "32 bit application cannot access the internet on a Vista 64bit platform".
    Guarda qua http://support.packardbell.com/it/item/index.php?i=topic_02810&pi=platform_amadeus_imedia

    "Sistemi che utilizzano NVIDIA network controller e Windows Vista 64 bit, le applicazioni 32-bit come Internet Explorer 32, Norton Live Update e Windows Live Messenger non accedono ad internet, mentre le restanti applicazioni 64-bit funzionano.
    Problema causato da FILE MANCANTE a 32-bit dell'NVIDIA application filter (installato con i chipset driver).
    La patch esegue il comando "netsh winsock reset" (meglio segnarselo) che resetta il catalogo Winsock ai valori di default e previene l'uso dell'utility di rete "NVIDIA network management tools". "Winsock" è una specifica tecnica che definisce come come le applicazioni Windows devono accedere ad internet, specialmente con protocollo TCP/IP".

    Come dire... scusa Franco se noi utenti ti disturbiamo senza prima contattare neanche le faq del produttore... però grazie dell'ottimo supporto e dell'attenzione prestata!
    Tanti saluti e ottimo lavoro
    e buona continuazione
    Roberto
    venerdì 15 gennaio 2010 23:56
  • Sempre benvenuto e grazie per aver riferito.
    Ciao

    Franco Leuzzi - Microsoft ® MVP Windows Desktop Experience
    sabato 16 gennaio 2010 11:10
    Moderatore