none
Problema di schedulazione RRS feed

  • Domanda

  • Sicuramente è una banalità, ma ci sto sbattendo la testa da due giorni.
    Ho due server Windows 2008 Standard da due clienti diversi.
    Su entrambi ho creato la schedulazione dell'invio di una mail (tramite l'utility Blat) che mi avvisi dell'andamento del backup notturno, solo che su un server funziona perfettamente mentre sull'altro eseguendo la schedulazione, anche a mano, mi salta sempre fuori il risultato (0xC) e ovviamente la mail non parte.

    Il comando eseguito è

    %windir%\system32\cmd.exe /C "batch_che_lancia_la_mail.cmd"

    Lanciando l'intera stringa del comando da prompt, la mail viene inviata, quindi mi vien da pensare che sia proprio la schedulazione ad avere qualche problema, pur eseguendola con diritti amministrativi. Inizialmente avevo importato l'evento da un file XML salvato da un terzo server e poi modificato con i parametri giusti (procedura che ho eseguito anche sull'altro server senza riscontrare problemi), quindi ho provato a creare il job da zero, partendo dal registro eventi (associa attività all'evento...), ma il risultato è stato il medesimo.
    Il registro degli eventi non riporta nulla che mi possa essere d'aiuto.
    Qualche suggerimento?

    giovedì 13 marzo 2014 18:30

Risposte

  • :: On Thu, 13 Mar 2014 18:30:18 +0000
    :: (Technet.it-IT.windowsserverit)
    :: <2cd2d1a9-9f9d-42ef-a706-7786fa7dfca4@mvps.org>
    :: Vitor-nillo wrote:
     
    > Sicuramente è una banalità, ma ci sto sbattendo la testa da due
    > giorni. Ho due server Windows 2008 Standard da due clienti diversi.
    > Su entrambi ho creato la schedulazione dell'invio di una mail
    > (tramite l'utility Blat) che mi avvisi dell'andamento del backup
    > notturno, solo che su un server funziona perfettamente mentre
    > sull'altro eseguendo la schedulazione, anche a mano, mi salta sempre
    > fuori il risultato (0xC) e ovviamente la mail non parte.
    >
    > Il comando eseguito è
    >
    > %windir%\system32\cmd.exe /C "batch_che_lancia_la_mail.cmd"
    >
     
    attenzione il comando "blat -install ...parametri..." memorizza i
    parametri nel registry per l'UTENTE corrente, il che significa che se
    "blat" viene poi lanciato in un contesto utente diverso i parametri in
    questione NON saranno disponibili; credo tu abbia due modi per poter
    risolvere il problema; il primo è quello di passare a "blat" TUTTI i
    parametri sulla linea di comando (inclusi server, credenziali, etc), il
    secondo ... è quello di NON usare "blat" ma di utilizzare un pezzo di
    VBScript o PowerShell per inviare la mail
     
    ciao
     
     
    venerdì 14 marzo 2014 16:07
  • Dopo dura riflessione, GastoneCanali ha scritto :

    Credo sia un problema di registrazione dei parametri di Blat.

    puoi postare il batch ?

    Ho risolto.
    Ho ripreso la riga di registrazione di Blat che avevo usato sull'altro server e mi sono accorto che avevo scritto male un parametro ("-p" al posto di "-pw" per la password) quindi il batch non trovava il profilo corretto.
    Ora l'ho eseguita (da un prompt elevato) e la schedulazione funziona e manda la mail.
    Il job di schedulazione comprendeva tutto il path, sia per il "cmd.exe" (con l'uso della variabile %windir%) che per il batch che lancia la mail. Inoltre avevo aggiunto il path di Blat tra le variabili di sistema.

    Se lancio il comando dal prompt normale funziona mentre se lo lancio da prompt elevato, no. La schedulazione evidentemente parte sempre con privilegi elevati, che ci sia o meno la spunta sull'apposita casella.

    Non credo proprio (per non darti un NO secco), SOLO se c'è la spunta viene eseguito elevato, altrimenti sarebbe un BUG!  Ho visto ora, che manca il path nel lancio del Batch */C "batch_che_lancia_la_mail.cmd"*, ti ricordo che la "working dir" di un processo elevato è %windir%\system32, questo è molto probabile che sia la causa.

    Visto che funziona, per curiosità ho fatto una prova:
    Ho eliminato il profilo di Blat da prompt elevato e l'ho ricreato partendo però da un prompt "normale" (sono comunque l'administrator).
    Ho tolto la spunta da "Esegui con privilegi più elevati" nel job schedulato e l'ho fatto partire. L'utente con cui lancio il job è lo stesso da cui sto svolgendo tutto il lavoro.
    Risultato: 0xC come quando non trovava il profilo corretto.
    Presumo, quindi, che a richiedere privilegi elevati siano o il comando lanciato dallo schedulatore (%windir%\system32\cmd.exe /C "c:\path\del\batch.cmd") o il batch stesso

    [/CODE]

    blat -subject "Backup Server" -body "Backup Completato" -to mail@destinatario.it -p nome_profilo

    [/CODE]


    ps:Ma quale utente è stato cambiato: Vitor-nillo, il gatto o il personaggio di di guerre stellari... sei forse ObiWan ?

    Non sono ObiWan (magari) ma Skywalker Senior e il mio avatar è il gatto. Non so chi siano Vitor-nillo o l'altro utente con cui è apparso il mio secondo messaggio. Ho posto il problema sul forum della community di NNTP Bridge e mi hanno risposto che Microsoft aveva fatto dei non meglio precisati cambiamenti ma dopo qualche ora è tornata sui suoi passi, infatti ora sono tornato "me stesso".

    venerdì 14 marzo 2014 16:22

Tutte le risposte

  • Scriveva Vitor-nillo giovedì, 13/03/2014:

    Sicuramente è una banalità, ma ci sto sbattendo la testa da due giorni.

    Che diavolo è successo?

    Vedo il mio messaggio (qui sopra) ma l'autore risulta essere un altro!


    David Wilkinson | Visual C++ MVP
    giovedì 13 marzo 2014 19:37
  • Eh, no, c'è proprio qualcosa che non va! La risposta è apparsa a nome di un altro utente ancora!

    -EDIT-

    Deve essere un problema con l'NNTP bridge. Scrivendo direttamente via web appare il nome giusto.

    giovedì 13 marzo 2014 19:39
  • riesci a dare un codice di errore più esteso es. "C0000XXX" http://support.microsoft.com/kb/308558/it

    Se non ho capito male, il backup viene eseguito, ma non viene inviata la mail, corretto?

    Il task è eseguito elevato?

    Se commenti il comando di invio (::blat.exe .....) il task termina correttamente con 0x0 ?


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    giovedì 13 marzo 2014 23:42
    Moderatore
  • GastoneCanali ha detto questo venerdì :

    riesci a dare un codice di errore più esteso es. "C0000XXX"http://support.microsoft.com/kb/308558/it

    Se non ho capito male, il backup viene eseguito, ma non viene inviata la mail, corretto?

    Il task è eseguito elevato?

    Se commenti il comando di invio (::blat.exe .....) il task termina correttamente con 0x0 ?

    Credo sia un problema di registrazione dei parametri di Blat.
    Se lancio il comando dal prompt normale funziona mentre se lo lancio da prompt elevato, no.
    La schedulazione evidentemente parte sempre con privilegi elevati, che ci sia o meno la spunta sull'apposita casella.
    Oggi pomeriggio farò altre prove e farò sapere.

    P.S. Ora sto scrivendo dall'ufficio, vediamo se anche qui l'NNTP bridge mi cambia l'utente

    venerdì 14 marzo 2014 11:25
  • Credo sia un problema di registrazione dei parametri di Blat.
    puoi postare il batch ?

    Se lancio il comando dal prompt normale funziona mentre se lo lancio da prompt elevato, no.
    La schedulazione evidentemente parte sempre con privilegi elevati, che ci sia o meno la spunta sull'apposita casella.

    Non credo proprio (per non darti un NO secco), SOLO se c'è la spunta viene eseguito elevato, altrimenti sarebbe un BUG!  Ho visto ora, che manca il path nel lancio del Batch /C "batch_che_lancia_la_mail.cmd", ti ricordo che la "working dir" di un processo elevato è %windir%\system32, questo è molto probabile che sia la causa.

    Ma "se lo lancio da prompt elevato, no." che errore ottieni?

    Prova a schedulare il batch direttamente  c:\path\al\tuo\batch\batch_che_lancia_la_mail.cmd

    oppure

    ::
    %windir%\system32\cmd.exe /C  c:\path\al\tuo\batch_che_lancia_la_mail.cmd
    ::

    ciao

    ps:Ma quale utente è stato cambiato: Vitor-nillo, il gatto o il personaggio di di guerre stellari... sei forse ObiWan ?


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere


    venerdì 14 marzo 2014 13:45
    Moderatore
  • :: On Thu, 13 Mar 2014 18:30:18 +0000
    :: (Technet.it-IT.windowsserverit)
    :: <2cd2d1a9-9f9d-42ef-a706-7786fa7dfca4@mvps.org>
    :: Vitor-nillo wrote:
     
    > Sicuramente è una banalità, ma ci sto sbattendo la testa da due
    > giorni. Ho due server Windows 2008 Standard da due clienti diversi.
    > Su entrambi ho creato la schedulazione dell'invio di una mail
    > (tramite l'utility Blat) che mi avvisi dell'andamento del backup
    > notturno, solo che su un server funziona perfettamente mentre
    > sull'altro eseguendo la schedulazione, anche a mano, mi salta sempre
    > fuori il risultato (0xC) e ovviamente la mail non parte.
    >
    > Il comando eseguito è
    >
    > %windir%\system32\cmd.exe /C "batch_che_lancia_la_mail.cmd"
    >
     
    attenzione il comando "blat -install ...parametri..." memorizza i
    parametri nel registry per l'UTENTE corrente, il che significa che se
    "blat" viene poi lanciato in un contesto utente diverso i parametri in
    questione NON saranno disponibili; credo tu abbia due modi per poter
    risolvere il problema; il primo è quello di passare a "blat" TUTTI i
    parametri sulla linea di comando (inclusi server, credenziali, etc), il
    secondo ... è quello di NON usare "blat" ma di utilizzare un pezzo di
    VBScript o PowerShell per inviare la mail
     
    ciao
     
     
    venerdì 14 marzo 2014 16:07
  • Dopo dura riflessione, GastoneCanali ha scritto :

    Credo sia un problema di registrazione dei parametri di Blat.

    puoi postare il batch ?

    Ho risolto.
    Ho ripreso la riga di registrazione di Blat che avevo usato sull'altro server e mi sono accorto che avevo scritto male un parametro ("-p" al posto di "-pw" per la password) quindi il batch non trovava il profilo corretto.
    Ora l'ho eseguita (da un prompt elevato) e la schedulazione funziona e manda la mail.
    Il job di schedulazione comprendeva tutto il path, sia per il "cmd.exe" (con l'uso della variabile %windir%) che per il batch che lancia la mail. Inoltre avevo aggiunto il path di Blat tra le variabili di sistema.

    Se lancio il comando dal prompt normale funziona mentre se lo lancio da prompt elevato, no. La schedulazione evidentemente parte sempre con privilegi elevati, che ci sia o meno la spunta sull'apposita casella.

    Non credo proprio (per non darti un NO secco), SOLO se c'è la spunta viene eseguito elevato, altrimenti sarebbe un BUG!  Ho visto ora, che manca il path nel lancio del Batch */C "batch_che_lancia_la_mail.cmd"*, ti ricordo che la "working dir" di un processo elevato è %windir%\system32, questo è molto probabile che sia la causa.

    Visto che funziona, per curiosità ho fatto una prova:
    Ho eliminato il profilo di Blat da prompt elevato e l'ho ricreato partendo però da un prompt "normale" (sono comunque l'administrator).
    Ho tolto la spunta da "Esegui con privilegi più elevati" nel job schedulato e l'ho fatto partire. L'utente con cui lancio il job è lo stesso da cui sto svolgendo tutto il lavoro.
    Risultato: 0xC come quando non trovava il profilo corretto.
    Presumo, quindi, che a richiedere privilegi elevati siano o il comando lanciato dallo schedulatore (%windir%\system32\cmd.exe /C "c:\path\del\batch.cmd") o il batch stesso

    [/CODE]

    blat -subject "Backup Server" -body "Backup Completato" -to mail@destinatario.it -p nome_profilo

    [/CODE]


    ps:Ma quale utente è stato cambiato: Vitor-nillo, il gatto o il personaggio di di guerre stellari... sei forse ObiWan ?

    Non sono ObiWan (magari) ma Skywalker Senior e il mio avatar è il gatto. Non so chi siano Vitor-nillo o l'altro utente con cui è apparso il mio secondo messaggio. Ho posto il problema sul forum della community di NNTP Bridge e mi hanno risposto che Microsoft aveva fatto dei non meglio precisati cambiamenti ma dopo qualche ora è tornata sui suoi passi, infatti ora sono tornato "me stesso".

    venerdì 14 marzo 2014 16:22
  • Sembra che ObiWan abbia detto :

    On Thu, 13 Mar 2014 18:30:18 +0000
    (Technet.it-IT.windowsserverit)
    <2cd2d1a9-9f9d-42ef-a706-7786fa7dfca4@mvps.org>
    Vitor-nillo wrote:

     

    Sicuramente è una banalità, ma ci sto sbattendo la testa da due
    giorni. Ho due server Windows 2008 Standard da due clienti diversi.
    Su entrambi ho creato la schedulazione dell'invio di una mail
    (tramite l'utility Blat) che mi avvisi dell'andamento del backup
    notturno, solo che su un server funziona perfettamente mentre
    sull'altro eseguendo la schedulazione, anche a mano, mi salta sempre
    fuori il risultato (0xC) e ovviamente la mail non parte.

    Il comando eseguito è

    %windir%\system32\cmd.exe /C "batch_che_lancia_la_mail.cmd"

     
    attenzione il comando "blat -install ...parametri..." memorizza i
    parametri nel registry per l'UTENTE corrente, il che significa che se
    "blat" viene poi lanciato in un contesto utente diverso i parametri in
    questione NON saranno disponibili; credo tu abbia due modi per poter
    risolvere il problema; il primo è quello di passare a "blat" TUTTI i
    parametri sulla linea di comando (inclusi server, credenziali, etc), il
    secondo ... è quello di NON usare "blat" ma di utilizzare un pezzo di
    VBScript o PowerShell per inviare la mail
     
    ciao
     

    Alla fine era un problema di registrazione del profilo (un banale typo).
    Mi documenterò sugli altri metodi perché sono sempre propenso a ridurre al minimo l'utilizzo di tool di terze parti.

    venerdì 14 marzo 2014 16:28
  • è quello di NON usare "blat" ma di utilizzare un pezzo di
    VBScript o PowerShell per inviare la mail
     

    Su powershell posso anche convenire, ma vbscript è meglio lasciarlo perdere, dato che i Collaboration Data Objects non sono più forniti...

    Ciao Gastone

    PS: bisogna stare attenti con questi Jedi, basta nominarli e ricompaiono...


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    venerdì 14 marzo 2014 23:27
    Moderatore
  • Molto probabilmente ScaiVuolcher il vecchio ha detto:

    Alla fine era un problema di registrazione del profilo (un banale typo).
    Mi documenterò sugli altri metodi perché sono sempre propenso a ridurre al minimo l'utilizzo di tool di terze parti.

    #powershell
    $filename = "c:\mioallegato.txt" $smtpServer = "mioservermail" $mail = new-object Net.Mail.MailMessage $allegato = new-object Net.Mail.Attachment($filename) $smtp = new-object Net.Mail.SmtpClient($smtpServer) $mail.From = "bk@mio.dom" $mail.To.Add("walker@dom.dom") $mail.Subject = "il mio soggetto" $mail.Body = "la mia mail" $mail.Attachments.Add($allegato) $smtp.Send($mail)

    Sarebbe stato bello avere il batch, già nell'apertura del thread, forse qualcuno avrebbe visto l'errore banale e si sarebbe capito qualcosa in più sul misterioso comando che richiede l'elevazione o NO, BOooHhhh

    Ciao


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere

    venerdì 14 marzo 2014 23:56
    Moderatore
  • Scriveva GastoneCanali sabato, 15/03/2014:

    Volevo seguire il tuo consiglio (powershell). Alla fine ce l'ho fatta ma è stata un pelino più complicata del previsto.
    Il server SMTP a cui mi appoggiavo richiedeva l'autenticazione e l'ultima cosa che volevo era lasciare un file di testo contenente la password dell'account mail in chiaro.

    Ho trovato la soluzione abilitando un SMTP Virtual Server in ISS con i seguenti comandi powershell:

    import-module servermanager
    add-windowsfeature smtp-server
    add-windowsfeature rsat-smtp
    

    Nel virtual server ho abilitato il relay solo da localhost.

    Dopodiché ho dovuto abilitare gli script in powershell:

    Set-ExecutionPolicy RemoteSigned

    Infine ho dovuto impostare l'avvio automatico del servizio SMTP (normalmente impostato su "avvio manuale") altrimenti il virtual server risultava non avviato dopo un reboot.

    Ho fatto una prova con Powershell creado un script PS1 molto semplice:

    send-mailmessage -from mittente@dominio.it -to
    destinatario@altrodominio.it -subject "Backup" -body "backup OK"
    -smtpserver localhost -Encoding ([System.Text.Encoding]::UTF8)
    

    L'ho schedulato al posto della riga che lanciava Blat e per il momento sembra andare.
    Se funziona lo applicherò anche agli altri server.

    Grazie

    domenica 16 marzo 2014 01:01
  • Tirare su un smpt server, per giunta senza nessuna forma di autenticazione, open per tutti, solo per inviare una mail ogni tanto, a mio parere, non sembra una soluzione ottimale... anzi la sconsiglio vivamente (ma ripeto questa è una mia cosiderazione).

    Facendo un passo in dietro, dato che salvavi la password nel registro in chiaro con blat (vedi il profilo salvato) non capisco le tue preoccupazioni  con  lo script in powershell :)  .
    Tra l'altro posh ha la possibilità di salvare le credenziali in modo sicuro e anche in questi forum ne hanno parlato, oppure si poteva fare uno script per l'invio diretto (ma sarebbe stato reinventare la ruota)...

    Avresti potuto/DOVUTO rendere leggibile il tuo file batch_che_lancia_la_mail.cmd solo all'utente impegato per la schedulzione (aggiungerei system e admins), così il contenuto del batch, password ivi comprese, sarebbe stato al sicuro da occhi indiscreti!

    Ma se fosse stato così, la password sarebbe stata al sicuro ("l'ultima cosa che volevo era lasciare un file di testo contenente la password ") e non ci sammo trovati a scrivere qui.

    Ciao


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere



    domenica 16 marzo 2014 11:30
    Moderatore
  • Il 16/03/2014, GastoneCanali ha detto :


    Tirare su un smpt server, per giunta senza nessuna forma di autenticazione, open per tutti, solo per inviare una mail ogni tanto, a mio parere, non sembra una soluzione ottimale... anzi la sconsiglio vivamente (ma ripeto questa è una mia cosiderazione).

    Non c'è autenticazione, ma il relay è consentito solo al localhost


    Facendo un passo in dietro, dato che salvavi la password nel registro in chiaro con blat (vedi il profilo salvato) non capisco le tue preoccupazioni  con  lo script in powershell :)  . Tra l'altro posh ha la possibilità di salvare le credenziali in modo sicuro e anche in questiforum  <http://social.technet.microsoft.com/Forums/it-IT/f42d7a0f-5ee3-4e62-a5be-733a30ed8608/powershell-salvareleggere-le-credenziali-da-un-file>ne hanno parlato, oppure si poteva fare uno script per l'invio diretto (ma sarebbe stato reinventare la ruota)...

    Non è mai troppo tardi per correggere la situazione. Vado a leggere quel thread.



    Avresti potuto/DOVUTO rendere leggibile il tuo file batch_che_lancia_la_mail.cmd solo all'utente impegato per la schedulzione (aggiungerei system e admins), così il contenuto del batch, password ivi comprese, sarebbe stato al sicuro da occhi indiscreti!

    E' già così. E' l'admin che invia la mail ed il batch si trova nella sua cartella documenti

    domenica 16 marzo 2014 19:23
  • Nel suo scritto precedente, Skywalker Senior ha sostenuto :

    Il 16/03/2014, GastoneCanali ha detto :


    Tirare su un smpt server, per giunta senza nessuna forma di autenticazione, open per tutti, solo per inviare una mail ogni tanto, a mio parere, non sembra una soluzione ottimale... anzi la sconsiglio vivamente (ma ripeto questa è una mia cosiderazione).

    Non c'è autenticazione, ma il relay è consentito solo al localhost

    Aggiungo. oltre al relay, anche la connessione è concessa solo a localhost. Inoltre l'accesso anonimo è disabilitato. Lanciando il job schedulato con credenziali amministrative e abilitando nel virtual host l'autenticazione integrata, il batch viene eseguito regolarmente e la mail viene spedita.
    Curiosamente, registrando le credenziali con la procedura descritta nell'altro thread e aggiungendo il parametro "-Credential" al batch, funziona tutto sia da powershell (lanciano i comandi uno ad uno) che da normale Prompt (lanciano il batch "powershell c:\....\batch.ps1"), sia in modalità normale che con diritti elevati, ma non funziona il comando schedulato (codice restituito: 0x1), con privilegi elevati o meno.

    domenica 16 marzo 2014 21:05
  • Inoltre l'accesso anonimo è disabilitato.

    E come faceva a funzionare lo script powershell se la send-mailmessage era senza utente e password?

    Lanciando il job schedulato con credenziali amministrative e abilitando nel virtual host l'autenticazione integrata , il batch viene eseguito regolarmente e la mail viene spedita.

    Quale job ? Come è fatto questo script? Deduco che prima avevi solo l'autenticazione di base?(l'accesso anonimo, hai già detto che era disabilitato...)

    Curiosamente, registrando le credenziali con la procedura descritta nell'altro thread e aggiungendo il parametro "-Credential" al batch, funziona tutto sia da powershell

    Ma non avevi detto che funzionava già due righe sopra? E poi se abiliti l'autenticazione integrata perchè usi le credenziali nelle tue prove? 

    In tutto questo thread sono riportate informazioni non chiare e spesso in contraddizione fra loro, es. path di schedulazione non presente nei post, ma presente nei tuoi server, autenticazione anonima disattivata ma  l'invio avviene senza usr e pwd e nonostante ciò tutto funziona e poi ogni post aggiunge variabili al problema ... difficilissimo seguirti, ancora più arduo darti consigli; passo; tanto te la canti e te la suoni come vuoi.

    Alla prossima

    Gastone


    Gastone Canali >http://www.armadillo.it

    Se alcuni post rispondono al tuo quesito(non necessariamente i miei), ricorda di contrassegnarli come risposta e non dimenticare di contrassegnare anche i post utili. GRAZIE! Ricorda di dare un occhio ai link Click Here andHere



    lunedì 17 marzo 2014 00:37
    Moderatore
  • GastoneCanali ha detto questo lunedì :

    difficilissimo seguirti, ancora più arduo darti consigli; passo, tanto te la canti e te la suoni come vuoi.

    Lungi da me "cantarmela e suonarmela", sono apertissimo a tutti i consigli e ben conscio dei miei limiti, soprattutto nell'esporre la situazione.

    Allora, ricapitoliamo per cercare di porre fine all'odissea.

    In questo momento funziona tutto ed il problema di mancata schedulazione segnalato ieri era sicuramente dovuto al fatto che l'utente che lanciava il job era l'Administrator locale invece di quello di dominio (svista mia nell'importazione del job dal file XML).

    Nel virtual host ho abilitato solo l'autenticazione integrata e la possibilità di relay e connessione solo da localhost (127.0.0.1).

    Questo è il batch schedulato al verificarsi di un evento (fine backup):

    powershell C:\Users\Administrator\Documents\EmailNotification\backupok.ps1

    E questo è l'attuale contenuto dello script:

    $pwd = Get-Content
    C:\Users\Administrator\Documents\EmailNotification\cred.txt |
    ConvertTo-SecureString
    $crd = New-Object -TypeName System.Management.Automation.PSCredential
    ("DOMINIO\Administrator",$pwd)
    send-mailmessage -from administrator@mittente.it -to
    report@destinatario.it -subject 'Report Backup' -body 'Il backup del
    server si è completato correttamente.' -smtpserver localhost
    -Credential $crd -Encoding ([System.Text.Encoding]::UTF8)
    

    Sul perchè prima funzionasse l'autenticazione anche senza specificare le credenziali nello script, posso solo ipotizzare che venissero automaticamente usate quelle dell'utente che lancia il batch.

    lunedì 17 marzo 2014 11:32