none
Exchange 2007 su SBS 2008 impossibile avviare "Microsoft Exchange Information Store" RRS feed

  • Domanda

  • Salve a tutti.

    Nella nostra azienda abbiamo

    • Server 1 SBS 2008
    • Server 2 Windows 2008 Ent R2 con Forefront TMG installato.

    Il dominio è stato recentemente migrato da Server 2003 R2 a SBS (Server1). In seguito è stato aggiunto da zero il Server 2 con TMG installato e configurato come firewall di confine per consentire accesso alla rete esterna e interna.

    Per cui

    LAN 192.168.1.1

    WAN 10.10.10.2 (dove il router è 10.10.10.1)

    Fin qui tutto bene se non fosse che non riesco a far ripartire Exchange in seguito ad un riavvio della server 1.

    La stessa cosa mi era già successa prima di migrare il dominio e aggiornare il server 1. Il problema è rimasto in sospeso perché in quell'occasione ho deciso di rivedere un po' tutta la struttura hardware/software.

    Ora si ripropone puntuale non appena implemento TMG.

    Ho 3 eventi ricorrenti che riporto di seguito:

     

    1) Log Name:      Application
    Source:        MSExchange Autodiscover
    Date:          06/09/2010 22.00.28
    Event ID:      1
    Task Category: Web
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SBS-SERVER.avc.local
    Description:
    Unhandled Exception "The Exchange Topology service on server localhost did not return a suitable domain controller."
    Stack Trace:    at Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetConfigDCInfo(Boolean throwOnFailure)
       at Microsoft.Exchange.Data.Directory.TopologyProvider.PopulateConfigNamingContexts()
       at Microsoft.Exchange.Data.Directory.TopologyProvider.GetConfigurationNamingContext()
       at Microsoft.Exchange.Data.Directory.ADSession.GetConnection(String preferredServer, Boolean isWriteOperation, Boolean isNotifyOperation, ADObjectId& rootId)
       at Microsoft.Exchange.Data.Directory.ADGenericReader.GetNextResultCollection(Type controlType, DirectoryControl& responseControl)
       at Microsoft.Exchange.Data.Directory.ADPagedReader`1.GetNextResultCollection()
       at Microsoft.Exchange.Data.Directory.ADPagedReader`1.GetNextPage()
       at Microsoft.Exchange.Data.Directory.ADPagedReader`1.<GetEnumerator>d__0.MoveNext()
       at Microsoft.Exchange.Autodiscover.Providers.Outlook.OutlookAutoDiscoverProvider.SimpleConfigCache`2.Freshen(ADSystemConfigurationSession session)
       at Microsoft.Exchange.Autodiscover.Providers.Outlook.OutlookAutoDiscoverProvider.UpdateCacheCallback(Object stateInfo)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Autodiscover" />
        <EventID Qualifiers="49152">1</EventID>
        <Level>2</Level>
        <Task>2</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-09-06T20:00:28.000Z" />
        <EventRecordID>45099</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SBS-SERVER.avc.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>The Exchange Topology service on server localhost did not return a suitable domain controller.</Data>
        <Data>   at Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetConfigDCInfo(Boolean throwOnFailure)
       at Microsoft.Exchange.Data.Directory.TopologyProvider.PopulateConfigNamingContexts()
       at Microsoft.Exchange.Data.Directory.TopologyProvider.GetConfigurationNamingContext()
       at Microsoft.Exchange.Data.Directory.ADSession.GetConnection(String preferredServer, Boolean isWriteOperation, Boolean isNotifyOperation, ADObjectId&amp; rootId)
       at Microsoft.Exchange.Data.Directory.ADGenericReader.GetNextResultCollection(Type controlType, DirectoryControl&amp; responseControl)
       at Microsoft.Exchange.Data.Directory.ADPagedReader`1.GetNextResultCollection()
       at Microsoft.Exchange.Data.Directory.ADPagedReader`1.GetNextPage()
       at Microsoft.Exchange.Data.Directory.ADPagedReader`1.&lt;GetEnumerator&gt;d__0.MoveNext()
       at Microsoft.Exchange.Autodiscover.Providers.Outlook.OutlookAutoDiscoverProvider.SimpleConfigCache`2.Freshen(ADSystemConfigurationSession session)
       at Microsoft.Exchange.Autodiscover.Providers.Outlook.OutlookAutoDiscoverProvider.UpdateCacheCallback(Object stateInfo)</Data>
      </EventData>
    </Event>

    2) Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          06/09/2010 22.02.37
    Event ID:      2102
    Task Category: Topology
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SBS-SERVER.avc.local
    Description:
    Process MAD.EXE (PID=1696). All Domain Controller Servers in use are not responding:
    SBS-SERVER.avc.local
     
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange ADAccess" />
        <EventID Qualifiers="49156">2102</EventID>
        <Level>2</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-09-06T20:02:37.000Z" />
        <EventRecordID>45112</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SBS-SERVER.avc.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>MAD.EXE</Data>
        <Data>1696</Data>
        <Data>SBS-SERVER.avc.local
    </Data>
      </EventData>
    </Event>

    3) Log Name:      Application
    Source:        MSExchange ADAccess
    Date:          06/09/2010 23.02.42
    Event ID:      2114
    Task Category: Topology
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SBS-SERVER.avc.local
    Description:
    Process MAD.EXE (PID=1696). Topology discovery failed, error 0x80040a02 (DSC_E_NO_SUITABLE_CDC). Look up the Lightweight Directory Access Protocol (LDAP) error code specified in the event description. To do this, use Microsoft Knowledge Base article 218185, "Microsoft LDAP Error Codes." Use the information in that article to learn more about the cause and resolution to this error. Use the Ping or PathPing command-line tools to test network connectivity to local domain controllers.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange ADAccess" />
        <EventID Qualifiers="49156">2114</EventID>
        <Level>2</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2010-09-06T21:02:42.000Z" />
        <EventRecordID>45499</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SBS-SERVER.avc.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>MAD.EXE</Data>
        <Data>1696</Data>
        <Data>80040a02</Data>
        <Data>DSC_E_NO_SUITABLE_CDC</Data>
      </EventData>
    </Event>

    Grazie, Lorenzo.

    lunedì 6 settembre 2010 21:07

Risposte

  • Ciao Andrea, grazie per la risposta.

    In verità ho eseguito il BPA di SBS e ho corretto parecchie cosine qua e la ereditate dalla migrazione.

    Niente a che fare direttamente con Exchange comunque. Ho lanciato anche il BPA di exchange e ho sistemato anche gli avvisi principali tra cui installare la SP3.

    Il dato saliente è che per il momento ho deciso di rinunciare ad implementare TMG nella mia rete.

    Quindi ho rimosso il server 2 dalla rete e ho ricollegato il server 1 al router: exchange funziona di nuovo!

    In ogni caso aprire questo post (e di conseguenza la tua risposta) mi ha aiutato a sistemare un po di zozzerie residue nella configurazione di SBS.

    Ciao e grazie ancora.

    Lorenzo Ceccaioni

    • Contrassegnato come risposta Anca Popa giovedì 9 settembre 2010 08:11
    mercoledì 8 settembre 2010 19:15

Tutte le risposte

  • Ciao Lorenzo, 

    Hai eseguito il BPA di SBS 2008?

    Aumenta il DL e vediamo di capire qualcosa in più

     

    Set-Eventloglevel -Identity "MSExchange ADAccess\General" -Level expert

    Set-Eventloglevel -Identity "MSExchange ADAccess\Cache" -Level expert

    Set-Eventloglevel -Identity "MSExchange ADAccess\Topology" -Level expert

    Set-Eventloglevel -Identity "MSExchange ADAccess\LDAP" -Level expert

    Set-Eventloglevel -Identity "MSExchange ADAccess\Configuration" -Level expert

     


    Andrea Gallazzi
    http://www.andreagallazzi.com
    This posting is provided "AS IS" with no warranties, and confers no rights.
    martedì 7 settembre 2010 07:26
  • Ciao Andrea, grazie per la risposta.

    In verità ho eseguito il BPA di SBS e ho corretto parecchie cosine qua e la ereditate dalla migrazione.

    Niente a che fare direttamente con Exchange comunque. Ho lanciato anche il BPA di exchange e ho sistemato anche gli avvisi principali tra cui installare la SP3.

    Il dato saliente è che per il momento ho deciso di rinunciare ad implementare TMG nella mia rete.

    Quindi ho rimosso il server 2 dalla rete e ho ricollegato il server 1 al router: exchange funziona di nuovo!

    In ogni caso aprire questo post (e di conseguenza la tua risposta) mi ha aiutato a sistemare un po di zozzerie residue nella configurazione di SBS.

    Ciao e grazie ancora.

    Lorenzo Ceccaioni

    • Contrassegnato come risposta Anca Popa giovedì 9 settembre 2010 08:11
    mercoledì 8 settembre 2010 19:15
  • Ciao,

    Ti ringrazio per le notizie, ritengo che siano molto utili per tutti noi e soprattutto per gli altri membri della community che potrebbero essere nella stessa situazione.

    Con l'occasione aggiungo i miei ringraziamenti a Andrea per la sua risposta e per tutto quello che fa per questo forum Exchange Server!!

    Ciao.  


    Anca Popa
    Follow ForumTechNetIt on Twitter
    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie Microsoft. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte di Microsoft.
    giovedì 9 settembre 2010 08:11