none
Server 2008 R2 - Operazione pianificate non si avviano RRS feed

  • Domanda

  • Salve a tutti, ho un problema con operazioni pianificate che devo impostare sul server in oggetto. La pianificata lancia un batch che fa partire un elaborazione del gestionale che scrive un file in cartella.

    Se doppio clic sul file .bat lancio correttamente e i file si creano. Se la pianificata la lancio manualmente con il "run" parte senza problemi e crea i file. Se la schedulo di li a poco si avvia e parte creando file come da manuale.

    Il problema sta nel quando l'utente è disconnesso, in questo caso l'amministratore di dominio che è anche il proprietario della pianificata non ne vuole sapere di partire e genera errore.

    Ho fatto decine di prove con esecuzione da administrator,da gruppo administrators, da altro utente di dominio ma nulla.

    Penso il problema sia che nello script viene usata una unità di rete, che non capisco se debba essere mappata nello script o da altra parta...

    sono proprio nuovo di 2008 mi starà sfuggendo un flag da qualche parte, qualcuino mi sa aiutare?

    Grazie

    --

    Jett

    lunedì 11 aprile 2011 17:18

Risposte

  • giusto per chiudere il discorso segnalo che era un problema di script per via delle unità di rete da mappare e le variabili settate dal gestionale.

    riconfigurando gli script puntando tutti i percorsi in locale ora funziona.

    Grazie

    Saluti

     

    • Contrassegnato come risposta Anca Popa venerdì 15 aprile 2011 07:50
    venerdì 15 aprile 2011 07:30

Tutte le risposte

  • puoi postare lo script?

    Inoltre: quale errore viene generato?


    Adriano - MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]adcoop.it
    lunedì 11 aprile 2011 18:24
  • Inoltre:

    To run a task under the security context of a specified account (regardless of whether that account is logged on), click Change User or Group, enter credentials for the account, and then click Run whether user is logged on or not. (http://technet.microsoft.com/en-us/library/dd851678.aspx)

    Some tasks will only run when a certain user is logged on, depending on a task's security options. If a scheduled task does not run when you expect it to run, ensure that the task's security options are set correctly. For more information, see Task Security Context and Change an Existing Task.

    In particolare questo ultimo link (http://technet.microsoft.com/en-us/library/cc722152.aspx) dovrebbe rispondere al tuo problema


    Adriano - MCITP Server Administrator MCTS Windows Server 2008 Applications Infrastructure, Configuration adriano.mariolini[at]adcoop.it
    • Proposto come risposta Adriano Mariolini lunedì 11 aprile 2011 18:32
    • Modificato Anca Popa mercoledì 13 aprile 2011 14:48 formattazione sorgente HTML
    • Proposta come risposta annullata Anca Popa venerdì 15 aprile 2011 07:50
    lunedì 11 aprile 2011 18:31
  • Eccomi, grazie per le risposte, sto per andare a leggermi i vari link che mi avete postato, intanto copio sotto anche lo script.

    Ora come ora è impostato per connettere l'unità di rete e poi rimuoverla alla fine (ma non ho ancora capito se serve...)

    ----------------------
    net use m: \\server07\sd
    SET DLC=D:\PRO
    c:
    cd \work
    cd d:\
    d:
    cd PRO\HTM\bin\
    prowin32.exe -ininame M:\test\aka\ak.ini -pf M:\test\aka\ak.pf -param "A=M:\test\aka\AK.TXT,E=1,O=mario,T=Server,P=jcodebat.p,I=REPORT"
    net use m: /delete /yes
    ------------------------

    Saluti

    martedì 12 aprile 2011 08:34
  • giusto per chiudere il discorso segnalo che era un problema di script per via delle unità di rete da mappare e le variabili settate dal gestionale.

    riconfigurando gli script puntando tutti i percorsi in locale ora funziona.

    Grazie

    Saluti

     

    • Contrassegnato come risposta Anca Popa venerdì 15 aprile 2011 07:50
    venerdì 15 aprile 2011 07:30