none
Certificato Star RRS feed

  • Domanda

  • Salve a tutti,

    in un exchange 2010 ho installato un certificato Star (*.dominio.it), quando però apro outlook mi appare l'avviso relativo al certificato che mi allerta che il nome non è coerente con il nome del server che si presenta con (server.dominio.local).

    Il problema è che sul certificato non posso aggiungere il SAN relativo al dominio interno ma solo relativi al dominio.it.

    Coma posso risolvere il problema?

    Grazie

    Michele

     

    • Tipo modificato Anca Popa mercoledì 1 giugno 2011 06:23 in attesa di ulteriori delucidazioni
    • Tipo modificato Anca Popa mercoledì 8 giugno 2011 10:53 domanda con soluzione
    mercoledì 25 maggio 2011 09:24

Risposte

  • Ciao,

    non avevo provato perchè il problema era relativo a pc all'interno della intranet che teoricamente non avrebbero bisogno della configurazione di OA, ho però verificato che l'autodiscover configura comunque il servizio (anche se deseleziono il checkbox nella scheda connessioni, all'avvio successivo lo trovo nuovamente selezionato).

    Ho lanciato il test di autoconfigurazione e ho notato che gli unici 2 servizi che puntano al server in intranet sono l'Availability Service e OOF, ho provato a modificare l'InternalURL del Web Services, mettendo l'indirizzo relativo al dominio.it (correttamente risolto anche all'interno della intranet) , dopo aver riavviato l'IIS aprendo Outlook, non è apparso il warning del certificato e nel test di configurazione ora gli indirizzi di Availability Service e OOF puntano all'indirizzo domain.it quindi il problema sembrerebbe risolto.

    Grazie a tutti per l'aiuto.

    Michele

     

     

    • Contrassegnato come risposta Anca Popa mercoledì 8 giugno 2011 10:53
    mercoledì 8 giugno 2011 08:50

Tutte le risposte

  • Ciao Michele,

    Il tuo quesito è ancora aperto. Potresti per cortesia farci sapere se ti serve ancora qualche dritta, oppure sei riuscito a risolvere nel frattempo?

    Grazie in anticipo di un tuo aggiornamento,

    Saluti,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    martedì 31 maggio 2011 13:26
  • Ciao , il problema non è ancora stato risolto, aprendo outlook appare l'avviso che indica che il nome interno del server , non corrisponde al nome del certificato (*.dominio.com)

     

    Qualche suggerimento?

     

    Grazie 

    venerdì 3 giugno 2011 11:52
  • Ciao Michele, perchè dici che non puoi cambiare il certificato?

     

    Saluti

    Nino

    venerdì 3 giugno 2011 12:06
  • Ciao Michele,
    se stiamo parlando di una connessione tramite outlook anywhere allora devi lanciare il seguente comando:

    Set-OutlookProvider EXPR -CertPrincipalName msstd:*.azienda.it

    Inoltre bisogna verificare qual è l'url (solitamente è causato dall'autodiscover uri) incriminato
    Per capire qual è l'url incrominato, tasto dx right click sull'icona di outlook nella try bar test email autoconfiguration. Togli tutti i flag e lascia autodiscover.
    Da li vedi qual è l'url o l'uri che non va

    Saluti
    .m

    Massimiliano Luciani

    venerdì 3 giugno 2011 12:07
  • Ciao Nino,

    il certificato generato da Digicert è un certificato star (*.dominio.com), ho già contattato digicert chiedendio se ci fosse modo di aggiungere nel certificato un SAN contenente il nome locale del server (server.dominio.local) ma mi hanno risposto che nei certificati di tipo star si possono aggiungere solamente sottodomini ma non i domini locali.

    Quindi nel certificato installato nel server di exchange ho solamente *.dominio.com valido per autodiscovery.dominio.com, mail.dominio.com ma non x nomeserver.dominio.local, per cui aprendo outlook all'interno dell'azienda appare il warning di cui parlavo nei post precedenti!

     

    Michele

    venerdì 3 giugno 2011 13:07
  • Scusa Michele,

    Leggendo gli ultimi interventi sul thread, dei quali ringrazio Nino e Massimiliano, volevo farti una domanda: non ho capito bene dal tuo post se hai anche provato a seguire il consiglio di Massimiliano?

    Grazie in anticipo di qualsiasi delucidazione,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    lunedì 6 giugno 2011 10:57
  • Ciao,

    non avevo provato perchè il problema era relativo a pc all'interno della intranet che teoricamente non avrebbero bisogno della configurazione di OA, ho però verificato che l'autodiscover configura comunque il servizio (anche se deseleziono il checkbox nella scheda connessioni, all'avvio successivo lo trovo nuovamente selezionato).

    Ho lanciato il test di autoconfigurazione e ho notato che gli unici 2 servizi che puntano al server in intranet sono l'Availability Service e OOF, ho provato a modificare l'InternalURL del Web Services, mettendo l'indirizzo relativo al dominio.it (correttamente risolto anche all'interno della intranet) , dopo aver riavviato l'IIS aprendo Outlook, non è apparso il warning del certificato e nel test di configurazione ora gli indirizzi di Availability Service e OOF puntano all'indirizzo domain.it quindi il problema sembrerebbe risolto.

    Grazie a tutti per l'aiuto.

    Michele

     

     

    • Contrassegnato come risposta Anca Popa mercoledì 8 giugno 2011 10:53
    mercoledì 8 giugno 2011 08:50
  • Ciao Michele,

    Sono felice che sei venuto a capo del problema e ti ringrazio di aver condiviso la tua esperienza con la community.

    Un saluto,


    Anca Popa Follow ForumTechNetIt on Twitter

    Buon Exchange a tutti!

    Microsoft offre questo servizio gratuitamente, per aiutare gli utenti e aumentare il database dei prodotti e delle tecnologie. Il contenuto viene fornito “così come è” e non comporta alcuna responsabilità da parte dell'azienda

    mercoledì 8 giugno 2011 10:53